FrankMurphy
Contributor
Contributor

Keep getting certificate 'Security Alert' pop-ups - Pro 15.5 on Win8.1

Jump to solution

I keep getting 10s of these pop-ups on my Win8.1 host when I'm running Workstation.

It happens irrespective of whether I have a VM running or not.

I've added the certificate to the root store.

I keep clicking yes - but they keep coming up.

Please see attached png schreenshots.

Any help would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

Perhaps there's more info in the Windows event log.

AFAIK the only part of workstation that uses a self generated certificate is the shared VMs feature.

If you are not using that, most people do not use it, then you can disable it.

Menu -> Edit -> Preferences -> Shared VMs -> click the "Changed Settings" button and Allow in the Windows User Account Control popup that follows it.

Then click the "Disable Sharing" button.

Hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
5 Replies
wila
Immortal
Immortal

Hi,


When does this happen? Your screenshot does not show any alerts, just some parts of a certificate.

This is when visiting a website in your browser?

If so, what website and show us the certificate of that website, including the URL's

edit: Correction, it shows one certificate alert, but no details on what that alert is for.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
FrankMurphy
Contributor
Contributor

Hi Wil

Thanks for replying.

When does this happen?

Happens intermittently whenever I start Workstation up.

This is when visiting a website in your browser?

No. I get the alert on my host, not related to any website. With or without a browser being open.

I was thinking it may have something to do with some background service of Workstation?

it shows one certificate alert, but no details on what that alert is for.

That's partly the problem. Other than the 'Security Alert' I don't get any other info. Can I look anywhere to get some further info? Workstation or host?

0 Kudos
wila
Immortal
Immortal

Hi,

Perhaps there's more info in the Windows event log.

AFAIK the only part of workstation that uses a self generated certificate is the shared VMs feature.

If you are not using that, most people do not use it, then you can disable it.

Menu -> Edit -> Preferences -> Shared VMs -> click the "Changed Settings" button and Allow in the Windows User Account Control popup that follows it.

Then click the "Disable Sharing" button.

Hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
FrankMurphy
Contributor
Contributor

Thanks Wil.

Disabling shared VMs seems to have done it.

Still early days, I'll keep an eye on it for a few more days just to be sure then accept yours as the answer.

Thanks again

0 Kudos
wila
Immortal
Immortal

You're welcome!

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos