Faize
Enthusiast
Enthusiast

Is there a global setting to prevent VMs from automatically connecting to new USB devices?

Just now, I plugged in a (Windows-formatted) external HDD. The (Linux) VM proceeded to try and take control of it, resulting in the host freezing for several minutes until I gave up and literally pulled the plug.

I understand that this can be configured on a VM-by-VM basis under Settings -> USB Controller -> uncheck the "Automatically connect new USB devices" checkbox, but is there a global override where I can disable this for all VMs, regardless of what the VM-specific setting says?

0 Kudos
1 Reply
bluefirestorm
Virtuoso
Virtuoso

You could try putting the equivalent entry in the vmx into the config file. Some vmx configuration dictionary entries can be applied host wide by adding it into the config file instead of configuring it one by one at the VM level. But I don't know the precedence/conflict resolution rules (e.g. if the vmx configuration entry is a different value than the config which one takes precedence?).

So in this case try putting

usb.generic.autoconnect = "FALSE" to the config file.

For a Windows host, the file would be C:\ProgramData\VMware\VMware Workstation\config.ini

For a Linux host, the file would be /etc/vmware/config

0 Kudos