oaklodge
Enthusiast
Enthusiast

Install of 8 fails with error 25028 in vmwarevmcisockets64.msi

Had 7.1 installed, removed it, rebooted machine then tried to install 8.

Got the error 25028 in vmwarevmcisockets64.msi and the install failed.

0 Kudos
8 Replies
viderbit
Contributor
Contributor

Same error and for me (clean Windows XP SP3).

Why the hell is that?

Error 25028 indicate that we have a problem with Microsoft Application Virtualization Desktop Client. This is enterprise service?!?!?!?

Can you just explain or give us temporary fix please!

I need Vmware WS8 trial to make a EDU presentation.

0 Kudos
jbudreau
VMware Employee
VMware Employee

It looks like you are hitting the same issue as this thread - http://communities.vmware.com/message/1831154

By any chance are you runnging the program "AppVerifier" on your machine?

0 Kudos
pavd2000
Contributor
Contributor

---------------------------
VMware-workstation-full-8.0.2-591240
---------------------------
The MSI 'c:\temp\vmware_1330637056\vmwarevmcisockets64.msi' failed.
---------------------------
ОК 
---------------------------

I think that QA is very bad in Vmware (5 years ago all was OK). WTF?

0 Kudos
xiaoshu2012
Contributor
Contributor

In fact, the solution is very simple, turn off all your anti-virus software
And then install it

0 Kudos
continuum
Immortal
Immortal

it really is not that easy - you can get this problem even with no antivirus software installed

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
xiaoshu2012
Contributor
Contributor

I first installed, the installation can not
Tip: Install of 8 fails with error 25028 in vmwarevmcisockets64.msi
But when I turn off the antivirus software, the installation was successful

0 Kudos
analytik2
Contributor
Contributor

Same problem, no AV, quit all programs, stopped all unnecessary services, rebooted a couple of times, reinstalled Vcredist a couple of times, still to no avail.

tools-build-462819: 05/06/12 10:22:46 Begin Logging
tools-build-462819: 05/06/12 10:22:46 --- VMInstallVMCIDriver() : Installing VMCI driver
tools-build-462819: 05/06/12 10:22:46 Getting Property CustomActionData = G:\Program Files\Common Files\VMware\Drivers\vmci\device\;2;%SystemRoot%\system32\vsocklib.dll
tools-build-462819: 05/06/12 10:22:46 Failed to uninstall vsock provider 0
tools-build-462819: 05/06/12 10:22:46 Failed to uninstall 32 wow vsock provider 0
tools-build-462819: 05/06/12 10:22:46 Util_GetKeyValueStringW
tools-build-462819: 05/06/12 10:22:46 Cannot open the registry HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware Drivers: 2
tools-build-462819: 05/06/12 10:22:46 Cannot query key value HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\Wnd: 2
tools-build-462819: 05/06/12 10:22:46 Failed to get window text: -536870399
tools-build-462819: 05/06/12 10:22:46 Installing driver with INF: "G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf", flags: 1
tools-build-462819: 05/06/12 10:22:46 Found "G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf"
tools-build-462819: 05/06/12 10:22:46 Attempting to install HID1: PCI\VEN_15AD&DEV_0740&SUBSYS_074015AD
tools-build-462819: 05/06/12 10:22:46 HID1 install status: 0xe000020b. The device instance does not exist in the hardware tree.
tools-build-462819: 05/06/12 10:22:46 Attempting to prepare OS for device that matches INF: G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf
tools-build-462819: 05/06/12 10:22:46 Attempting to pre-install inf file: "G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf"
tools-build-462819: 05/06/12 10:22:46 Successfully installed inf
tools-build-462819: 05/06/12 10:22:46 Success: Reboot not required
tools-build-462819: 05/06/12 10:22:46 unicode provider path %SystemRoot%\system32\vsocklib.dll
tools-build-462819: 05/06/12 10:22:46 Succesfully installed 64 bit vsock transport provider
tools-build-462819: 05/06/12 10:22:46 Cannot query key value HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\Wnd: 2
tools-build-462819: 05/06/12 10:22:46 Failed to get window text: 0
tools-build-462819: 05/06/12 10:22:46 Installing driver with INF: "G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf", flags: 1
tools-build-462819: 05/06/12 10:22:46 Found "G:\Program Files\Common Files\VMware\Drivers\vmci\device\VMCI.inf"
tools-build-462819: 05/06/12 10:22:46 Attempting to install HID1: ROOT\VMWVMCIHOSTDEV
tools-build-462819: 05/06/12 10:22:47 HID1 install status: 0x00000002. The system cannot find the file specified.
tools-build-462819: 05/06/12 10:22:47 Failed to install driver: 0x00000002. The system cannot find the file specified.
tools-build-462819: 05/06/12 10:22:47 Posting error message 25028
tools-build-462819: 05/06/12 10:22:54 MsiProcessMessage returned: 0
tools-build-462819: 05/06/12 10:22:54 End Logging
tools-build-462819: 05/06/12 10:22:54 Begin Logging
tools-build-462819: 05/06/12 10:22:54 --- VMUninstallVMCIDriver() : Uninstalling VMCI driver
tools-build-462819: 05/06/12 10:22:54 Successfully uninstalled vsock provider
tools-build-462819: 05/06/12 10:22:54 Successfully uninstalled 32 bit vsock wow provider
tools-build-462819: 05/06/12 10:22:54 Util_GetKeyValueStringW
tools-build-462819: 05/06/12 10:22:54 Util_GetKeyValueStringW(HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware Drivers\VmciHostDevInst) = "ROOT\VMWVMCIHOSTDEV\0000"
tools-build-462819: 05/06/12 10:22:54 Cannot query key value HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\Wnd: 2
tools-build-462819: 05/06/12 10:22:54 Failed to get window text: -536870399
tools-build-462819: 05/06/12 10:22:54 Migrating device ID PCI\VEN_15AD&DEV_0740&SUBSYS_074015AD to the best driver
tools-build-462819: 05/06/12 10:22:54 Deleting D:\Windows\system32\drivers\VMCI.sys
tools-build-462819: 05/06/12 10:22:54 Did not find file/directory: "D:\Windows\system32\drivers\VMCI.sys"
tools-build-462819: 05/06/12 10:22:54 Already removed: D:\Windows\system32\drivers\VMCI.sys
tools-build-462819: 05/06/12 10:22:54 End Logging

0 Kudos
continuum
Immortal
Immortal

The uninstaller often does not remove the registry-keys for this driver.

After an uninstall-attempt reboot - next open regedit and search for "vmci"
You may need to modify permissions on a few keys to be able to delete the rests.

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos