PackElend
Enthusiast
Enthusiast

Incorrect Version of Driver "vmci.sys" not Fixed by Reinstalling Workstation Player 14.1.3 build-9474260 (Win 10 Enterprise 1703)

Jump to solution

i reinstalled vmware Tools and Workstation Player  but I still get the error:

It could be same as desrtcibed here Incorrect Version of Driver "vmci.sys" not Fixed by Reinstalling Workstation 10.0.4

Resinstalling the vmci driver in Windows isn't an option as I cannot find the hardware item in the device manager.

The only workaround is to turning vmci0 value to false is not at all a good approach.

0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

Did you reboot between uninstalling VMware Player and re-install?

Especially if you have driver version issues that is a required step.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
7 Replies
continuum
Immortal
Immortal

Workaround:
edit the vmx-file for all VMs and disable vmci


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
wila
Immortal
Immortal

Hi,

Did you reboot between uninstalling VMware Player and re-install?

Especially if you have driver version issues that is a required step.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
a_p_
Leadership
Leadership

Please search your C: drive for "vmci.sys" to see whether it it is stored in different directories with different versions .


André

0 Kudos
PackElend
Enthusiast
Enthusiast

Please search your C: drive for "vmci.sys" to see whether it it is stored in different directories with different versions .

There are three places. I assume one and two are only backups created by VMware.

pastedImage_0.png

C:\Program Files\Common Files\VMware\Drivers\vmci\device\Win8

pastedImage_6.png

C:\Windows\System32\DriverStore\FileRepository\vmci.inf_amd64_64189b30c198ca23

pastedImage_4.png

C:\Windows\System32\drivers

pastedImage_3.png

0 Kudos
PackElend
Enthusiast
Enthusiast

edit the vmx-file for all VMs and disable vmci

I mentioned that workaround in my original post but also said it isn't recommended

0 Kudos
PackElend
Enthusiast
Enthusiast

Did you reboot between uninstalling VMware Player and re-install?

Especially if you have driver version issues that is a required step.

that solved it, you are a genius

0 Kudos
wila
Immortal
Immortal

LOL, far from a genius.

Down here we call it experience.

Glad to hear it helped.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos