WhiteKnight
Hot Shot
Hot Shot

In VMs, Microsoft Edge renders its menu with wrong blend mode

Jump to solution

In all my virtual machines (VMware Workstation on Windows 10x64), Microsoft Edge renders its menu with a strange blend mode (I suspect it's "Multiply"):

MS Edge blend mode.png

 

I cannot read anything of that menu.

What can I do to have Microsoft Edge render its menu correctly?

Your answers are appreciated.



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

The issue you're seeing is a known issue.

It has been discussed many times for the various browsers (google chrome and even Firefox).

The issue has to do with hardware rendering.

The fix is to either turn off 3D for the VM completely, but the better solution is to turn it off in MS Edge.

In order to do so, in MS Edge go to settings -> select "System and Performance" and disable "hardware acceleration".

wila_0-1655982457379.png

After doing that, the problems should be resolved.

If you are not able to access settings in MS Edge, then you can also open the page "edge://settings/system" to get to the 'Hardware acceleration' settings.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

4 Replies
wila
Immortal
Immortal

Hi,

The issue you're seeing is a known issue.

It has been discussed many times for the various browsers (google chrome and even Firefox).

The issue has to do with hardware rendering.

The fix is to either turn off 3D for the VM completely, but the better solution is to turn it off in MS Edge.

In order to do so, in MS Edge go to settings -> select "System and Performance" and disable "hardware acceleration".

wila_0-1655982457379.png

After doing that, the problems should be resolved.

If you are not able to access settings in MS Edge, then you can also open the page "edge://settings/system" to get to the 'Hardware acceleration' settings.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
WhiteKnight
Hot Shot
Hot Shot

Thank you, @wila,  for sharing your very valuable information.

Out of curiosity: Will the next version of VMware Workstation remedy this situation? I'm doing all my work in VMs and I'd appreciate getting the most out of it.



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos
wila
Immortal
Immortal

Hi,

I don't work for VMware.. so I have no idea what they will address or not.

Having said that.. this has been an issue for years and years, so I would not have my hopes up on this getting addressed any day soon.

This is probably also an item where the goal is changing. Browsers will try to support the latest hardware features and VMware is chasing that as well, although much further behind due to the complexity of providing hardware accelerated virtual graphics.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
WhiteKnight
Hot Shot
Hot Shot

Ah, yes! Thanks for clarifying!

@VMware: All these 3D issues would easily be resolved if you decided to implement GPU Passhthrough in VMware Workstation …



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos