blastwave
Enthusiast
Enthusiast

I was thinking of an upgrade to Workstation 14 Pro but the VMware store looks to be broken?

Not sure if anyone else sees the VMware store as being "broken" but I seem to see the main page but all the CSS has been lost.

vmware_store_broken.png

Anyone else seeing that ?

Tags (1)
0 Kudos
8 Replies
bluefirestorm
Virtuoso
Virtuoso

I get the "broken" VMware Store site (similar to your screenshot) when I use Firefox Private Browsing mode.

Chrome incognito looked OK; as is Edge.

Firefox private browsing mode seems to break more sites than Chrome incognito.

0 Kudos
vcallaway
Enthusiast
Enthusiast

There were several VMware sites intermittently down today. They all appear to be working correctly as of now.

0 Kudos
blastwave
Enthusiast
Enthusiast

I am using Firefox 57.0.1 on Red Hat Enterprise Linux 7.4 with no particular special "mode" and the vmware store appears quite broken.

# date

Mon Dec 18 23:14:34 GMT 2017

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

From your screenshot, there is a "shield" icon to the left of the "green lock" in the address/URL bar; which suggests that you are using Private Browsing mode or Private Window. The shield icon does not appear when regular browsing is used.

The VMware online store only appears to be broken with Firefox (on a macOS, Windows 10) when Private Browsing mode is used; otherwise it appears fine just like Chrome, Safari, and Edge.

pastedImage_1.png

pastedImage_0.png

0 Kudos
blastwave
Enthusiast
Enthusiast

I am not using "private browsing mode" at all. I am not even aware it exists however, yes, I do see some spooky stuff as you say :

vmware_store_broken2.png

Gets even better if we enable some add-ons that protect my system from trash :

vmware_store_broken.png

So therein lay the entire problem most likely.

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

Perhaps it is the Preferences settings for Tracking Protection and/or the Privacy Badger add-on make the browsing session behave like "private mode".

I'll leave it to you whether to use another browser or tone down the privacy settings at the very least for the session where the website/webpages appear broken. As I said before, more sites/webpages seem to break with Firefox private mode than Chrome incognito mode or Edge private mode.

0 Kudos
blastwave
Enthusiast
Enthusiast

I hate being that "special user" but every other complex site, social media, new site, all of them work fine except ...

vmware_store_broken3.png

Pretty special site there.

0 Kudos
mfelker
Expert
Expert

If it is still down tomorrow you can try to call Sales directly, complain bitterely about what a good customer you are (assuming you've b ought products before and have a customer id) and escalate as high as you can go.   You just might be rewarded with a free license to apply to the trial version.   Sounds crazy but it worked for in getting a WS 12 and I was a very happy camper

0 Kudos