Highlighted
Contributor
Contributor

Hyper-V or Device/Credential Guard problem

I applied the solution ways in the link but I couldn't succeed again. Who has a different opinion?

I made Hyper-V disable, again I encountered the same error.

Your host does not meet minimum requirements to run VMware Workstation with Hyper-V or Device/Credential Guard enabled. Refer to VMware KB article 76918 at https://kb.vmware.com/kb/76918 for more details.

sorun1.PNG

Tags (1)
9 Replies
Highlighted
User Moderator
User Moderator

What version of Windows 10 is your host?

0 Kudos
Highlighted
Contributor
Contributor

If and only if you are on 15.5.5 of Vmware workstation pro and your host is on Windows 10 version 2004, you need to go into the vm settings try under the hardware >> processors setting the virtualization (Intel or AMD) and the virtualization counters if your guest is any version of Windows.

In addition under the options tab >> advanced, make sure UEFI and secure boot are both checked for Windows 10 guests.  For windows 7 guest make sure the BIOS instead of UEFI is selected.  Prior versions may also need that BIOS setting also enabled.

I have not yet tried either "Credential guard" or "Device guard" active on the host OS.  Please be aware to this point, I have seen nothing about this.  I have given you the settings that work in my situation where the Host OS is Windows 10 version 2004 and the guests are Windows 10 version 1909 and Windows 7 service pack 1.

I hope this helps.

I forgot to note that I do have hyper-v installed on the host!

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi,

Thank you for posting your query in community.

Per WS user guide https://docs.vmware.com/en/VMware-Workstation-Pro/15.0/workstation-pro-15-user-guide.pdf

Running Workstation on a Hyper-V Enabled Host is available in 15.5.5 version of Workstation Pro.

System Requirements

  • Processor Requirements for Host System
    • Intel Sandy Bridge or newer CPU
    • AMD Bulldozer or newer CPU

  • Supported Host Operating Systems
    • Windows 10 20H1 build 19041.264 or newer

Nested VMs/PMCs/RTM and HLE/PKU are not supported so far.

Could you please try to change the Hyper-V status as follow:

How to change Hyper-V status

  • By Windows Powershell tools to Enable/Disable Hyper-V
    •      Download Windows Powershell tools

               dgreadiness_v3.6 is a tool that Microsoft published to enabled/disable Device Guard/Credential Guard

               -- https://www.microsoft.com/en-us/download/details.aspx?id=53337

    •      Execute dgreadiness_v3.6  scripts with proper parameter by administrator user

                    Set-ExecutionPolicy Unrestricted if needed

     If Execution-Policy is not already set to allow running script, then you should manually set it as below and then use the readiness script:

    • Set-ExecutionPolicy Unrestricted
    • DG_Readiness_Tool_v3.6.ps1 -Enable

     To Enable DG/CG. If you have a custom SIPolicy.p7b then use the -Path parameter else the hardcoded default policy is used

     Usage: DG_Readiness.ps1 -Enable OR DG_Readiness.ps1 -Enable -Path <full path to the SIPolicy.p7b>

    • DG_Readiness_Tool_v3.6.ps1 -Disable

     To Disable DG/CG. For more usage, you can refer to the readme.txt from the download bundle file.

  •      Reboot

How to verify your host is ready to run with/without Hyper-V?

Check Hyper-V & VBS Status & Device Guard status

By windows cmd line msinfo32.exe

Thanks,

0 Kudos
Highlighted
VMware Employee
VMware Employee

Also there is an another to disable/enable Hyper-V Re: VMware Workstation does not support nested virtualization on this host.   Thanks ppan7 for  the solution.

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

It is happen for vmware 14.  as well. so i try the vmware 15, same result. after i updated windows 10 restart. need some quick bug fixes. I suspect is the Razer HID class driver upgrade. do you also use razer keyboard or device aswell? because this is the only one windows update history i get.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I have the same issue. My Winversion is

pastedImage_0.png

Thanks for your support!

0 Kudos
Highlighted
Contributor
Contributor

So I was having this same issue, what worked for me was disabling Virtual Based Security on my Windows 10 1909 host machine. Now I'm able to boot my vm.

I opened local group policy and browsed to - Computer Configuration\Administrative Templates\System\Device Guard. I then set "Turn on Virtualization Based Security" to Disabled. Not sure if a restart is needed, I restarted anyway just in case. Hope that helps. 

Highlighted

@cos2020 This did the trick.

Please visit my blog at https://nachogonzalez.com.ar
0 Kudos
Highlighted
Contributor
Contributor

After many hours of troubleshooting and many attempted fixes I finally got my VM working again by rolling back the Windows Update that came in the day before. It was a 'Security update for Windows' that somehow managed to mess up my host to VMware relationship. For the record all of the following didn't work for me: 

 

  1. Updating my windows build - I was unable to do so safely on my laptop due to a lack of assurance testing on my model 
  2. Disabling Hyper-V/device guard/Windows HyperVisor Platform/Virtual machine platform
  3. Upgrading to VMware Workstation Player 16 and Downgrading to VMware Workstation Player 14 which supposedly do not interfere with Hyper-V anyway but the issue still persisted 

I was about to give up and just wait until I could safely upgrade my Windows build when I thought that it could have been to do with the windows update which I did yesterday so rolled it back and the VM worked fine Player 15 and 16. 

 

System info: 

Microsoft Windows 10 Home

Version 10.0.18363 Build 18363

 

Hope this can help some others with the very annoying issue

0 Kudos