TheErrant1
Contributor
Contributor

How to set numlock for a VM booting with EFI?

ok so I created VMs with EFI firmware (instead of BIOS). Now every time I boot it, it does not set the numlock to "on". It is always off. 😞 Is there a way to set numlock to "on" upon boot-up for a VM with EFI boot?

(I know it is do-able in the BIOS settings IF I was using BIOS instead of EFI)

Please help!

Background: We have to use SmartCards to logon to a VM's preboot encryption.....and everyone uses numeric PIN codes. Manually setting numlock every time a VM boots up is very annoying.

Tags (2)
0 Kudos
4 Replies
HuanguoZhong
VMware Employee
VMware Employee

Thanks for coming to Workstation community. It's not a workstation issue. There are some solutions on line, I've found a link, hope it helps.

How to Enable or Disable a Toggle Key at Startup in Vista, Windows 7, and Windows 8

0 Kudos
TheErrant1
Contributor
Contributor

Thanks but you may have misunderstood my question. It "IS" a VMware workstation issue...and let me tell you why....

My problem happens "before" windows boots up...on the McAfee Drive Encryption 7.1 authentication screen. We have PIV/Smart card authentication enabled. Users have to put in their numeric PIN on that screen. We need the numlock "ON" at that time, so people can use the numeric keys on the right side of their keyboards. This is "before" Windows Operating System has even booted and hence, has nothing to do with Windows OS.

The solution you are posted (and I was aware of that before I started this thread) is when windows has booted up (inside windows OS).

0 Kudos
HuanguoZhong
VMware Employee
VMware Employee

Oh, get it.

As far as I know, for Virtual EFI, there currently isn't much in the EFI setup utility, there isn't option to enable Num Lock.

0 Kudos
WhiteKnight
Hot Shot
Hot Shot

It's 2022 now, and I'm facing the same issue. Has there been added an option to Workstation 16+ to have num-lock being enabled when a guest is booting with EFI?



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos