Enthusiast
Enthusiast

Here is patch for Workstation 6.5.2 on Linux 2.6.31 kernel

I'm pleased to announce an updated patch. I found some more time to work on it, and there's two big improvements:

1) It's "universal". It works for Linux 2.6.29, and Linux 2.6.30, and Linux 2.6.31!

2) Your VMware module files no longer need to be restored from backup, after a failed upgrade. The patch script is now much smarter about backing up the files that it changes. It uses checksums to make sure that it is seeing the original VMware Workstation 6.5.2 files, and when those files are found, it backs them up to a place that it uses for all future runs. The script is now idempotent: it's OK to run it more than once, it will have the same effect.

Here are 2 files, attached.

There's the shell script, and the patch file.

Download both of these files, to the same directory.

Then, run the script, as root. (Check it first, unless you REALLY trust me not to put some kind of rootkit in there!)

su <-- become root

bash ./vmware-6.5.2-newkernmods.sh <-- run the script

I tested it, and it worked, on these 3 kernels:

Linux 2.6.29.2

Linux 2.6.30.1

Linux 2.6.31-rc3

This is only for VMware Workstation 6.5.2. It won't work on any older version.

It's only for the host OS. It won't work on the guest OS (VMWare Tools).

It won't work on VMware Player.

It won't work on VMware Server.

Do let me know if this works successfully for you!

0 Kudos
91 Replies
Enthusiast
Enthusiast

Polo: That's unusual that you would have to change the checksums in the script. I took into account both the 32-bit and 64-bit download versions of VMware Workstation 6.5.2 build 156735. Is there a different version out now?

0 Kudos
Contributor
Contributor

0 Kudos
Contributor
Contributor

I'm running Workstation 6.5.2 x86_64 and Fedora 11 w/ kernel 2.6.29.6-213.fc11.x86_64. The compile w/ the new patch seems to go ok and I can run VMs ok, but when I suspend a guest VMware seems to 'hang' where the GUI console seems to look like the guest is suspended but I can't close the GUI window, I get a message that a VM is still in use. a ps listing shows that indeed the guest is still running. I can kill -9 the process and when I restart the guest it comes out of suspend ok.

Is there any info I can gather here that would be helpful.

0 Kudos
Contributor
Contributor

Hello,

same here with Fedora FC11 Kernel 2.6.29.6-213.fc11.i586 and VMware Workstation 6.5.2. After suspending the VM, VMware-process needs a kill -9

Thank you very much for the patch to compile.

0 Kudos
Contributor
Contributor

Thanks Krellan, patch works on my 64-bit Fedora notebook.

Still running into issues starting vmware though on the 64-bit Fedora 11 - can only launch via sudo - vmware - user gets GIO::error.

When or if someone has figured this out would be appreciated as well. Cheers and thanks again!

___

Anthony Rosati

___ Anthony Rosati
0 Kudos
Contributor
Contributor

And a warning to aybara and others -- it is a &lt;i&gt;bad idea&lt;/i&gt; to exit your guest vm in full screen mode and not get back to the host OS before it dies. I'm working at a place where I don't have any easy network access back to the host to remote login to issue that kill, and when vmware hangs one can no longer exist the hung window or X (Ctrl-Alt-Bksp no longer works -- vmware owns your keyboard).. I've had to hard reboot twice now (twice because I'm a slow learner:-) because I tend to work in full screen mode in my XP-Pro guest if I work there at all.

And yeah, it would be simply lovely if vmware would pay a bit of corporate attention to this. vmware is a commercial product and I paid for it; seems like getting it to work without hangs on current linux kernels would be a bit of a priority if they wish to continue making money selling software in a world where they have many open source free competitors, some of which ALSO sometimes hang, but hang for free and hang in a context where somebody tries to fix the hang.

rgb

0 Kudos
Contributor
Contributor

A couple more things:

The 'hang' seems to happen only w/ Windows Guests (well, XP, I don't have Vista+), I have some RHEL guests and they don't 'hang' where I have to kill -9 the vmx process.

I also have some of the crazy keyboard behaviour mentioned earlier, keys seem to get 'stuck' while in the VM, and that passes over to my host OS, so I'm not sure if that's a Fedora 11 problem or something from VMware.

0 Kudos
Enthusiast
Enthusiast

Same thing for me using an XP VM under Fedora 11 (kernel 2.6.29.6). I got the same warnings during the compile but it built & loaded the modules ok. VM appears work but when I do a shutdown VMPlayer hangs and needs a 'kill' to get rid of it. The VM does appear to have shutdown correctly though.

Thanks for the patch.

0 Kudos
Contributor
Contributor

Running Fedora 11 , 2.6.29.6-217.2.3.fc11.x86_64, with patched vmware 6.5.2 on both a laptop and a workstation I experienced my XP

guest os's hanging on shutdown and had to use "kill -9" on the vmx process. While doing some debugging I noticed it appeared to an

issue with the pcscd daemon. As I do not use any smart cards, I disabled that daemon (service pcscd stop; chkconfig pcscd off) and now

my XP guests close down as expected on both computers.

I normally disable unused features/daemons, including pcscd, but had not yet applied my standard disable changes. If you're not using smart

cards I suggest that you disable the daemon, with luck it'll solve both your issues.

0 Kudos
Contributor
Contributor

Perfect tip!

Thank you very much.

0 Kudos
Enthusiast
Enthusiast

Confirming -- the patch enables a clean build, VMWare Player 2.5.2 on Kubuntu 9.10 64-bit. But the keyboard/mouse issue is pretty bad here. It goes like this: The guest OS (Win XP) login window appears. Ctrl-G will give me one, and only one, opportunity to complete the Win XP password. The "Enter" that follows appears to disable the keyboard and mouse permanently, for the guest OS. Moreover, the host (9.10) now has no Shift or Caps lock or Ctrl or F- keys, although the mouse behavior seems normal. With no ability to exit to the tty console with a Ctrl-Alt key combo, only a mouse-clicked shutdown/restart from KDE is possible. Very eager for a workaround to this one!

0 Kudos
Enthusiast
Enthusiast

Idaho: A very wise idea. I remember pcscd, from the days when Fedora had the "Install Everything" option. I knew I had installed pcscd, because the CPU went to 100% with the crashed pcscd daemon stuck in a loop. Good idea to disable pcscd. Didn't know it interfered with VMware, wow, that's a new low, even for pcscd Smiley Happy

0 Kudos
Contributor
Contributor

Thanks IdahoJTD for sugestion. I can confirm that i no longer have any shutdown issues after stoping pcscd daemon.

Thanks IdahoJTD again.

0 Kudos
Contributor
Contributor

So the pcscd fixed the 'hanging' problem, but I'm still having the 'crazy keyboard' issue where the 'enter' key seems to get stuck until I hit esc or ctl-alt or something else as I mash the keyboard.

0 Kudos
Contributor
Contributor

Success with 2.6.30.2 kernel, but problems with 2.6.30.4:

...........

Testing compilation of vmnet module to see if it works

Using 2.6.x kernel build system.

make: Entering directory `/usr/lib/vmware/modules/source/vmnet-only'

make -C /lib/modules/2.6.30.4/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/linux-2.6.30.4'

CC /usr/lib/vmware/modules/source/vmnet-only/driver.o

CC /usr/lib/vmware/modules/source/vmnet-only/hub.o

CC /usr/lib/vmware/modules/source/vmnet-only/userif.o

CC /usr/lib/vmware/modules/source/vmnet-only/netif.o

/usr/lib/vmware/modules/source/vmnet-only/netif.c: In function ‘VNetNetIfSetup’:

/usr/lib/vmware/modules/source/vmnet-only/netif.c:216: error: ‘struct net_device’ has no member named ‘init’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:217: error: ‘struct net_device’ has no member named ‘open’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:218: error: ‘struct net_device’ has no member named ‘hard_start_xmit’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:219: error: ‘struct net_device’ has no member named ‘stop’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:220: error: ‘struct net_device’ has no member named ‘get_stats’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:221: error: ‘struct net_device’ has no member named ‘set_mac_address’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:222: error: ‘struct net_device’ has no member named ‘set_multicast_list’

make[2]: *** Ошибка 1

make[1]: *** Ошибка 2

make[1]: Leaving directory `/usr/src/linux-2.6.30.4'

make: *** http://vmnet.ko Ошибка 2

make: Leaving directory `/usr/lib/vmware/modules/source/vmnet-only'

Sorry, problem compiling the vmnet module after it was patched.

Please check that Linux kernel version 2.6.30.4 is supported.

0 Kudos
Contributor
Contributor

Currently compiling kernel 2.6.30.5.

I'll let you know if it works...

EDIT:

It passed patching and compiling, but still not working for me.

My custom built distro is to blame... :smileygrin:

Just ask for Diamond!

Just ask for Diamond!
0 Kudos
Contributor
Contributor

I didn't really expect it to fix the crazy keyboard issue. I have a "stuck key" issue which ONLY occurs when I use Ctrl-G to grab focus. I do not use Unity at all, and as long as I use the mouse to grab the focus then my system works as expect. Under Fedora 10 I would uses Ctrl-G, especially on my laptop, as I don't like to have to mouse any more than necessary. However since upgrading to Fedora 11, I have discovered that behavior will cause a stuck key and I have to essentially shutdown the guest machine. In the host I will lose my shift and control key functionality and I have to use setxkbmap to restore sanity. I've not had time to look at what is really going on but knowing that simply avoiding using the keyboard to grab focus into the guest is enough to make my system entirely usable. I stumbled across another thread discussing similar keyboard issues but now can't find it, however the workaround suggested there was exactly what I'm doing -- avoid the keyboard grab.

-- John

0 Kudos
Contributor
Contributor

After I manually removed and reinstalled vmware, same thing on 2.6.30.5:

Using 2.6.x kernel build system.

make: Entering directory `/usr/lib/vmware/modules/source/vmnet-only'

make -C /lib/modules/2.6.30.5-sgnb/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/linux-2.6.30.5'

CC /usr/lib/vmware/modules/source/vmnet-only/driver.o

CC /usr/lib/vmware/modules/source/vmnet-only/hub.o

CC /usr/lib/vmware/modules/source/vmnet-only/userif.o

CC /usr/lib/vmware/modules/source/vmnet-only/netif.o

/usr/lib/vmware/modules/source/vmnet-only/netif.c: In function ‘VNetNetIfSetup’:

/usr/lib/vmware/modules/source/vmnet-only/netif.c:216: error: ‘struct net_device’ has no member named ‘init’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:217: error: ‘struct net_device’ has no member named ‘open’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:218: error: ‘struct net_device’ has no member named ‘hard_start_xmit’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:219: error: ‘struct net_device’ has no member named ‘stop’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:220: error: ‘struct net_device’ has no member named ‘get_stats’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:221: error: ‘struct net_device’ has no member named ‘set_mac_address’

/usr/lib/vmware/modules/source/vmnet-only/netif.c:222: error: ‘struct net_device’ has no member named ‘set_multicast_list’

make[2]: *** Ошибка 1

make[1]: *** Ошибка 2

make[1]: Leaving directory `/usr/src/linux-2.6.30.5'

make: *** http://vmnet.ko Ошибка 2

make: Leaving directory `/usr/lib/vmware/modules/source/vmnet-only'

Sorry, problem compiling the vmnet module after it was patched.

Please check that Linux kernel version 2.6.30.5-sgnb is supported.

0 Kudos
Contributor
Contributor

I've had the 'crazy keyboard' when I'm inside a guest VM (only WinXP so far) - I grab focus w/ the mouse. I've also noticed I can't copy/paste from the guest to host and vice versa (vmtools installed on the guest).

0 Kudos
Contributor
Contributor

thanks so much for this patch. i was able to get your most recent file to work for me, only after commenting out the md5 checks, as they did not match. i am running vmware player 2.5.2 in newly installed fedora 11 (kernel 2.6.29.6).

however, i have no sound in the vm. error:

Cannot connect virtual device sound. No corresponding device is available on the host.

i've had sound previously with the same vmware player on the same machine, running under ubuntu 8.10. any thoughts?

forgot to mention that i am running xp in the vm.

Message was edited by: laz0rama

0 Kudos