GlennH201110141
Contributor
Contributor

Guest can't ping host OS

Hello,

I would like help getting my two Windows 7 guest OS VMs to ping the Windows 7 host. 

Background:

  • Host is Windows 7 64 bit.
  • Guests are both Windows 7 32 bit, recently converted from VPC. 
  • I have both guests functioning normally other than this issue. 
  • both guests are configured to use bridged network
  • bridge network (vmnet0) is configured to use a single wireless adapter, not automatic

What I have tried:

  • firewalls on both guest and host are turned off
  • verified host and guests are assigned expected IPs and are on same subnet
  • pinging from guest to guest works both ways
  • pinging from host to both guests works
  • guests can ping router
  • guests can reach the internet, browse google, etc.
  • VPN on guests are off
  • guests can ping other PCs on network
  • other PCs on network can ping host
  • other PCs on network can ping guests
  • verified vmnetbridge service is running
  • verified adapter related registry keys
  • I briefly had success when I was playing with enabling Internet Connection Sharing on my host's wireless adapter settings.  I could not understand how that should help, and while I was experimenting, turning it off and on, it stopped working for me. 
  • rebooted VMs
  • tested using both IP and name, resolving name with hosts file

Here is my vmx file for one guest, they are both similar:

.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "7"
memsize = "1424"
MemAllowAutoScaleDown = "FALSE"
displayName = "W7 Sonicwall VPN"
guestOS = "windows7"
floppy0.present = "TRUE"
floppy0.autodetect = "TRUE"
floppy0.filename = "auto detect"
ethernet0.present = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.connectionType = "bridged"
ethernet0.startConnected = "TRUE"
ide0:0.present = "TRUE"
ide0:0.fileName = "W7 Sonicwall VPN.vmdk"
ide1:0.present = "TRUE"
ide1:0.autodetect = "TRUE"
ide1:0.filename = "auto detect"
ide1:0.deviceType = "cdrom-raw"
vmci0.present = "TRUE"
pciBridge0.present = "TRUE"
tools.upgrade.policy = "useGlobal"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
extendedConfigFile = "W7 Sonicwall VPN.vmxf"
virtualHW.productCompatibility = "hosted"
ide1:0.startConnected = "TRUE"
tools.syncTime = "FALSE"
uuid.location = "56 4d 1e e7 3a ae c7 10-eb ae 21 97 b0 4c 06 3d"
uuid.bios = "56 4d b5 b7 8a 15 7e 47-e4 4f a9 cf c2 ba 4a d6"
replay.supported = "FALSE"
unity.wasCapable = "TRUE"
replay.filename = ""
ide0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
ethernet0.pciSlotNumber = "32"
vmci0.pciSlotNumber = "33"
vmotion.checkpointFBSize = "24576000"
vmci0.id = "-1027978538"
floppy0.startConnected = "FALSE"
ethernet0.vnet = "VMnet0"
checkpoint.vmState = ""
cleanShutdown = "FALSE"
debugStub.winOffsets.version = "7"
scsi0.virtualDev = "lsisas1068"
scsi0.pciSlotNumber = "160"
sound.pciSlotNumber = "34"
scsi0.present = "TRUE"
sound.present = "TRUE"
sound.fileName = "-1"
sound.autodetect = "TRUE"
debugStub.winOffsets.value = "0xb8,0xb4,0x18,0x188,0x16c,15,408,0x268,0x260,0x230,0x218,0x88,0x28,0x18,0x20,0x24,1,0x280,0x0,0xc,0x14,0x200000,0x1a8,0xc,0xc,0x18,0x12c,0x1ec"
scsi0.sasWWID = "50 05 05 67 8a 15 7e 40"
ethernet0.addressType = "static"
ethernet0.address = "00:50:56:00:4a:01"

And here is the ipconfig /all for my guest:

C:\Program Files\Microsoft Visual Studio 10.0\VC>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : VMW7SONICVPN
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-50-56-00-4A-01
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::d00e:125e:4e:afa0%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.123(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, July 18, 2011 3:14:19 PM
   Lease Expires . . . . . . . . . . : Friday, September 16, 2011 3:14:19 PM
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 469765161
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-09-D0-2F-00-03-FF-1E-AA-4C

   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{830B6778-EB77-443C-9BDC-08B62E813411}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:30f6:3f82:3f57:ff84(Preferred)
   Link-local IPv6 Address . . . . . : fe80::30f6:3f82:3f57:ff84%12(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Program Files\Microsoft Visual Studio 10.0\VC>

Your time and advice is greatly appreciated.  I have spent much time researching and testing but I am stuck.  I am a newbie to vmware.

Thanks,

Glenn

22 Replies
Scissor
Virtuoso
Virtuoso

Welcome to the forums!

Does your host have a Realtek NIC installed?  Even if it doesn't, try disabling any "checksum offload" or other "offload" settings on your Host's Network Adapter to see if that helps.

More information: 

http://kb.vmware.com/kb/1015940

http://kb.vmware.com/kb/1025978

You said that you already disabled the Host's firewall as part of your testing... but I have to ask if you have a 3rd party Firewall or other security software installed on the Host?  Some 3rd party firewalls do not fully disable unless they are uninstalled.

0 Kudos
GlennH201110141
Contributor
Contributor

Thank you Scissor, for your response and your welcome,

My host adapter is an Atheros Wireless NIC.  I checked and it does not have either checksum option available or anything related to checksums whatever.  My wired adapter does, but I am not bridging on that so I didn't bother trying it.  Would it make sense to?

One of the articles suggests changing the setting on both the host and guest, and the guests do have the setting.  I have disabled it but it didn't help.

Regarding firewalls, both the host and the guests are windows firewalls only.

Should I try reinstalling Workstation 7?

Thanks,
Glenn

0 Kudos
Scissor
Virtuoso
Virtuoso

Is this the first Guest you have created on this particular Host?  (wondering if other Guests are able to ping your Host)

I would check to make sure that Workstation is actually bridging to the correct Host adapter.  Edit -> Virtual Network Editor -> VMnet0.  Change selection from "Automatic" and manually select your Wireless adapter.

0 Kudos
GlennH201110141
Contributor
Contributor

I have 4 VMs on this host now.  All have the same issue.  2 are W7 and 2 are XP.  They were all imported from VPC.  I have not built any VMs from scratch yet.

Networking is confirmed, and all VMs are able to reach internet, ping eachother, get pinged. 

0 Kudos
Scissor
Virtuoso
Virtuoso

Can other machines on your network ping your Host? (another laptop or desktop)?

0 Kudos
GlennH201110141
Contributor
Contributor

Yes.

0 Kudos
Scissor
Virtuoso
Virtuoso

Maybe check for an updated driver for your Host's Wireless card?

Can you temporarily switch your Host from using a Wireless connection to a Wired connection and see if the problem still happens (remember to change the adapter that VMware bridges to).  That should tell us if the problem is with VMware or with your Wireless adapter.

0 Kudos
GlennH201110141
Contributor
Contributor

That did something!

After switching my host to use the wired adapter, and changed the Network Config, I can now ping all the way around and my guests see my host.

So... on to why the wireless adapter doesn't work.

I have asked Windows to update the driver and it finds it up to date already.

I was going to search Atheros for updated drivers but i can't find a proper model number for this NIC.

So does this indicate an issue with my wireless NIC or vmWare?

Not sure what to try next...

Thanks,
Glenn

0 Kudos
Scissor
Virtuoso
Virtuoso

Does your Wireless Card have the "VMware Bridge Protocol" bound to it? (see below picture)

Bridge-Protocol.PNG

As to locating updated drivers... To get more information about a PCI device, Open up Device Manager, locate your card, and right-click -> properties -> Details tab -> Hardware IDs and make a note of the PCI IDs...  (See below picture)

PCI-id.PNG

.. Then visit http://pciids.sourceforge.net/ and look up the device using the Vendor and Device IDs (8086 and 4239 in the screenshot above).   If you find it on the web site, the entry usually includes a model number that you can then use to search on the manufacturer's web site for drivers.

0 Kudos
GlennH201110141
Contributor
Contributor

Thank you for the excellent details.  I have determined my W-NIC is a Atheros AR928X.  I found the latest driver from atheros.cz, an unofficial driver site, and attempted an update, but windows again stated my driver is up to date.

A new development: The problem has spread. I am now unable to ping my host, when using either my wired or wireless adapters.   I am not certain when it broke, but the only changes I have attempted was to shut down my VMs and in the Network Editor, I clicked Restore Defaults.  Now, even when i reset the network editor the same way as before (when it was working) it still doesn't work.

Thanks,

Glenn

0 Kudos
continuum
Immortal
Immortal

in virtual network editor make sure you don't use automatic bridging

specify vmnet0 for the regular nic and vmnet2 for the wireless


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
GlennH201110141
Contributor
Contributor

Wait.  My fault.  I was pinging the wrong address for the wired adapter.  It is working.  

0 Kudos
rnrprojects
Contributor
Contributor

Hello all thanks for the attention to this I am having the same issue. I have the same Wireless setup (Atheros AR5B97) and when I disable the wireless and plug into the physical jack change my bridge setting from auto to the Nic it takes right off. I do not see a updated driver for this card. I have also checked to the properties of the wireless card and it does have the VmBridge and it is checked.

Thanks for any help to correct the wireless issue.

0 Kudos
GlennH201110141
Contributor
Contributor

Unfortunately, I am still working around this by using my wired adapter.

Even tech support at vmware couldn’t solve the wireless adapter problem without creating a second host-only network (which is a configuration headache, multiple adapters, extra firewall exemptions, host file changes, on and on...) I currently have my wireless adapter disabled as both point to the same router.

If you or anyone does find a working solution to this, please post it here.

Thanks,

Glenn

0 Kudos
a_p_
Leadership
Leadership

Only a thought. Did you ever consider, this could be an issue with the wireless router/access point (e.g. security settings)!?

André

0 Kudos
MohK
Contributor
Contributor

Same problem here.. VirtualBox works just fine... tired of looking for a solution now.

Can ping the guest from host.. just not the other way around via Bridge (Realtek Wireless NIC)

0 Kudos
yardduck
Contributor
Contributor

I don't know if this will help your situation at all, I just lost network connectivity on my bridged network 192.168.27.x, but could still ping vmware's virtual network 192.168.47.x.  Neither of my guest os's (win2k3, win2k8 sbs) could ping host (win2k3), and vice versa.  I found a setting under 'virtual network manager' for vmnet0 which lets you manually select the appropriate physical nic, in my case I think vmware got confused by the presence of the hamachi vpn adapter, so I just manually selected the realteck gbe nic and all is well.

0 Kudos
ZeroTheHero
Contributor
Contributor

I was having this issue and solved it in a not-so-simple way.

I changed the virtual network adapter to host-only, set my wireless card with fixed lease and added a secondary gateway and IP poiting to my vmnet1 (host-only) interface.

my network is 192.168.1.x

my vmnet2 is 192.168.81.x

on my corporate networks i received dhcp lease

wrote the info about the lease on a notepad

copied it to my wireless interface as fixed lease

added a seconday ip (192.168.81.10) and gateway (192.168.81.1)

host started to ping vm, vm doesn't ping host but it is a firewall issue.

then it worked.

Message was edited by: ZeroTheHero

0 Kudos
vihar1
Enthusiast
Enthusiast

I've encountered a similar issue today and managed to find a solution.

My setup:

- Win 7 host

- Workstation host only networking

- 3 Win 2008 R2 guests

- RDP works for all guests

- ping works only for 2 guests, not for vCenter

- cannot connect to vCenter server via vSphere client

The issue was that the network type in the vCenter guest was set to public. I've change it to work network and it immediately started working. Disabling the firewall or setting network type to private/home might have done the same.

I do not know why the network type was different here though...

0 Kudos