ScrapDog
Contributor
Contributor

Fullscreen

Jump to solution

I have a question and i cant find an answer,

Is there any way to start de VMRC.exe with a shortcut and enter it in fullscreen ?
I want a shortcut on my desktop (windows 10) and when i click it it need to be start in fullscreen.

Can anybody help me ?

Greetings,

Enrico

0 Kudos
1 Solution

Accepted Solutions
fabio1975
Hot Shot
Hot Shot

Ciao 

you have three options, two with Full-Screen Option and one without full-Screen option (unfortunately this is with VMRC)

VMware Workstation

"C:\Program Files (x86)\VMware\VMware Workstation\vmware.exe" -f -H 192.168.1.201 -M 35

VMware Player

"C:\Program Files (x86)\VMware\VMware Workstation\vmplayer.exe"  -X -H 192.168.1.201 -M 35

VMRC

"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe" vmrc://root@192.168.1.201/?moid=35

 

Where 192.168.1.201 is IP or FQDN of ESXi and  MOID or M (35) the identification of VM (found with this command on ESXi Host vim-cmd vmsvc/getallvms)

The option -f (Workstation) -X (Player) are for open the session on Full-Screen Mode

The vim-cmd vmsvc/getallvms output is:

fabio1975_0-1621370202258.png

 

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos

View solution in original post

7 Replies
fabio1975
Hot Shot
Hot Shot

Ciao 

Check if this post in the community can help you:

Solved: VMWare Remote Console 10 start fullscreen from com... - VMware Technology Network VMTN

The VM you need to connect to is active on workstation or ESXi, it's not clear to me.

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos
wila
Leadership
Leadership

Hi,

Instead of VMRC use vmware-kvm.exe (it's in your vmware workstation folder somewhere) and pass it the vmx file.

It's awesome.

Doc is here: https://blogs.vmware.com/workstation/2014/03/whats-cool-vmware-kvm-utility.html

 

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
ScrapDog
Contributor
Contributor

@fabio1975 

It dont work, i dont know what kind of path i neeed to type with does (look like) mac adresses. 

0 Kudos
ScrapDog
Contributor
Contributor

@wila

This one is working but my vm's running in ESXi, on the local pc it works, but how can i connect to a ESXi workstation ?

0 Kudos
wila
Leadership
Leadership

Hi,

You didn't mention "ESXi" and posted this at the workstation section of the forum, so I didn't consider that.
AFAIK then you're back to VMRC.

For the connection URL have a look at William Lam's site:
https://williamlam.com/2011/10/how-to-generate-vm-remote-console-url.html

There's probably some invocation for vmware-kvm (like it doesn't complain about --host as a parameter),  but I'm not patient enough now to figure out. VMware player used to have a remote option as well.. back in the day.

See my post here from 2009...
https://planetvm.net/blog/?p=330

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
fabio1975
Hot Shot
Hot Shot

Ciao 

you have three options, two with Full-Screen Option and one without full-Screen option (unfortunately this is with VMRC)

VMware Workstation

"C:\Program Files (x86)\VMware\VMware Workstation\vmware.exe" -f -H 192.168.1.201 -M 35

VMware Player

"C:\Program Files (x86)\VMware\VMware Workstation\vmplayer.exe"  -X -H 192.168.1.201 -M 35

VMRC

"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe" vmrc://root@192.168.1.201/?moid=35

 

Where 192.168.1.201 is IP or FQDN of ESXi and  MOID or M (35) the identification of VM (found with this command on ESXi Host vim-cmd vmsvc/getallvms)

The option -f (Workstation) -X (Player) are for open the session on Full-Screen Mode

The vim-cmd vmsvc/getallvms output is:

fabio1975_0-1621370202258.png

 

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos

View solution in original post

ScrapDog
Contributor
Contributor

Thank you,

It works fine now. I can get fullscreen running vm aat once 🙂 🙂

I only have to find out how to set the resolution correct. But i guess that will be no problem.

Thanks again, you where a gretfull help.

Regards,

ScrapDog

0 Kudos