VMware Communities
vito_cavallo
Contributor
Contributor

File Permissions - Multiple Users - Linux Host ?

I installed VMWare Workstation 6 on a Linux host. I am running Windows XP as a guest. When I launch VMware as anything other than root, I receive file permission errors.

I do not want to give full access to tthe VMWare folder since I do not want the user deleting important files by mistake.

Is there a KB article or newsgroup posting that explains the best way to set permissions so users can launch VMware but not erase the files?

Thank you.

Reply
0 Kudos
8 Replies
IamTHEvilONE
Immortal
Immortal

I think it would be read + write and probably execute .... the problem is that folders and files may be created on the host when the VM powers up.

If you don't want to give them access to the VMware Folder ... move the virtual machine(s) that they need to access to a folder that is fine for them to muck up, and give the proper permissions there.

Reply
0 Kudos
vito_cavallo
Contributor
Contributor

I was able to set the permissions for a user, but problems arise if another user logs on and want to use the same virtual machine. Since the VM and host OS is on a domain, I can have multiple users log in to use.

If another person logs in, they get the "file permissions" error.

Thanx

Reply
0 Kudos
AWo
Immortal
Immortal

If you're talking about starting VMware Workstation itself (and not the guest) check your permissions on "/usr/bin/vmware". It should be "r-xr-xr-x".

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
Reply
0 Kudos
IamTHEvilONE
Immortal
Immortal

when you mean log in ... do you mean Power On A virtual machine?

You can't have 2 different users power on a VM, that's because a user places a lock on the VMDK and VMX files. then they can't be edited by any another user.

why do you need multiple users accessing the same vm?

Reply
0 Kudos
AWo
Immortal
Immortal

Both users should be in the "users" group. If you don't want to go with this group, add another one, maybe "vmware" and change the group ownership to this new group.

The user/group who wants to run the guest should have at least "rwx" to the whole guest directory and the files below it.

Message was edited by: AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
Reply
0 Kudos
vito_cavallo
Contributor
Contributor

I think I need to be more specific. I can launch VMware from any account, no problems.

VMware is being used by one user at a time. The permission errors occur when the user "Powers Up" the VM.

I did notice vm files created in the /tmp directory.

I finally just made rwx all for one user, that seems to work fine. Would still like to have 2 users launch VM at seperate times.

Maybe that is not an option.

thanx

Reply
0 Kudos
AWo
Immortal
Immortal

Have you tried to use a group for this purpose? The rights of files and directories are always "user-group-all". Check which group owns the directory and the files. It should be the group "users" where every user is a member of by default. Set the rights to "rwxrwx---" which gives the user and the group the necessary rights.

Which files are in the "/tmp" directory?

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
Reply
0 Kudos
rkr002
Enthusiast
Enthusiast

I can describe settings I'm using for that situation.

Assign the users to a group, then make this group as owner of the VM-machine directory and all its files.

Then change permissions for the dir to 'rwxrwx-' and for files to 'rw-rw--'.

Also set GID attribute for the directory, to have eventual new files be created with the group as the owner.

I'm using such settings successfully and two users can run a VM in turn without problems.

I don't bother about /tmp files as I had no problems with them at all

(I suppose because the files are created on behalf of each user separately and for 1 session only).

Reply
0 Kudos