IntenseMilk
Contributor
Contributor

Failed to stop vmware-tools.service: Unit vmware-tools.service not loaded.

When attempting to install vmware tools.. I get an error after initializing and it looks something like this:

here is the a picture of this error : Imgur: The most awesome images on the Internet 

Here is the error typed out if you don't trust links :

Initializing...

Making sure services for VMware Tools are stopped


Failed to stop vmware-tools.service: Unit vmware-tools.service not loaded.

Unable to stop services for VMware tools

Execution aborted.

Please help, thank you very much Smiley Happy

3 Replies
LPuentes
Contributor
Contributor

Hi IntenseMilk,

I had the same problem when trying to install Arch+i3wm+vmwaretools(10.1.6)

Problem:

when invoking vmware-install.pl, I got:

Failed to stop vmware-tools.service or vmware-tools-thinprint.service

Solution:

After invoking vmware-install.pl with a "Execution Aborted" message.

Execute:

sudo perl /usr/bin/vmware-config-tools.pl --skip-stop-start

This will allow you to finish your installation/configuration.

You can check that: /etc/init.d/rc0.d and rc6.d have files for you next steps of configuring your guest.

JoseVaca
Contributor
Contributor

Just had the same issue with an Ubuntu 16.04 guest, then I realized that while installing with defaults (using "sudo ./vmware-install.pl -d"), the init scripts directory was set to "/etc/rc.d" instead of "/etc/init.d", so after setting it manually the installation finished successfully.

Hope this helps!

0 Kudos
edwardsereed
Contributor
Contributor

Thank you - this resolved my problem updating vmware-tools on OpenSuSE 12.1-64 guest running on Win10 host using vmware-desktop.

Who the hell creates 13,000 line perl scripts?

0 Kudos