mohanss08
Contributor
Contributor

Failed to start LSB: This service starts and stops VMware services

Have upgraded `Ubuntu-18.04 LTS` to `20.04 LTS` using below commands on command line.


$ sudo apt-get update
$ sudo apt-get upgrade --yes
$ sudo apt-get dist-upgrade --yes

Upgrade finished successfully. After server reboot, not able to start the vmware service.


$ sudo systemctl start vmware.service
Job for vmware.service failed because the control process exited with error code.
See "systemctl status vmware.service" and "journalctl -xe" for details.

$ sudo systemctl status vmware.service
● vmware.service - LSB: This service starts and stops VMware services
Loaded: loaded (/etc/init.d/vmware; generated)
Active: failed (Result: exit-code) since Sat 2021-11-13 17:44:46 IST; 1min 50s ago
Docs: man:systemd-sysv-generator(8)
Process: 1837 ExecStart=/etc/init.d/vmware start (code=exited, status=1/FAILURE)
Tasks: 0 (limit: 618660)
Memory: 14.8M
CGroup: /system.slice/vmware.service

Nov 13 17:44:46 svr-4 vmware[1837]: Starting VMware services:
Nov 13 17:44:46 svr-4 vmware[1837]: [37B blob data]
Nov 13 17:44:46 svr-4 vmware[1837]: [52B blob data]
Nov 13 17:44:46 svr-4 vmware[1837]: [53B blob data]
Nov 13 17:44:46 svr-4 vmware[1837]: [33B blob data]
Nov 13 17:44:46 svr-4 vmware[1837]: [30B blob data]
Nov 13 17:44:46 svr-4 vmware[1837]: [41B blob data]
Nov 13 17:44:46 svr-4 systemd[1]: vmware.service: Control process exited, code=exited, status=1/FAILURE
Nov 13 17:44:46 svr-4 systemd[1]: vmware.service: Failed with result 'exit-code'.
Nov 13 17:44:46 svr-4 systemd[1]: Failed to start LSB: This service starts and stops VMware services.

$ sudo /etc/init.d/vmware status
Module vmmon not loaded
Module vmnet not loaded

$ sudo /etc/init.d/vmware start
Starting VMware services:
Virtual machine monitor failed
Virtual machine communication interface done
VM communication interface socket family done
Blocking file system done
Virtual ethernet failed
VMware Authentication Daemon done

$ uname -r
5.4.0-91-generic

$ vmware --version
[AppLoader] Use shipped Linux kernel AIO access library.
An up-to-date "libaio" or "libaio1" package from your system is preferred.
VMware Workstation 15.0.0 build-10134415

$ systemctl list-units --state=failed
UNIT LOAD ACTIVE SUB DESCRIPTION
● vmware-workstation-server.service loaded failed failed LSB: This services starts and stops the Workstation as a Server daemon.
● vmware.service loaded failed failed LSB: This service starts and stops VMware services

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

2 loaded units listed.

As per this [link] [https://communities.vmware.com/t5/VMware-Workstation-Pro/Failed-to-start-LSB-This-service-starts-and...] instruction, `Re-install the VMware Workstation Kernel modules` step fails with below errors.

$ sudo vmware-modconfig --console --install-all
[AppLoader] GLib does not have GSettings support.

(process:9815): GLib-CRITICAL **: 19:53:16.571: g_file_test: assertion 'filename != NULL' failed
Failed to setup build environment.

Can someone help to solve this? Thanks in advance.

0 Kudos
9 Replies
scott28tt
VMware Employee
VMware Employee

Presumably this is your host OS, information about the Workstation version would be helpful.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
mohanss08
Contributor
Contributor

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.3 LTS
Release:        20.04
Codename:       focal
$ vmware --version
VMware Workstation 15.0.0 build-10134415
$ uname -a
Linux svr-4 5.4.0-91-generic #102-Ubuntu SMP Fri Nov 5 16:31:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
0 Kudos
mohanss08
Contributor
Contributor

$ sudo systemctl status vmware-workstation-server.service
● vmware-workstation-server.service - LSB: This services starts and stops the Workstation as a Server daemon.
     Loaded: loaded (/etc/init.d/vmware-workstation-server; generated)
     Active: failed (Result: exit-code) since Sun 2021-11-14 20:24:41 IST; 13h ago
       Docs: man:systemd-sysv-generator(8)
    Process: 2199 ExecStart=/etc/init.d/vmware-workstation-server start (code=exited, status=1/FAILURE)

Nov 14 20:24:40 svr-4 systemd[1]: Starting LSB: This services starts and stops the Workstation as a Server daemon....
Nov 14 20:24:41 svr-4 vmware-workstation-server[2199]: [42B blob data]
Nov 14 20:24:41 svr-4 systemd[1]: vmware-workstation-server.service: Control process exited, code=exited, status=1/FAILURE
Nov 14 20:24:41 svr-4 systemd[1]: vmware-workstation-server.service: Failed with result 'exit-code'.
Nov 14 20:24:41 svr-4 systemd[1]: Failed to start LSB: This services starts and stops the Workstation as a Server daemon..


$ sudo systemctl start  vmware-workstation-server.service
Job for vmware-workstation-server.service failed because the control process exited with error code.
See "systemctl status vmware-workstation-server.service" and "journalctl -xe" for details.
0 Kudos
scott28tt
VMware Employee
VMware Employee

Workstation 16 is supported on Ubuntu 20, but not Workstation 15: https://kb.vmware.com/s/article/2129859

There may be something you can do to get it working, I don’t have any experience in doing so, but one possible outcome here might be a Workstation upgrade.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
mohanss08
Contributor
Contributor

I have un-installed previous version and installed VM workstation-16.12.1 successfully on my ubuntu-20 lts system. However still facing the same problem with the service.

$ sudo ./VMware-Workstation-Full-16.2.1-18811642.x86_64.bundle  --console --eulas-agreed --required
[sudo] password for dejuje:
Extracting VMware Installer...done.
Installing VMware Workstation 16.2.1
    Configuring...
[######################################################################] 100%
Installation was successful.
$ vmware

 Tried to run vmware command on command line and tried to load the latest available kernel, Getting attached error. Have tried the below OS commands.

sudo apt-get update
sudo apt-get upgrade --yes
sudo apt-get dist-upgrade --yes 
sudo apt-get install build-essential dkms

cd /lib/modules/$(uname -r)/build/include/linux
sudo ln -s ../generated/utsrelease.h
sudo ln -s ../generated/autoconf.h
sudo ln -s ../generated/uapi/linux/version.h

 linux-headers-5.4.0-91-generic is already the newest version (5.4.0-91.102) installed. Here what I'm missing? And what precisely is vmware looking for?

0 Kudos
mkubecek
Hot Shot
Hot Shot

Does the devel package match currently running kernel? You may also try building the modules manually with "vmware-modconfig --console --install-all" to see what exactly is the problem.

0 Kudos
mohanss08
Contributor
Contributor

$ sudo vmware-modconfig --console --install-all
[AppLoader] GLib does not have GSettings support.

(process:31113): GLib-CRITICAL **: 14:51:49.338: g_file_test: assertion 'filename != NULL' failed
Failed to setup build environment.

Still something is missing in my Ubuntu-20.04LTS host?

0 Kudos
mohanss08
Contributor
Contributor

Any help on us to will solve this problem will be highly appreciated. 

0 Kudos
LicensesSNL
Contributor
Contributor

The fix for me was to uninstall vmware-workstation and re-install. Not saying that is a good thing but was how to use it again.

With Workstation v16 they seem to prefer to add features to prevent installing it, validating the license, activating it, dealing with Linux kernel updates. You'd think by version 16 all those issues would no longer exist but no more bugs per version increment. Its as if no one at the company actually uses it.

0 Kudos