BPenglase
Enthusiast
Enthusiast

Error updating Windows VMWare Tools

Jump to solution

Just upgraded to 7.0.1, and when I try to update the VMWare tools, it goes out and downloads the tools, asks me for my root password (all normal), then fails, with the error

"Error: install of VMware tools for Windows 2000 or later failed. Please report this to VMware or your system administrator as appropriate."

I haven't been able to find any log files with anything either. If someone can point me in the right direction...

And this might be related to:

http://communities.vmware.com/thread/196350

and

http://communities.vmware.com/message/1467500

0 Kudos
1 Solution

Accepted Solutions
rd1381
Enthusiast
Enthusiast

i tried today and it seems to be fixed

View solution in original post

0 Kudos
12 Replies
rd1381
Enthusiast
Enthusiast

me too

mine is vmware new version updated from 7.0.0 to new 7.0.1 version

host :ubuntu 9.10 x64

guest :windows 7

p.s.

i did some investigation with wireshark and found the url of downloading tools and downloaded myself

it a file like this : vmware-tools-windows-8.1.3-203739.x86_64.component.tar

and extracted the files inside in a folder and tired to install the component with this command in terminal (sudo of course )

vmware-installer --install-component=vmware-tools-windows-8.1.3-203739.x86_64.component

and it says your version is up to date nothing to do Smiley Happy)

so either vmware downloads the older version or the new version is somehow messed up so it thinks it still the older version (like a not updated naming scheme )

0 Kudos
rd1381
Enthusiast
Enthusiast

update :

i tired to run vmware as root so to eliminate any access problem (plz dont sa "dont run anything as root" i know)

and i tailed the log file related to update (running instalne :/tmp/vmware-root# tail -f ui-22060.log

output at the end of running:

Feb 08 12:15:16.273: vmui| OnProgress: jobID=1 progress=96 message=Downloading VMware Tools for Windows 2000 or later...

Feb 08 12:15:16.335: vmui| OnProgress: jobID=1 progress=97 message=Downloading VMware Tools for Windows 2000 or later...

Feb 08 12:15:16.388: vmui| OnProgress: jobID=1 progress=98 message=Downloading VMware Tools for Windows 2000 or later...

Feb 08 12:15:16.435: vmui| CDS: TAR: Finished writing /tmp/vmware-root/cdstmp_22060_0/vmware-tools-windows-8.1.3-203739.x86_64.component (33341623 bytes)

Feb 08 12:15:16.436: vmui| CDS: TAR: Finished writing /tmp/vmware-root/cdstmp_22060_0/descriptor.xml (1048 bytes)

Feb 08 12:15:16.436: vmui| CDS: Extraction has completed for /tmp/cdstmp_22060_0.

Feb 08 12:15:16.443: vmui| OnProgress: jobID=1 progress=100 message=Downloading VMware Tools for Windows 2000 or later...

Feb 08 12:15:16.444: vmui| OnProgress: jobID=1 progress=100 message=Update of VMware Tools for Windows 2000 or later pending...

Feb 08 12:15:16.459: vmui| CDS: Searching for product=fusion version=latest build=0 arch=x86_64

Feb 08 12:15:16.473: vmui| OnProgress: jobID=1 progress=-1 message=Updating VMware Tools for Windows 2000 or later...

Feb 08 12:15:16.474: vmui| CDS: Beginning execution of installer for 495ddb69933f0f1f9aa6983f8e12d82975ce4b609887043a3da0dadabbeb6512 (last one!)...

Feb 08 12:15:16.484: vmui| CDS: Host is using VMIS 1.1

Feb 08 12:15:17.517: vmui| CDS: Install for 495ddb69933f0f1f9aa6983f8e12d82975ce4b609887043a3da0dadabbeb6512 returned installerStatus 2, exitCode 0!

Feb 08 12:15:17.529: vmui| CDS: Bulletin 070e09d39cb3615a9c5bdbf98ea76e78b21ec69f2f3cbf3fe7a1698a0c0a2875 has successfully installed with no errors.

Feb 08 12:15:18.920: vmui| OnProgress: jobID=1 progress=100 message=Finished updating VMware Tools for Windows 2000 or later.

Feb 08 12:15:18.921: vmui| CDS: Component 1 of 1 : tools-windows version 8.1.3 build 203739

Feb 08 12:15:18.921: vmui| CDS: Component install state = CDS_INSTALLED_UNKNOWN

Feb 08 12:15:18.921: vmui| CleanupFinishedInstalls: Finished installing 070e09d39cb3615a9c5bdbf98ea76e78b21ec69f2f3cbf3fe7a1698a0c0a2875, Unknown install state

Feb 08 12:15:18.941: vmui| OnAbort: jobID=1 cancelled=0 error=Install of VMware Tools for Windows 2000 or later failed. Please report this to VMware or your system administrator as appropriate.

Feb 08 12:15:19.035: vmui| ProcessDoneAbort: onAbort - jobID=1 cancelled=0 error=Install of VMware Tools for Windows 2000 or later failed. Please report this to VMware or your system administrator as appropriate.

hope vmware fixes this soon

0 Kudos
Kasraeian
Expert
Expert

Hi,

I have uploaded my VMware Tools Ver 8.0 ISO file which I have it in my Workstation 7.0 folder as compress file to my site.

(sorry I just have winrar on my system)

you can download it, the mount it to your guest os and install ....

This is the link (Romved) for the file.

And the screenshot for its version

I hope it help a little.

Please tell me if anything goes wrong with the rar file.



-= If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" =-

-= If there's any mistake in my notes, please correct me! =-

-= Thanks =-

MCTS, VCP

If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" If there's any mistake in my notes, please correct me! Sohrab Kasraeianfard | http://www.kasraeian.com | @Kasraeian
Kasraeian
Expert
Expert

I'm Also trying to upload the zip file here, as soon as I did it, I will send the Link.



-= If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" =-

-= If there's any mistake in my notes, please correct me! =-

-= Thanks =-

MCTS, VCP

If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" If there's any mistake in my notes, please correct me! Sohrab Kasraeianfard | http://www.kasraeian.com | @Kasraeian
rd1381
Enthusiast
Enthusiast

thanks

are you from vmware company? if so why have vmware fixed the official way of getting updates.

and if you are not i really cant install a non-trusted app (specially a driver) one on my vmware. not that i think you have virus or something).

if you have a link on vmware download site that fixes this problem it would be much appreciated

still thanks for your link

0 Kudos
Kasraeian
Expert
Expert

Hi,

I'm not from VMware and I don't know why they didn't publish these driver as standalone package.

That right no body can trust any outsider and install what they publish or upload, but AFAIK, My system is clean and my anti virus is update, but any way, I'll try to find a way to download a secure one from VMware site.

By the way, may be the package is corrupted because recently we have a lot of Internet problem our country, lots of disconnection. (if that's the case, I'm sorry)

-= If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" =-

-= If there's any mistake in my notes, please correct me! =-

-= Thanks =-

MCTS, VCP

If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" If there's any mistake in my notes, please correct me! Sohrab Kasraeianfard | http://www.kasraeian.com | @Kasraeian
0 Kudos
rd1381
Enthusiast
Enthusiast

what country are you from?

and no its not corrupted because :

1: i tried like 10 times allready and it goes to 100 % and still gives error

2: i downloaded that component from url ( as i said) and still it gives error( says system uptodate)

3 component file is in tar format and to my knowledge it has a checking ability in it

4 i tried some service that get the url itself and i get it from there (i use it for some site that have no resume ability and high ping) and still its same

so i think its not corrupted when downloading but its from source

0 Kudos
admin
Immortal
Immortal

Hi BPenglase,

Please attach the following so we can look into your issue:

- the output of /usr/bin/vmware-installer -t BEFORE and AFTER installation

- a copy of /var/log/vmware-installer

Thanks!

-Josh

0 Kudos
Kasraeian
Expert
Expert

I'm from Iran, and the reason I guessed the package is corrupted is multiple disconnection happened while I have upload it.



-= If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" =-

-= If there's any mistake in my notes, please correct me! =-

-= Thanks =-

MCTS, VCP

If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" If there's any mistake in my notes, please correct me! Sohrab Kasraeianfard | http://www.kasraeian.com | @Kasraeian
0 Kudos
Kasraeian
Expert
Expert

Sorry, I have removed the link from my post and also file from my site, according to conversation with some friends.



-= If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" =-

-= If there's any mistake in my notes, please correct me! =-

-= Thanks =-

MCTS, VCP

If you found this note/reply useful, please consider awarding points for "Correct" or "Helpful" If there's any mistake in my notes, please correct me! Sohrab Kasraeianfard | http://www.kasraeian.com | @Kasraeian
0 Kudos
rd1381
Enthusiast
Enthusiast

i tried today and it seems to be fixed

View solution in original post

0 Kudos
BPenglase
Enthusiast
Enthusiast

I didn't get a chance to try it on Friday, however today (Monday, 2/15/10), I can confirm that it is working. I was able to update the tools that have previously failed.

Message was edited: Grammar

0 Kudos