benitoski
Contributor
Contributor

Error "Your host does not meet minimum requirements to run VMware Workstation with Hyper-V ..."

Hi

VMware Workstation 15 Pro - 15.5.6 build-16341506

Until last Friday my Vantage virtual machine was working fine, I actually used it without problems. Today I wanted to start preparing material for tomorrow, Monday and I find this error.
The first error screen says:
"Your host does not meet minimum requirements to run VMware Workstation with Hyper-V or Device/Credential Guard enabled. Refer to VMware KB article 76918 at https://kb.vmware.com/kb/76918 for more details."
I did not make any changes on my Win 10 or updates.
I checked what the VMware page mentioned in the first message says and it refers to having Hyper-V and / or Device/Credential Guard enabled in Windows.
I think both were disabled on Friday, since I was able to use VMware perfectly in the demo.
Anyway, I also decided to check the status of both things by using the instructions in https://winaero.com/how-to-check-if-your-pc-can-run-windows-10-hyper-v/ and both do not appear in the System Summary section but the line that says: "A hypervisor has been detected. Features required for Hyper-V will not be displayed."
I don't know what that line said before, when VMWare did work, or if that line is important to my problem, also there are several lines dedicated to "Hyper-V" in the file that I am not able to understand if they are relevant or not.
I also collected all the info with Support > Collect Support Data and I'm attaching the resulting zip file.
I would be very grateful if someone can tell me how to solve this problem
Oscar

Labels (2)
Tags (2)
0 Kudos
3 Replies
a_p_
Leadership
Leadership

0 Kudos
wila
Immortal
Immortal

Hi,

It is most likely going to be a windows update that messed you up.
You're on Windows 10 version 19.09 and that's the reason you are getting the error.
Your hardware certainly is modern enough.

Looks like that the Hyper-V role has been enabled, I can't really verify that in your logs as the VM doesn't even try to start and as such the vmware.log file is from before the problem.
Back then Hyper-V was not enabled.

In order to turn off Hyper-V mode, run the following command at the host in windows command-line with Administrator privileges:

bcdedit /set hypervisorlaunchtype off

Reboot the system to activate your changes.

If you want to go back to Hyper-V mode again, then you can enable it like this:

bcdedit /set hypervisorlaunchtype auto

 

Hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
benitoski
Contributor
Contributor

Hi, 

You was right! I solved the issue upgrading Windows to 20H2 and using VMware 16 player.

Thanks for your support

Oscar