Andy_Burns
Contributor
Contributor

Error "You do not have access rights to this file" - apparently caused by spaces in .vmx file name?

I had an interesting problem over the weekend. I had been working on a VM several times last week. When I went to open it on Saturday, I got an error:

Could not open virtual machine: I:\MOSS003 - OCT07 Base\Windows Server 2003 Enterprise Edition.vmx.

You do not have access rights to this file

Naturally, it struck me that a) I'm admin on my own machine, so privileges seems unlikely, and b) it had worked fine on Thursday. As I: is a USB hard disc, I copied the VM to my local drive, but the problem persisted.

I made sure that permissions were the same for this VM and others - they were.

I tried upgrading VMWare from 6.0.1 to 6.0.2, just on the off-chance - the problem persisted.

I was trying to open the VM by double clicking on the .vmx file. I tried opening the VM through the 'file open' dialog too - that didn't work either. In fact, that caused VMWare to crash. I've attached the support dump from that.

In the end, one of my colleagues suggested removing all spaces in the VMX file name (based on this post: http://communities.vmware.com/message/716278#716278 ) - and that fixed it. If I put the spaces back into the VMX file name - errors again. The really weird thing is, though, that I have plenty of other virtual machines with spaces in the file name, and they seem to work just fine. Further, why did it work and then it start to raise errors when the file names hadn't changed?

Sounds like a fairly daft bug. I'm not sure how to report this to Support, though - I don't want to open a support call (removing the spaces works for me) - but I'd like to alert development/quality control. Something isn't right there.

Oh, I'm using VMWare workstation for Windows 6.0.2 on Vista

0 Kudos
7 Replies
continuum
Immortal
Immortal

You have Vista - have you checked file permissions ?

In Vista file-permissions change like the weather - so look there first

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
Andy_Burns
Contributor
Contributor

Yup. I actually went and copied the VM into the folder for a VM which worked, and applied permissions downward. The problem persisted. And I'm Admin on this machine anyway.

Besides, if it were a permission issue, why would removing the spaces fix it, and putting the spaces in the VMX file name break it again?

0 Kudos
continuum
Immortal
Immortal

Is the VM located in a very deep path ? - very long pathname ?

Whats the filesystem - ntfs or fat32 ?

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
Andy_Burns
Contributor
Contributor

No, the path was I:\MOSS003 - OCT07 Base\Windows Server 2003 Enterprise Edition.vmx. Not very long...

0 Kudos
Liz
Virtuoso
Virtuoso

I dont have vista to hand, but, this used to happen to XP machines to, if you could work out and translate thsi to vista process try:

Explorer -> Tools ->Folder Options-> File Types->

find the vmx file

click advanced

on open click edit

and check that the %1 is in double quotes

0 Kudos
teemark
Contributor
Contributor

your fix solved my problem with my initial access attempt following installation of 6.0.2. on WVista. have u reported the bug?

0 Kudos
Andy_Burns
Contributor
Contributor

Nope, I've not submitted this as a bug - I'm not sure how to do that.

But I did just get someone else saying that they had a similar issue on Vista - http://www.novolocus.com/2007/10/22/error-you-do-not-have-access-rights-to-this-file/

His problem involved numbers, not spaces, in the VMX file name, though.

Unfortunately, the problem seems very intermittent. Certainly, I've not had any issues with numbers in the file name.

0 Kudos