VMware Communities
jtaylordfw
Contributor
Contributor

Disabling Power-related keyboard shortcuts in VMWare Workstation

Hello -- I am using VMWare Workstation 6.0.1 and I am wondering if anyone knows how to disable (or alter) the power-related keyboard shortcuts (which can be accessed from the VM-Power menu). The one that is irritating me the most is CTRL-Z, which is the same keystroke as "Undo" in most editors. I'd love to be able to disable this functionality (or at least have VMWare prompt me with a confirmation dialog). Does anyone know how to modify these features?

12 Replies
oreeh
Immortal
Immortal

There is a confirmation dialog by default.

If you don't get it you disabled it in the past.

Check the config.ini or preferences.ini (can't remember which one at the moment) and reenable it.

Reply
0 Kudos
admin
Immortal
Immortal

There's a confirmation when powering-off but not one for suspending which is non-destructive.

Right now there's no way to disable or change those keyboard shortcuts.

You might wish to do things to make it more obvious when you're grabbed in the guest (I configure my guests to use different mouse cursors from the host).

Reply
0 Kudos
matthewls
Enthusiast
Enthusiast

I agree that changing these hotkeys is important. I keep accidentally rebooting the VM by hitting ^r, which refreshes many windows. Please let us customize these! Thanks.

matthewls
Enthusiast
Enthusiast

we discussed this about a year ago. Is there any way to disable the shortcuts? I just did it again--Ctrl-r reset the machine when I was actually trying to refresh the window of his looking at in another program.

Reply
0 Kudos
mdunn-vmware
Expert
Expert

If you're on Windows and you have a resource editor (Visual Studio for example), you can open vmware.exe in the editor and remove the accelerators that you don't want.

Reply
0 Kudos
matthewls
Enthusiast
Enthusiast

Thank you for the insight. I have delphi 32 somewhere, and guess it may have a resource editor.

...Well, I found a freeware resource editor but couldn't find the right parts...probably 'cause the editor is not fully unpacking the exe...

OK! Found another editor and it shows acccelerators...now I need the key codes but that should be easy.

Thanks again!

Reply
0 Kudos
matthewls
Enthusiast
Enthusiast

I'm sure you're busy, but if you've got the time:

Inside the vmware.exe resources are two accelerator groups, 115 and 41909. Each contains the line that I suspect is the culprit:

VK_R, 40021, NOINVERT, CONTROL, VIRTKEY

True?

mdunn-vmware
Expert
Expert

Right, the parts to look at are the modifier keys (CONTROL) and the virtual key code (VK_R). The rest of the fields are only meaningful to the developers.

Reply
0 Kudos
matthewls
Enthusiast
Enthusiast

Super. Thanks again.

Reply
0 Kudos
matthewls
Enthusiast
Enthusiast

I forgot to mention that removing the VK_R key solved my inadvertent rebooting vm with ^r. Yippee!

kopseng
Enthusiast
Enthusiast

What is the name of the freeware editor you used to find the "accelerators", Matthew? Rebooting by mistake is still an issue 15 years later 😁

By the way, if there are more "modern" ways of achieving this, then please let me know.

Reply
0 Kudos
kopseng
Enthusiast
Enthusiast

The resource editor approach worked perfectly on VMWare 15.5 using Resource Tuner by Heaventools, following the listed approach. I added a full answer on SuperUser with screenshots for the interested.

Reply
0 Kudos