uvdevnull
Enthusiast
Enthusiast

Disable sound upon grab and release focus

Jump to solution

Every time focus is grabbed or released, a sound is played. How do I stop it?

0 Kudos
1 Solution

Accepted Solutions
uvdevnull
Enthusiast
Enthusiast

Thank you wila​,

Your mention that it was not a VMware feature but Windows itself, I started going down that path and found that it was the "Default Beep" that was set to "Windows Background.wav" that was making that sound. I disabled it. Obviously it will affect other things that use the Default Beep but at least I'm not so annoyed by moving the mouse in and out of the VM guest.

pastedImage_0.png

View solution in original post

0 Kudos
4 Replies
Alex_Romeo
Leadership
Leadership

Hi,

when you open a post you must always specify the product and the version. This information helps us to direct more precisely to the solution.

check if you solve with this, otherwise provide us with the information:

Setting Preferences for VMware Workstation

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
wila
Immortal
Immortal

Hi,

Assuming you are running Windows...

This is not a standard feature of VMware, if you hear this then it is something done by the operating system.

On Windows 10 you can configure sounds for events via:

Settings -> System -> Notifications & Actions -> then under "get notifications for these senders" -> Click on "Audio" -> it will show a new screen where you can tweak

If that doesn't help.. (fair chance)

Settings -> System -> Sound - scroll down - App Volume and device preferences

See if it has a setting for your grab/release focus or anything with VMware

If that still doesn't help.. (possible)

Settings -> System -> Sound - at the right hand side - "Sound Control Panel"

Go to tab page "Sounds" and search for the sound you are hearing in the enabled "Program events"

In your case I would probably go straight to the "Sound Control Panel", but I don't know what exactly you are seeing.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
uvdevnull
Enthusiast
Enthusiast

Thank you wila​,

Your mention that it was not a VMware feature but Windows itself, I started going down that path and found that it was the "Default Beep" that was set to "Windows Background.wav" that was making that sound. I disabled it. Obviously it will affect other things that use the Default Beep but at least I'm not so annoyed by moving the mouse in and out of the VM guest.

pastedImage_0.png

0 Kudos
dariusd
Leadership
Leadership

I don't think Workstation is producing the beep.  Something else on your host may be producing the sound in response to Workstation's grab/ungrab and its effects on the keyboard, mouse or clipboard.

Do you have any 3rd-party software/drivers installed on your Windows host for support or enhancement of keyboard, mouse or clipboard functions?

Have you enabled any of the Ease of Access options in the settings on your host?  Some of those may produce audible feedback – although I do not know of any which would produce the Default Beep, it may still be worth checking out those settings.

--

Darius

0 Kudos