Kiwitech62
Contributor
Contributor

Device/Credential Guard error on Windows 10 Home

Jump to solution

I recently upgraded to the latest version of VMware Workstation (14.1.1) and am now encountering the following problem when trying to launch VM's that worked fine previously.

"VMware Workstation and Device/Credential Guard are not compatible. VMware Workstation can be run after disabling Device/Credential Guard. Please visit http://www.vmware.com/go/turnoff_CG_DG for more details."

Problem is that I'm running Windows 10 Home and the Device/Credential Guard is not a feature of that version - it's in Windows 10 Enterprise.

VMware Workstation version: 14.1.1 build 7528167

Windows 10 version:  Windows 10 Home - Version 1083 (build 17115.1)

As mentioned previously the VM's worked fine on the previous version of Workstation 14 on Windows 10 Home. The suggestions to turn off Device/Credential Guard for Windows 10 all relate to the Enterprise version and Hyper-V, which doesn't run on the Home version so the settings to change don't exist.

Appreciate any assistance or suggestions to resolve my problem.

1 Solution

Accepted Solutions
Scillonian
Hot Shot
Hot Shot
Windows 10 version:  Windows 10 Home - Version 1083 (build 17115.1)

This could be a bug/feature in the Insider Preview builds for 1803. This is from the Windows 10 Feedback Hub using vmware as the search criteria:

WooHoo fix for VMware  Device Security/Credential Guard issues

Well Boys and Girls after reading through the release notes for build 17093 in the wee small hours of the night, I have found the change point that affects my VMware Workstation VM's causing them not to work,  it is the Core Isolation settings under Device Security under windows security (new name for windows defender page) in settings.  By default it is turned on, however when I turned it off and restarted my pc all my VMware VM's resumed working correctly.  Perhaps a by device option could be incorporated in the next build to allow us to test individual devices / Apps responses to allow the core isolation to be on or off per device or App as required .

From the Start Menu: Windows Defender Security Centre > Device Security > Core Isolation.

I'm only running the Insider Preview as a 32-bit VM which does not support the minimum requirements for Device Security so cannot test this solution.

View solution in original post

27 Replies
Scillonian
Hot Shot
Hot Shot
Windows 10 version:  Windows 10 Home - Version 1083 (build 17115.1)

This could be a bug/feature in the Insider Preview builds for 1803. This is from the Windows 10 Feedback Hub using vmware as the search criteria:

WooHoo fix for VMware  Device Security/Credential Guard issues

Well Boys and Girls after reading through the release notes for build 17093 in the wee small hours of the night, I have found the change point that affects my VMware Workstation VM's causing them not to work,  it is the Core Isolation settings under Device Security under windows security (new name for windows defender page) in settings.  By default it is turned on, however when I turned it off and restarted my pc all my VMware VM's resumed working correctly.  Perhaps a by device option could be incorporated in the next build to allow us to test individual devices / Apps responses to allow the core isolation to be on or off per device or App as required .

From the Start Menu: Windows Defender Security Centre > Device Security > Core Isolation.

I'm only running the Insider Preview as a 32-bit VM which does not support the minimum requirements for Device Security so cannot test this solution.

View solution in original post

Kiwitech62
Contributor
Contributor

That solution worked successfully. Much appreciated Smiley Happy

0 Kudos
LeoViotti
Contributor
Contributor

Finally a solution that works! The suggestion from VMware KB is all but useless.

0 Kudos
shsmmi
Contributor
Contributor

Facing the same problem, tired all the suggestion and trieded what you said but still struggle

Edition: Windows 10 Home , Version 1083, OS build 17134.228, Installed on 05 jun 2018

System type 64-bit operating system, x64- based processor

Appreciate any assistance or suggestions to resolve my problem.
0 Kudos
shsmmi
Contributor
Contributor

Device/Credential Guard error on Windows 10 Home

Facing the same problem, tired all the suggestion and trieded what you said but still struggle

Edition: Windows 10 Home , Version 1083, OS build 17134.228, Installed on 05 jun 2018

System type 64-bit operating system, x64- based processor

Appreciate any assistance or suggestions to resolve my problem.
0 Kudos
yanw
VMware Employee
VMware Employee

Hi, shsmmi:

Although i am not sure why workstation has detected the Device Guard running on you Win10 home edition. Would you please try to disable the Windows Device Guard according to this link?

Manage Windows Defender Credential Guard (Windows 10) | Microsoft Docs

0 Kudos
dudustefanello
Contributor
Contributor

Hi yanw, I have the same problem.

But in Windows 10 Home, Windows Defender Credential Guard is not enabled.

shsmmi also uses Windows 10 Home.

0 Kudos
shsmmi
Contributor
Contributor

in window open task manager then move to services and open it move down to stop all hyper-v try this

0 Kudos
medori4
Contributor
Contributor

Excelente. Gracias a esta respuesta pude resolver mi problema. Muchas gracias.

0 Kudos
redelinux
Contributor
Contributor

Just run cmd as Admin and type

bcdedit /set hypervisorlaunchtype off

and REBOOT

this will fix

and if you need hypervisor for something like windows emulator tools in visual studio just re-enable when you need by typing

bcdedit /set hypervisorlaunchtype auto

and REBOOT

Credential Guard is enabled by hypervisor, and when you disable hypervisorlaunchtype, it disables it. No there is no way to use VMWARE Workstation 14 with this enabled, because they don't support the use of stubs to access hardware through their VMs yet. Anyway, microsoft virtualization sucks so, disable it and keep using VMWARE as it is the fastest one on the market.

SVTMLLC
Contributor
Contributor

This was the easiest workaround I've found on the web. It works in combination with turning off Core Isolation in Win10 Home edition. Now I need to do it for all the systems that downloaded the latest Windows Update.  Thank you for this quick fix. -p

0 Kudos
UAreZbest
Contributor
Contributor

It works ! Thank you so much Smiley Happy

It is a small step for the Man, but a step of giant for VMware

0 Kudos
mharoutunian
Contributor
Contributor

Does anyone know if credential guard or any of the other Win 10 enterprise security settings mentioned like core guard are compatible with VMware Workstation 15?  My organization has these things enabled by GPO settings which is a pain to get a waiver and when I reconnect laptop to network it undoes everything I followed in the KB to fix it.

If not, the KB should really be changed to state all VMware Workstation versions are incompatible with these Windows 10 features, not just 12 and below when higher versions like 14 don't work either.

willypreston
Contributor
Contributor

For those still struggling to get it working, I attempted everything I could find in my searches and still could not get Workstation functioning in the 18xx builds of Windows10.

The last couple things I tried finally got it working.  These were:

-Disabling all the Windows services that start with Hyper-V and rebooting.

-Going into Defender(Windows Security)->App and Browser Control->Program Settings->add vmware.exe and then 'override' all of the options listed but set all of them to 'off''.

Afraid I don't know which was the final option which got me working, but really tried of messing with it.

0 Kudos
fvildoso
Contributor
Contributor

thanks, it works!

0 Kudos
JerryLerman
Contributor
Contributor

Awesome! It worked. Thank you very much!

0 Kudos
NRay
Contributor
Contributor

Resolution is provided in the VMware KB 2146361

For more information visit: VMware Workstation and Device/Credential Guard are not compatible. VMware Workstation can be run aft...

0 Kudos
lindros2
Contributor
Contributor

wrong. does not work.

0 Kudos
amoTom
Contributor
Contributor

It need uninstall new MS feature Windows Sandbox

It similar problem as Hyper-V