VMware Communities
Karti
Contributor
Contributor
Jump to solution

Dark Theme - Workstation Pro - Linux

Hi,

Looking at purchasing the Workstation Pro, but I cannot see any way to change the overall view to a dark theme, which TBH will be a stopper.

Could someone clarify that the Linux version only uses white (light theme)

Any comments appreciated.

Cheers

K

Reply
0 Kudos
1 Solution

Accepted Solutions
dariusd
VMware Employee
VMware Employee
Jump to solution

Workstation for Linux will use the theme settings from your desktop environment.  If your desktop is set to a dark theme, Workstation will also use a dark theme.  In the following screenshot, I am using Debian 11, and have used the gnome-tweaks application (in the bottom-right corner) to set the desktop to the Adwaita-dark theme, and Workstation seems to be appearing in the dark theme, as expected:

WS17-dark-theme.jpg

As far as I am aware, workstation 17 does not have any way to set the theme to anything other than the desktop theme.

View solution in original post

4 Replies
kCentre
Contributor
Contributor
Jump to solution

There's no theme option in preferences on linux hosts for 15, 16 and 17 Pro versions.

Reply
0 Kudos
louyo
Virtuoso
Virtuoso
Jump to solution

I am running on Debian 11.5. WS itself takes on the theme of my desktop (Mate). This does not affect the virtual machines, they use their own themes. 

Reply
0 Kudos
dariusd
VMware Employee
VMware Employee
Jump to solution

Workstation for Linux will use the theme settings from your desktop environment.  If your desktop is set to a dark theme, Workstation will also use a dark theme.  In the following screenshot, I am using Debian 11, and have used the gnome-tweaks application (in the bottom-right corner) to set the desktop to the Adwaita-dark theme, and Workstation seems to be appearing in the dark theme, as expected:

WS17-dark-theme.jpg

As far as I am aware, workstation 17 does not have any way to set the theme to anything other than the desktop theme.

Karti
Contributor
Contributor
Jump to solution

Thanks, TBH I thought my system was already set to dark (running Kubuntu) but a quick change and it gave me the dark theme. 

Much appreciated.

Karti_0-1669662258004.png

 

Reply
0 Kudos