Highlighted
Contributor
Contributor

Crash during update - can't reinstall

My system crashed while I was updating VMware workstation from 10.0.0 to 10.0.2.

Now, when I now try to un- or re-install VMware WS, I always only get:

-------------------------

"Another installation is already in progress

Please wait until that installation is complete and try again".

-------------------------

Since "that installation" is NEVER going to complete: what are my options? How do I rectify this?

This is on Windows 7 (Enterprise / 64bit)

M.

0 Kudos
3 Replies
Highlighted
User Moderator
User Moderator

Please take a look at VMware KB: Cleaning up after an incomplete uninstallation on a Windows host to see whether this helps solving the issue.

Just to rule that out, did you rename the installation .exe file? Please either use the original name and or a name other then e.g. vmware-workstation.exe ...

André

0 Kudos
Highlighted
Expert
Expert

0 Kudos
Highlighted
Contributor
Contributor

this is an old thread, sorry for the bump but the same thing happened to me, win10 crashed in middle of upgrade.
i think you found an answer in the last 6 years 🙂 just posting here in case someone else has same issue

to fix it, 

open window explorer 
in the address bar enter   %temp%
find a file called vmUpdateLauncher-........ and open in 
there will be location of the updater. just either copy paste the whole string and paste into cmd prompt or find it in explorer and double click.

1605914255 Connected to pipe = 00000334
1605914255 pipe = 00000334
1605914256 Connected to pipe = 00000308
1605914257 Connected to pipe = 00000334
1605914257 [RX] type=0 error=FALSE program='C:\Users\....\AppData\Local\VMware\vmware-download-16C8\cdstmp_ws-windows_15.5.7_17171714\VMware-workstation-15.5.7-17171714.exe' cmdLine='"C:\Users\.....\AppData\Local\VMware\vmware-download-16C8\cdstmp_ws-windows_15.5.7_17171714\VMware-workstation-15.5.7-17171714.exe"' processId=0 exitCode=0
1605914258 Calling CreateProcess:
0 Kudos