poiu123
Contributor
Contributor

Copy & paste uses incorrect keyboard layout

I'm running Workstation 15.1 on a Windows Server 2016 Standard host with a Debian9 Linux guest. Latest open-vm-tools and open-vm-tools-desktop are installed. Both, drag & drop and copy & paste are enabled in the guest isolation settings.

Anyhow, whenever I am copying a string from windows that includes pipe characters, quotes or similar, such as "foo" (including the quotation marks) it gets pasted as @foo@ in the guest. I couldn't find anything that seems to be related in the preferences or VM settings.

copying a string from windows on the debian shell

for example,

apt-get update && apt-get upgrade

gives

2019-06-12_094540.png

however typing out the commands on the shell works without any problems

Any idea on how I can fix this?

0 Kudos
1 Reply
continuum
Immortal
Immortal

Do you use a different keyboard layout on host and guest ?

I see this effect all the time when working remotely so I dont bother and use a putty session instead.


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos