scottmay
Contributor
Contributor

Client machines freeze momentarily but regularly - Ubuntu 14.10 x64 host machine, Linux and Windows clients

Jump to solution

Hi.  I've been using Workstation for a great many years so I would say I have my expectations set reasonably.

My main desktop machine:

-  Intel i7 (4950 I think) processor, 16G memory, Samsung 850 Pro SSD, Ubuntu 14.10 x64 operating system, VMWare Workstation 11.1

It runs really well, but my client machines, be they Windows 7 Enterprise or Ubuntu 14.04 LTS frequently "stutter" in use.  When the stuttering is going on, the host machine is showing relatively high CPU on vmware-vmx at 15 to 20 according to 'top'.  The stuttering might happen every minute or two, for maybe 5 to 10 seconds at a time.  It's annoying, but when I'm using CAD software in the client machine it's downright dangerous as short cut keys get missed, either partially or entirely, and generally bad things happen.

What can I monitor or try to stop this stuttering?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
scottmay
Contributor
Contributor

I'm going to call this solved - finally.  I thought I was going to have to keep using Virtual Box forever - a sad prospect.  This problem persisted into Version 12 Pro as well.

I can't believe I'm the only one having this problem - especially when its's happening on both machines - 2 for 2.  Actually I found another having this problem:

VMware workstation 11 on Ubuntu 15.04 high cpu utilization solved

VMware 11 workstation on Ubuntu with windows guests freezes from time to time with very high cpu utilization. The process vmware-vmx and khugepaged get 100% cpu time for a couple of seconds. The khugepaged is the process that configures the transparent hugepages. When i disable the transparent hugepages windows guest run without freezes again. To disable it on every operating system start up i put in /etc/rc.local
##################

if test -f /sys/kernel/mm/transparent_hugepage/enabled; then

   echo never > /sys/kernel/mm/transparent_hugepage/enabled

fi

if test -f /sys/kernel/mm/transparent_hugepage/defrag; then

   echo never > /sys/kernel/mm/transparent_hugepage/defrag

fi

##################

Solved Smiley Happy

View solution in original post

4 Replies
bgh89928
Enthusiast
Enthusiast

it might be your SSD causing the issue.

Samsung have announced that their SSDs (some of them, not sure which models) were having issue with sudden read/ write speed drop to ~10Mbps.

The issue have been fixed with their newest firmware update. So if you haven't updated your SSD's firmware, try it.

Also, if you could please provide your Workstation's specification. so the others can look at give you more reliable solution.

0 Kudos
scottmay
Contributor
Contributor

Thanks for that.  According to the Samsung website there's no update for the 850 Pro SSD I mentioned as my machine using, so, no not that.  While on that - I'm happy to provide additional details of my workstation, but what relevant items have I missed?  I will admit to neglecting that the virtual machines I run live on a Western Digital 7200 rpm hard disk, but that's nothing new.

Also, top reports specifically that vmware-vmx goes super busy at the time the stuttering happens - clearly the two are related - I'm just stuck trying to find a cause, and so then a solution.

0 Kudos
bgh89928
Enthusiast
Enthusiast

ok, so your workstation is running on 7200rpm HD.

Here are some solutions I could provide to you.

- For the Host machine -

first, I want you to see if your host PC's power management setting is set to "maximum performance".  I have never used Ubunto before so I do not know if your OS has the option for it but see if your OS is managing your PC in "power saving mode".  Also, see if your HD is enable to be turned off when it is not under load.

second, some motherboard provides feature called like "energy saving mode".  Go to BIOS setting and see if any of energy saving mode is enabled, if yes, disable it and see if the problem goes away.

third, tries to hear any weird sound when your workstation is not responding.  sounds like ticking or HD motor starts to spinning.  Continuous or multiple of ticking sounds represents unrecoverable bad sectors on your HD or even physical damage on your HD.  If you hear single or no ticking sound but hear HD motor starts to spinning, then refer back to my "first" and "second" part.  it is the sounds that your HD was turned off and starts to run again.

-For the Virtual machine -

First, check if your workstation's hard drive is configured as (Pre allocated).  If you are running the workstation on the SSD this would not cause any delaying or freezing but since your workstation is running under HD, as your virtual machine uses its HD, VMware tries to expand/ decrease the size of your Virtual machine's HD size.  Which may cause significantly short but regularly delaying of response..

Second, I did not recommended you to do the defragment when I first saw your post because I though your workstation is running under SSD, but now I know your workstation is running under HD, so I want you to try defragmenting your HD.  (DO the defragment on your host HD first, then do defragment on your virtual machine.)

Third, on your workstation, if you have given enough RAM, disable "virtual memory".

Fourth, if your windows system does not require any system protection (windows restore point), turn it off.

Fifth, turn off all the visual affect and any unnecessary background running programs.

Based on my experience, those short freezing is mostly caused by heavy/ busy workload on your HD.  I had similar freezing problem like you do, bun mine was long freezing and sometimes I had to forcefully power of the workstation.  And I have found that my HD was causing the issue.  Therefore, I only provided solutions based on the HD.

However, the freezing you are experiencing is maybe caused by some other reason(s) and my solutions may not fit to your situation but I hope you find right solution and resolve the issue.

Also, in this forum there are many VM professionals willing to help you out, so do not hesitate to throw out the questions you have right now.

0 Kudos
scottmay
Contributor
Contributor

I'm going to call this solved - finally.  I thought I was going to have to keep using Virtual Box forever - a sad prospect.  This problem persisted into Version 12 Pro as well.

I can't believe I'm the only one having this problem - especially when its's happening on both machines - 2 for 2.  Actually I found another having this problem:

VMware workstation 11 on Ubuntu 15.04 high cpu utilization solved

VMware 11 workstation on Ubuntu with windows guests freezes from time to time with very high cpu utilization. The process vmware-vmx and khugepaged get 100% cpu time for a couple of seconds. The khugepaged is the process that configures the transparent hugepages. When i disable the transparent hugepages windows guest run without freezes again. To disable it on every operating system start up i put in /etc/rc.local
##################

if test -f /sys/kernel/mm/transparent_hugepage/enabled; then

   echo never > /sys/kernel/mm/transparent_hugepage/enabled

fi

if test -f /sys/kernel/mm/transparent_hugepage/defrag; then

   echo never > /sys/kernel/mm/transparent_hugepage/defrag

fi

##################

Solved Smiley Happy

View solution in original post