Jarod725
Contributor
Contributor

Changing Workstation Server Port

Jump to solution

Author :

URL : http:////docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-2A5EC2D9-E49D-4...

Topic Name : Configuring Workspace Preference Settings

Publication Name : Using VMware Workstation Pro

Product/Version : VMware Workstation Pro/16.0

Question :

I see many references to changing the default port (443) under Edit > Preferences > Shared VMs ... but this doesn't exist in WS Pro 16.  So how do I change it?

1 Solution

Accepted Solutions
Mikero
Community Manager
Community Manager

The binaries are still there, but the UI is disabled, so if there's an existing autostart config it will still load.

That said, we will be removing the binaries in the next release which is slated for November, so this issue should vanish.

(FWIW, I am so sorry we had to remove this feature... )

-
Michael Roy - PM/PMM: Fusion & Workstation

View solution in original post

7 Replies
scott28tt
VMware Employee
VMware Employee

Workstation 16 doesn't support the Shared VMs feature.

This is mentioned in the Product Support Notice here: VMware Workstation 16 Pro Release Notes


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
Jarod725
Contributor
Contributor

Thank you, @scott28tt!  I understand that the feature was removed and that's why the preferences tab is no longer available.  The issue I've encountered is that vmware-hostd.exe still attaches to port 443 when the VMWare Workstation Server service is running.  From what I've found, for versions < v16, the advice was to edit the setting under Shared VMs in preferences.  Since that's no longer present, I'm not sure how to go about changing that process to listen on a different port.

My apologies for not being more clear in the original question, and thanks again for the quick response!

0 Kudos
RDPetruska
Leadership
Leadership

Well, with the removal of the Shared VM feature, the vmware-hostd service *should* no longer exist, therefore it should NOT be attaching to that port 443.

0 Kudos
Mikero
Community Manager
Community Manager

The binaries are still there, but the UI is disabled, so if there's an existing autostart config it will still load.

That said, we will be removing the binaries in the next release which is slated for November, so this issue should vanish.

(FWIW, I am so sorry we had to remove this feature... )

-
Michael Roy - PM/PMM: Fusion & Workstation
sjesse
Leadership
Leadership

Not sure you can answer these questions or not here, but why was it removed, just not enough interest? I used to rely on it before I bought my own esxi server and which meant i didn't need to use this feature anymore, but at the time I relied on it.

0 Kudos
starwellian
Contributor
Contributor

I've updated, but still the vmwarehost-d is being started and claiming port 443 which is not allowing me to install software that needs that port - is there something else I need to do?

0 Kudos
wila
Immortal
Immortal

There was a lot of complaints, so the feature is still lingering around for a bit.

You can disable the vmware-hostd service in your windows services and the port will be free. (Windows task manger -> Services tab page -> Open Services link at the bottom -> VMwareHostd

Stop & disable

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos