Justagrl
Contributor
Contributor

Cannot Start Virtual Machine or Go To SnapShot 'Error Restoring Snapshot...disk already in use'

The virtual machine is paused.  Attempting to resume virtual machine displays message 'VM Workstation has stopped working"

Attempting to go to snapshots in yellow attached causes same error

Attempting to go to snapshot shaded grey attached displays message 'Error restoring snapshot: One of the disks in this virtual machine is already in use by a virtual machine or by a snapshot.

How did I get here? I was deleting snapshots via Snapshot Manager to create disk space.  I received a message that there was not enough space to clean up the files. I attempted to clean up the files manually and 'muffed it'.

I did attempt to follow instructions in this discussion 'Unable to open .vmdk file. One of the disks in this virtual machine is already in use by a virtual m...

But I was stopped after running Command line 04 with the message 'Failed to convert disk: A file was not found (0x4)'.

See attached screen of SnapShot Manager with above comments, directory listing and logfile.

Can anyone help?

0 Kudos
1 Reply
continuum
Immortal
Immortal

All the embedded descriptorfiles will be necessary - read on here
VMDK-Handbook-Basics

Maybe you also need to ignore the vmsd,vmsn and vmen data .


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos