TITANcorp
Contributor
Contributor

Cannot Install SVGA Drivers on Windows 95 in VMWare Workstation

Hello, I am attempting to Install VMware Tools on a virtual Windows 95 system in VMware Workstation. However, I can not seem to help Windows 95 detect the VMware SVGA Driver.

I am using Windows 95 in VMware Workstation 8.0.6 build-1035888. The Windows 95 system boots as normal, but remains fixed in VGA mode as it cannot detect SVGA drivers.

Upon attempting an installation of VMware Tools, as outlined in the documentation, I receive the following error report:

This program has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor.

2.png

By right-clicking the CD icon, and launching an executable called instmsia.exe, I may then open the VMware Tools.msi file on the VMWare ISO. However, I receive a further error:

Setup failed to install the SVGA driver automatically. This driver will have to be installed manually. Instructions for how to do this will appear at the end of the installation.

Untitled.png

Unfortunately, no instructions appear, and after I reboot, the system does not detect the VMware driver. Also at this stage, I am not completely sure if the installation is complete.

When I attempt to install the VMWare SVGA Driver manually, through the Add Hardware window, and adding the driver via C:\program files\VMware\VMware Tools\Drivers\Video, the system reports further errors, and cannot detect the driver fully.

I have checked the documentation thoroughly, and cannot find an answer as to how to install VMware Tools in the system, as I keep receiving these errors. I have found the following threads on the VMware community website to be on my topic, but no clear answer seems forthcoming:

https://communities.vmware.com/message/1682171#1682171

https://communities.vmware.com/message/1416805#1416805

Thanks for any help anyone could give me and apologies if this has already been covered

0 Kudos
8 Replies
Nicole54
Contributor
Contributor

Hi

Welcome to the communities.

Strange you are testing win95 ,sorry no want to hurt you .

could you please let me know what you want to archive?

“Control Your Own Destiny or Someone Else Will”
0 Kudos
jontech
Contributor
Contributor

This is a bit of an old thread but I had the same issue and came across the solution

After I removed the VMware tools from the Windows 95 host, rebooted then reinstalled, it showed these instructions.

Screen Shot 2016-02-06 at 12.00.12 PM.png

0 Kudos
Ahmed_Selim
Enthusiast
Enthusiast

Hi,

Welcome to our community.

Did you checked this vmware KB VMware KB: Configuring the SVGA video driver on older versions of Windows virtual machines

--- If you found my answers useful please consider marking them as Helpful or Correct Kind regards, Ahmed Selim
0 Kudos
lazyguyMC
Contributor
Contributor

I know the problem, but DON'T know how to fix it. The Drive is labeled 'VMware Tool' instead of 'VMware Tools' The automatic installer goes to a config file, redirecting to the instalation disk. The config file would redirect to 'VMware Tools', but it's labeled 'VMware Tool' so it can't install. Now, don't go adding the "S" back, because it won't work. Windows 95 only alows 11 characters on a label unlike 12 on other operating systems (e.g Win 2000). To fix it, you must go to the configuration file, and change it so ist looks in 'VMware Tool'. I don't khow how to do that but if you can, upload the file to the cloud and share it.

0 Kudos
LGMailhos
Contributor
Contributor

The previous answer was almost correct. Just type "C:\Progra~1\VMware\VMware~1\Drivers\Video" instead of "C:\program files\VMware\VMware Tools\Drivers\Video"

0 Kudos
exsubnuke57
Contributor
Contributor

I cheated.  Didn't want to type in the long string, so just surfed to C:\Program Files\VMware\VMware Tools\Drivers and copied the video folder to C:\.

Then I did the Control Panel/Display/Settings/Advanced Properties/Adapter thing, clicked the Change button and chose VMware SGVAII.  Rebooted, and when all came back up, I had lots of screen resolutions to choose from, as well as True Color (32 bit).

0 Kudos
exsubnuke57
Contributor
Contributor

Forgot to mention, when I chose "Have Disk", I just entered C:\video

0 Kudos
rcmoore76137
Contributor
Contributor

I tried to install drivers, but no matter what I do Windows says there's a conflict with the VGA driver and it won't let me switch. I've tried Windows 98 and ME and they work fine. What gives?

0 Kudos