lepus-io
Contributor
Contributor

Can't passthrough mouse to guest VM

Jump to solution

Hello,

I can't select any mouse ( or HID) in removable devices.

I'm running vmware workstation 16 pro on OpenSUSE Tumbleweed.

Guest is Windows 10 PRO

"Show all USB Input Devices is enabled in Hardware options

I have modified the vmx with:

usb.generic.allowHID = "TRUE"

usb.generic.allowLastHID = "TRUE"

I've connected three mouse to the host.

 

I'm not able to see or select any mouse to send directly into the VM.

Could anyone kindly help me? πŸ™‚

 

Thank you!

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

That would suggest that the usbarbitrator service is either not running or not working correctly.

You're not alone, I see somebody else having issues here:
https://communities.vmware.com/t5/VMware-Workstation-Player/Cannot-detect-USB-devices-cannot-start-v...

But that's on Arch, not Suse.

First thing is to check if that service is running.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
7 Replies
wila
Immortal
Immortal

Hi,

This would be the relevant KB article:
https://kb.vmware.com/s/article/1033435

Did you shut down the vm before editing the vmx?

Are the mice not showing up under the USB connected devices after that change?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lepus-io
Contributor
Contributor

Hi wila,

 

thank you for the answer.

I followed that, and other, guides. 

I did all the steps, but nothing changed.

For example in the steps:

  • Go to VM > Removable Devices.
  • Find and select your keyboard/mouse.

 

In the Removable devices I can read only:

  • Network Adapter
  • Printer
  • Sound Card

lepus-io_0-1614068292224.png

 

When i changed the .vmx the VM was turned off.

 

Thank you!

 

0 Kudos
lepus-io
Contributor
Contributor

hello...

I noticed that any kind on USB device is not visibile... for example I can't connect a USB key to transfer data.

 

Any advice?

0 Kudos
wila
Immortal
Immortal

Hi,

That would suggest that the usbarbitrator service is either not running or not working correctly.

You're not alone, I see somebody else having issues here:
https://communities.vmware.com/t5/VMware-Workstation-Player/Cannot-detect-USB-devices-cannot-start-v...

But that's on Arch, not Suse.

First thing is to check if that service is running.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lepus-io
Contributor
Contributor

hi wila,

 

thank you... that was the problem.

In SUSE tumbleweed the vmware service doesn't start at boot, I don't know why but also using YAST I can't do that.

Anyway, everytime I need the workstation I run manually 

 

sudo systemctl start vmware.service

 

 and it works.

Now I updated the script:

 

sudo systemctl start vmware.service
sudo vmware-usbarbitrator

 

 and now I can see the usb devices in removable devices.

Also note that I can see the mouse and keyboards devices only in the VMs where I modified the vmx like in the KB guides.

I think that the services problem have to do with the kernel... I'm running 5.10.16-1-default by now, while in the OpenSUSE 15.2 I have not services problem and it is running the 5.3.18-lp152.63-default kernel.

I hope this informations will be of any help to someone else.

Manually run a script every time i boot is not ideal, but it works.

 

 

Thank you for your help.

0 Kudos
wila
Immortal
Immortal

Hi,

If you want the service to run automatically on boot then try:

 

sudo systemctl enable vmware.service

 

--

Wil

 

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lepus-io
Contributor
Contributor

Hi,

 

yes I tried that way, but it gave me an error.

sudo systemctl enable vmware.service
[sudo] password for root: 
vmware.service is not a native service, redirecting to systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable vmware
/usr/lib/systemd/systemd-sysv-install: line 31: chkconfig: command not found

 

I tried to install chkconfig with zypper or YAST, but it didn't find a provider for that package.

I didn't investigate more because the workaround was enough for my needs.

 I noticed that some distros left out chkconfig and I guess Tumbleweed is one of them, I think OpenSUSE Leap is still using it tho.

 

 

0 Kudos