Contributor
Contributor

Can't get shared folders working in FreeBSD 12.1 guest

I have VMware® Workstation 15 Pro 15.5.1 build-15018445 which I'm running on a Linux Mint 19.2 Cinnamon 64-bit host on an Intel NUC8i7BEH. I've successfully installed FreeBSD 12.1 as a guest in VMware and I *almost* have everything working except for shared folders. I've tried just about everything but, although they're enabled, went I try to mount a shared folder from within the guest OS, I get an error of "file not found" or something like that.

Any help would be appreciated.

Thanks,

jdb2

0 Kudos
1 Reply
Contributor
Contributor

I have made a little progress :


$ sudo vmhgfs-fuse -o allow_other -o uid=1001 .host:/[censored] /mnt/share
$ sudo mount -l zroot/ROOT/default on / (zfs, local, noatime, nfsv4acls) devfs on /dev (devfs, local, multilabel) zroot/tmp on /tmp (zfs, local, noatime, nosuid, nfsv4acls)
zroot on /zroot (zfs, local, noatime, nfsv4acls)
zroot/var/crash on /var/crash (zfs, local, noatime, noexec, nosuid, nfsv4acls)
zroot/var/mail on /var/mail (zfs, local, nfsv4acls)
zroot/usr/src on /usr/src (zfs, local, noatime, nfsv4acls)
zroot/var/tmp on /var/tmp (zfs, local, noatime, nosuid, nfsv4acls)
zroot/var/log on /var/log (zfs, local, noatime, noexec, nosuid, nfsv4acls)
zroot/usr/home on /usr/home (zfs, local, noatime, nfsv4acls)
zroot/usr/ports on /usr/ports (zfs, local, noatime, nosuid, nfsv4acls)
zroot/var/audit on /var/audit (zfs, local, noatime, noexec, nosuid, nfsv4acls)
/dev/fuse on /mnt/share (fusefs)
$ cd /mnt/share cd: /mnt/share: No such file or directory
$ cd /mnt/freebsd-share/
$ ls test.txt
$ ls -lah total 3 drwxrwxrwx  2 root  wheel    3B Jan 12 12:18 . drwxr-xr-x  4 root  wheel    4B Jan 12 12:13 .. -rw-r--r--  1 jdb2  wheel    0B Jan 12 12:18 test.txt
$ touch test2.txt
$ ls -lah total 4 drwxrwxrwx  2 root  wheel    4B Jan 12 12:22 . drwxr-xr-x  4 root  wheel    4B Jan 12 12:13 .. -rw-r--r--  1 jdb2  wheel    0B Jan 12 12:18 test.txt -rw-r--r--  1 jdb2  wheel    0B Jan 12 12:22 test2.txt
$

It seems I can now mount the shared directory, but, anything I do to it doesn't show up in the host directory

Any help would be appreciated

Thanks,

jdb2

0 Kudos