VMware Communities
acymiranda
Contributor
Contributor

Can't connect via VPN

Hi, everyone! This is my first post here!

I'm not very aware of network configuration (NATs and Bridges and so on), so I'll write in very basic mode πŸ™‚


I have a physical Win7 machine and, on this machine, I've installed a Windows Server 2008 on a VMWare Workstation. This VM will be used as a server to web development projects.

In the Win 2008, I enabled remote desktop connections and also configured Routing Remote Access, so users can connect to this machine via VPN.

Also, I've configured a no-ip host in Win 2008, for example, "myserver.no-ip.info". On Win 7 (physical machine), pings to myserver.no-ip.info returns all packs, so I think this host name is working.

But, in Win 7, I've set up a VPN to connect to the Win 2008 VM, but it never connects... throws a tunnel error. And connecting via Remote Desktop didn't work too. It says the the host is unreacheable or it's off etc.

The VM is configured to NAT.

What could be the problem? Why ping to host works but vpn to the same host doesn't? I've also tried to connect to VM through different physical machines, but neither worked.

Firewall is OFF in both physical and vm machines.

Thanks!

Reply
0 Kudos
7 Replies
PShahood
Contributor
Contributor

Try using BRIDGED - I use it with VPN daily.   I did have a problem with NAT before...

Reply
0 Kudos
0WayneH0
Hot Shot
Hot Shot

+1 -- Bridged (you want your VM to look like any other computer)

Reply
0 Kudos
acymiranda
Contributor
Contributor

I've tried Bridged too, but it is still the same situation...

I've just write the no-ip host on remote desktop access window and it keeps trying to connect and the exception occurs.

Am I missing something? Do I have to make any aditional configuration?

Thanks!

Reply
0 Kudos
PShahood
Contributor
Contributor

Next suggestion is to look in the "Virtual Network Editor" and see if it looks OK.  There was a lot going around on that not too long ago (I believe when 8.0 released).  What happened is there were a bunch of worthless "VMnet"s created and you needed to delete all that were invalid - they were messing things up.  I am not an authority at all, but for example, on my machine there are three entries:

     VMnet0 - Bridged - Autobridging

     VMnet1 - Host-only - - Connected - Enabled - ipaddress

     VMnet8 - NAT - NAT - Connected - Enabled - ipaddress

and below them, "Bridged" was selected.

When I had the issue, there were several more and were getting involved!  I deleted all but the above listed, restarted, and EVERYTHING worked as expected.

That's my 2cents - and I'm sticking with it!

Paul

Reply
0 Kudos
acymiranda
Contributor
Contributor

Hi!

My Virtual Networking connections are just like yours and I still can't get it work.

The no-ip client should be installed on the virtual Win 2008, right?

Thanks

Reply
0 Kudos
0WayneH0
Hot Shot
Hot Shot

If your virtual networks look the same as above then delete VMnet1 and VMnet8 like Paul says. For some reason every time you install workstation it insists on adding those virtual networks (even when upgrading). That should leave VMnet0 Auto-bridging. I'm not sure those additional networks would cause a conflict, but its something to try and I also always ensure those networks are deleted since I do not need them.

Then if your 2008 VM is set to use bridged networking just set it up as you would a separate physical machine. I'm not exactly familiar with the VPN software set up you are using, but I use VPN software (multiple types) on many VMs to connect to my work network, and every VM on my network looks and acts like a real physical machine that can be pinged, remoted into etc. So if you are running into some kind of troubles just try to diagnose it they way you would diagnose a real system. Start by testing that you can ping your VM and go from there.

Unfortunately I am no networking expert but I seem to have been able to fix a lot of issues over the years just through persistence. The recent versions of Workstation seem to have very robust networking in my experience.

Sorry I can't be of any more help than that.

Reply
0 Kudos
rainey
Enthusiast
Enthusiast

Do you have a router in this network?.

Some routers will not let your server, "server" to the local network PC's without a speical setting set in the router. The default is it servers to the web.

Also your may need port forwarding setting in the router also to get some things to work correctlly.

In my Linksys router it is this feature

Filter                      Internet NAT Redirection

This feature uses port forwarding                      to block access to local servers from local networked computers.                      Select Enabled to filter                      Internet NAT redirection, or Disabled                     to disable this feature.

Reply
0 Kudos