Contributor
Contributor

Bug? Connection to the document scanner is constantly interrupted / USB Verbindung zum Scanner wird ständig getrennt

Hello,

I have a Kodak Alaris E1025 document scanner

I connected this scanner via USB to the host (Ubuntu 20.04 LTS 64Bit / Workstation Pro 15.5.6) and also to the VM (Windows 10 Pro 64Bit, 6 cores, 12GB RAM).

Then I installed the driver and in the second step the software of the document scanner.

So far everything worked fine.

When I select a scan profile and press Start, the feed of the pages starts. Already while the second document is being scanned, an error message appears:

"Device is disconnected"

or with the Kodak diagnostic tool:

"Error occurred while retrieving DAT_IMAGEINFO.

DAT_STATUS: TWCC_CHECKDEVICEONLINE (0x17)

DAT_STATUSRAW: The USB scanner device was disconnected

***Scanner is disconnected***"

Rarely by chance the scan works (but also only once, on the immediate second try the error occurs as well). But to 90% however this error occurs.

(Here I have to switch off the device, unplug it from the power supply and quit software. Then I have to supply power again, switch on the device, start the software; only then I can start a new attempt).

I have found an old post here:

https://communities.vmware.com/thread/87975

However, this is already very old and I do not know whether this proposed solution:

# mount -t usbfs none /proc/bus/usb (console command)

usbfs /proc/bus/usb usbfs auto 0 0 (addition in /etc/fstab)

is currently still helpful under Linux, or whether Linux still uses this procedure?

I ask for help.

Many thanks!

Addendum:

In the meantime I have created a new VM with Windows 10 Pro (2004) and installed only the Kodak driver (to avoid software conflicts); and tested the scanner again. Result: same error!

Then I created another new VM with Ubuntu 20.04 and also installed only the Kodak driver.

The scanner is recognized by the scan software and here the scanner works as it should.

According to Kodak employees the scanner works under "Parallels Desktop for Mac" and also under VirtualBox (host and guest a Windows system).

He suspects a timing problem, a "USB bidirectional communication problem".

Conclusion:

Scanner works, VMware WP 15.5.6 with Linux as a guest system also works, Parallels and VirtualBox with Windows as a guest system also works.

So the Kodak driver would also be ok (works under certain circumstances with Windows and Linux in the VM).

So I suspect an error on the part of VMware in USB deployment on Windows guest systems.

Are VMware developers also involved in this forum?

Could this error be investigated please?

Can the USB ID be hard-assigned to a VM (as is the case with other virtualization software)?

Is it possible to further configure the Windows VM outside the graphical user interface?

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hallo,

ich habe einen Kodak Alaris E1025 Dokumentenscanner.

Diesen habe ich wie bisher auch andere Geräte per USB mit dem Host (Ubuntu 20.04 LTS 64Bit / Workstation Pro 15.5.6) verbunden und ebenso mit der VM (Windows 10 Pro 64Bit, 6 Kerne, 12GB RAM) verbunden.

Anschließend den Treiber und im zweitem Schritt die Software vom Dokumentenscanner installiert.

Dies hat soweit alles gut geklappt.

Wenn ich dann ein Scan-Profil auswähle und Start drücke, beginnt der Einzug der Seiten. Schon währenddessen das zweite Dokument eingescannt wird, erscheint eine Fehlermeldung:

"Device is disconnected"

oder mit dem Kodak Diagnosetool:

"Fehler beim Abrufen von DAT_IMAGEINFO aufgetreten.

DAT_STATUS: TWCC_CHECKDEVICEONLINE (0x17)

DAT_STATUSRAW: The USB scanner device was disconnected

***Scanner ist getrennt***"

Selten per Zufall funktioniert der Scan (aber auch nur einmal, beim sofortigen zweiten Versuch tritt ebenfalls der Fehler auf). Aber zu 90% jedoch tritt dieser Fehler auf.

(Hier muss ich das Gerät ausschalten, vom Stromnetz trennen und Software beenden. Anschließend erneut Strom zuführen, Gerät einschalten, Software starten; dann erst kann ich einen erneuten Versuch starten.)

Ich habe hier noch einen alten Beitrag gefunden:

https://communities.vmware.com/thread/87975

Allerdings ist dieser schon sehr alt und ich weiß nicht, ob dieser Lösungsvorschlag:

# mount -t usbfs none /proc/bus/usb (Konsolenbefehl)

usbfs  /proc/bus/usb  usbfs  auto  0  0 (Ergänzung in /etc/fstab)

aktuell unter Linux noch hilfreich ist, bzw. ob Linux diese Vorgehensweise noch nutzt.?

Ich bitte um Hilfe.

Herzlichen Dank!

Nachtrag:

Ich habe inzwischen eine neue VM mit Windows 10 Pro (2004) erstellt und nur den Kodak Treiber installiert (um ggf. Softwarekonflikte auszuschließen); und erneut den Scanner getestet. Ergebnis: gleicher Fehler!

Dann habe ich eine weiter neue VM mit Ubuntu 20.04 erstellt und ebenfalls nur den Kodak Treiber installiert.

Der Scanner wird von der Scansoftware erkannt und hier funktioniert der Scanner wie er soll.

Laut Kodak Mitarbeiter funktioniert der Scanner unter "Parallels Desktop for Mac" und ebenfalls unter VirtualBox (Host und Gast ein Windows System).

Er vermutet ein Timing-Problem, also ein "USB-Bidirektionales-Kommunikationsproblem".

Schlussfolgerung:

Scanner funktioniert, VMware WP 15.5.6 mit Linux als Gast System funktioniert auch, Parallels und VirtualBox mit Windows als Gast System ebenso.

Somit wäre der Kodak Treiber auch in Ordnung (funktioniert unter gewissen Umständen mit Windows und Linux in der VM).

Daher vermute ich einen Fehler seitens VMware bei der USB-Bereitstellung bei Windows Gastsystemen.

Sind auch VMware Entwickler in diesem Forum beteiligt?

Könnte man diesem Fehler bitte nachgehen?

Kann die USB-ID einer VM fest zugewiesen werden (wie dies bei anderen Virtualisierungsoftwares der Fall ist)?

Kann man hier ggf. die Windows VM, außerhalb der grafischen Oberfläche, noch weiter zielführend konfigurieren?

0 Kudos
0 Replies