WhiteKnight
Hot Shot
Hot Shot

Bug: Changing from Fullscreen back to Window mode alters guest language

Jump to solution

I noticed the following issue with Workstation:

When I change from Fullscreen to Window mode by hitting the keyboard combination <SHIFT>+<ALT>+<RETURN>, the language in the guest changes.

It's just like hitting <WINDOWS>+<SPACE> in the guest:

Languages.gif

I set up Windows to support both, German an English, for spell checking reasons.

In VMware Workstation preferences I changed the Workstation hot key setting to <SHIFT>+<ALT> because the original keyboard combination interferes with Visual Studio when installed in the guest:

Hot Key Settings.png

Same happens when I switch between VMs in Fullscreen mode using the keyboard (<SHIFT>+<ALT>+<LEFT ARROW> or <SHIFT>+<ALT>+<RIGHT ARROW>):

Unintentionally switching languages.gif

(see how the Windows UI language changes in my multilingual guest OS when I switch between VMs back and forth)

.

Is it sufficient to report this issue here? Or do you want me to buy a support ticket for this issue?

.



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos
1 Solution

Accepted Solutions
bonnie201110141
VMware Employee
VMware Employee

I can reproduce the issue locally and have filed an internal bug to track it. Thank you for reporting the issue to us!

View solution in original post

1 Reply
bonnie201110141
VMware Employee
VMware Employee

I can reproduce the issue locally and have filed an internal bug to track it. Thank you for reporting the issue to us!