Contributor
Contributor

Bridged Network does not allow browsing

I want to use VM with NIC connected directly to the network. With this I can ping say cnn.com but I cannot browse to CNN.com. I can ping the router that gives the IP address and Internet connection, but cannot browse to it.

Very strange experience.Spent the whole day struggling on this.

If I use NAT most of it works, however the VM now uses IP from another subnet (DHCP from VMNet8) and that gives me trouble with the devices on the network which the VM is communicating with, they cannot talk back as intended. Their messages are not sent back to the IP address of the VM which is another subnet.

0 Kudos
5 Replies
Contributor
Contributor

What I have noted is that if the host laptop is on WiFi the bridged connection in the guest works fine. However if the host is using wired connection (either the onboard NIC or the NIC on the USB C Docking station) the bridged setting for the host does not work. Can anyone throw some light on this. I would like to get everything working while using the wired NIC on the host as that gives me the maximum speed.

0 Kudos
Leadership
Leadership

In the virtual network editor, don't use "automatically bridge" setting, but specify which physical NIC that VMnet0 connects to. 

0 Kudos
Hot Shot
Hot Shot

This instruction is also included in the WS 15.5.5 release notes, so it should definitely solve the problem (and consider this thread as Solved).

0 Kudos
Contributor
Contributor

I have tried using the specific Network instead of Automatic in Virtual Network Editor. That has not made any difference.

Thread is NOT SOLVED.

0 Kudos
Contributor
Contributor

Hi i can confirm exactly the same problem.

It works over WLAN but not wired.

Tooks me one day, updating drivers, testing etc.

I found out it works with Version 15, seems like this problems starts with 15.5

Cheers mahaf

0 Kudos