Highlighted
Enthusiast
Enthusiast

Bridged Network Connection Problems in VMware Workstation 11

Jump to solution

I'm having bridged network connection problems in VMware Workstation 11. So far, I've tried:


Re: Windows 8.1 Pro/Ent Preview Guests - Windows Net Performance Halting, Barely Works


Re: Very slow network throughput Host->Guest but not Guest<-Host


So far, neither of the solutions worked. I've turned off "Large Send Offload" on every adapter that I could find on both the host and the guest. Nothing. Restoring these settings in any combination with others turned off didn't work either. I've edited the .vmx file and replace the occurrences with vmxnet3, and that didn't work either. So far nothing I've tried has worked. I've disabled all firewalls and antivirus. Still nothing. When I run the Guest OS Windows Network Diagnostic, I get the, "Your broadband modem is experiencing connectivity issues." However, I know this is not the case. I've also used the "Virtual Network Editor" to force the Bridged connection to select the correct nic (in my case, it's the Intel Centrino Wireless-N 1030 wireless adapter), but still no luck. Any help would be hugely appreciated.


Thank you,

Dave


My Stats:


Host:

OS: Windows 7 x64

Processor: Intel Core i7

Installed Memory (RAM): 16.0 GB (15.9 GB usable)

Wireless Adapter: Intel Centrino Wireless-N 1030

Router: Netgear AC1200 Smart Wifi Router; Model: R6200v2 (default settings)


Guest:

OS: Windows 7 x64


0 Kudos
1 Solution

Accepted Solutions
Highlighted
Enthusiast
Enthusiast

So I finally sound the solution. Bitdefender's firewall was blocking all traffic on the VMware Workstation Bridged connection. I turned off the Bitdefender Firewall completely, and Bridged Networking worked perfect. I'm probably going to create another topic specifically around configuring Bitdefender's firewall to allow VMware Bridged network traffic through.

View solution in original post

0 Kudos
11 Replies
Highlighted
Contributor
Contributor

Go to your Virtual Network Editor and run as Administrator.

Go down to the bottom and 'Restore Defaults'

Note: This will restore all the connectors back to new install status.

The Virtual Network Editor should look similar to this:

2015-06-01_12-56-28.png

Now go into one of your VM and make sure its set to Bridged Networking.

2015-06-01_13-00-57.png

That's all I do to get bridged networking. My routers DHCP server is assigning IP's.

0 Kudos
Highlighted
Contributor
Contributor

I'm unable to get bridging to work as well. In particular, I get this dialog when I attempt to switch VMnet0 to bridged:

NoBridged.png

I'm running Windows 10, build 10310. The network adapters are an Intel I218-V and I211 that are onboard an ASUS Deluxe X99 board. I've tried updating drivers, but it doesn't seem to make a difference.

0 Kudos
Highlighted
Contributor
Contributor

I can confirm that bridging has returned with Window's 10 10147 Smiley Happy

0 Kudos
Highlighted
Contributor
Contributor

Yep, working for me on Windows 10 Build 10147:

2015-06-19_21-30-51.jpg

0 Kudos
Highlighted
Enthusiast
Enthusiast

@VM Michael

Go to your Virtual Network Editor and run as Administrator.

Go down to the bottom and 'Restore Defaults'

Well, I did two things.


1. I clicked "Check for Updates". I noticed that VMware workstation had updates available (including updates for VMware Tools), so I installed those.


2. I clicked "Restore Defaults".


After that, my Bridged network worked fine. However, I don't know what fixed it. Because I didn't test "Restore Defaults" and installing the latest update independently, I have no way of knowing what actually fixed the problem. However, I'm going to give VMware Micheal the benefit of the doubt, and mark his answer as the correct one.

===========================================================================EDIT==============================================================

Well, now it's not working anymore. This is incredibly frustrating. I had just created a brand new virtual machine, and for the short time I had it on, I got internet connection using the "Bridged" network setting just fine.

However, I shut down my virtual machine, and then my entire host computer. When I booted my host computer, the Bridged networking didn't work anymore. Why did it temporarily work???

0 Kudos
Highlighted
Enthusiast
Enthusiast

I don't think I'll ever solve this problem. At least using community resources and Google. I've just about exhausted everything. This is the closest I've gotten to solving the problem:

Vmware Fix : Network Bridge on Device VMnet0 is Temporary down - YouTube

And even that didn't really do much. It reset the VMware created "Network", but the actual connection was still unresponsive. I think I'll just have to bite the bullet and pay VMware yet more cash for the utterly ridiculous price of $50. And that's just to access Tech Support. Obviously, they make "no guarantees" that the problem will even be solved. All in all, I'm thinking it might actually be my aging hardware. I connect using an Intel Centrino Wireless-N 1030. That was released in 2010, though I own the 2011 model. So I'm afraid that I'll pay $50 to hear the guy on the other end say, "Sorry, your hardware isn't supported by VMware Workstation 11." That would suck.

0 Kudos
Highlighted
Contributor
Contributor

You are not doing it correctly. A fresh install of VMWare will automatically add bridging, you don't need to do anything. The reason why you are not seeing it is that the Virtual Network Editor MUST be RUN AS ADNMINISTRATOR!

ALWAYS run Virtual Network Editor as Administrator. If not you will NOT see the default bridged network.

1) Right-click the Virtual Network Editor icon and RUN AS ADMINISTRATOR

2) Restore default and you should see the below. Doesn't matter what is in there, just RESTORE DEFAULTS!

2015-07-14_18-26-15.png

Now go to your VM and set to the below.

2015-07-14_18-36-05.png

Its a very simple process. The one hiccup is running as administrator. That's the only way you can see the default bridge connection. Normally it wouldn't matter because on a fresh install of VMWare it automatically put it in and you should NEVER have to mess with it.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Ha ha. I fully realize you have to run the Network Editor as administrator. "Restore Defaults" was even in the video tutorial I posted above. :smileylaugh:

Not to mention I use this trick to run programs whose functions require Administrative privileges:

Administrator.png

Setting this option automatically runs the program as administrator whenever you click on the shortcut. Just don't forget to set both the desktop shortcut AND the start menu shortcut. What I think is happening is the bridge protocol simply is malfunctioning. It might not be compatible with my old Intel Centrino wifi card. I say this because two years ago, an old version of VMware Workstation 10 DID work without any problems. But like I said, I'm calling VMware Tech Support tommorow and getting this problem solved once and for all. I've literally spent hours exhausting advice from every single Google link for the first 10 pages. The closest I got to solving the problem was the YouTube video in my above post, and even then, my problem is still not solved.

0 Kudos
Highlighted
Contributor
Contributor

Until Window's 10 and this bridging problem I never in the 10+ years running VMWare have I had to mess with the Network Editor at all.

The default bridging network is hidden until you run as administrator. I would delete VMWare, your network card, reboot, install VMWare, go into your VM and set to bridging. Don't mess with the editor. You MUST use the default bridging setup. It is specific for VMWare.

0 Kudos
Highlighted
Enthusiast
Enthusiast

VM Michael

Until Window's 10 and this bridging problem I never in the 10+ years running VMWare have I had to mess with the Network Editor at all.

The default bridging network is hidden until you run as administrator. I would delete VMWare, your network card, reboot, install VMWare, go into your VM and set to bridging. Don't mess with the editor. You MUST use the default bridging setup. It is specific for VMWare.

All right. So I:

1. Uninstalled VMware using Revo Uninstaller. Then after Revo was done, I manually searched "vmware" on my computer. The only thing VMware and Revo left behind were files in the TEMP folder, so I deleted those too. My computer was completely VMware free.

2. I uninstalled my network driver (Intel Centrino Wireless-n 1030)

3. Restarted my computer (Start>Restart)

4. Reinstalled my network driver

5. Reinstalled VMware Workstation from a fresh file download

6. Reinstalled my guest (Windows 7 x64) with Network Type set to "Bridged" (default settings)

While installing my guest, I noticed that, before I installed VM Tools, my bridged networking seemed to work fine. It created a network called "Network", and I could browse the internet fine. Then I finished installing VMware tools (which of course requires a mandatory reboot). After I rebooted, it seems then at the very specific point in time that my virtual machine started having network problems. It tried to connect, but what it connected to was an "Unidentified Network" with "No Internet Access". When I switched to NAT, it created another network called "Network 2". When I switched back to bridged, I got the same lack of connection. So I opened up the Network Manager in Control Panel. I saw "Network" and "Network 2" in the control panel. However, both were being "unused", and I noticed that there was not any network at all currently in use. That means the problem is that the bridged network protocol, for whatever reason, isn't connecting to it's correct network. So that's what my problem is. Now how do I actually fix it?

0 Kudos
Highlighted
Enthusiast
Enthusiast

So I finally sound the solution. Bitdefender's firewall was blocking all traffic on the VMware Workstation Bridged connection. I turned off the Bitdefender Firewall completely, and Bridged Networking worked perfect. I'm probably going to create another topic specifically around configuring Bitdefender's firewall to allow VMware Bridged network traffic through.

View solution in original post

0 Kudos