rafingrat
Contributor
Contributor

Bridged Connection in VMWare

Hi, I'm new to vmware and networks and am having trouble connecting to the internet from vmware. My host OS is Windows XP.

I'm running Ubuntu 7.04 on vmware workstation. When using NAT connection I'm able to access the internet from the guest OS but when in bridged mode, I can't.

My ifconfig -a[/u]

david@david-desktop:~$ ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:0C:29:B7:8E:ED

inet addr:192.168.16.128 Bcast:192.168.16.255 Mask:255.255.255.0

inet6 addr: fe80::20c:29ff:feb7:8eed/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:32128 errors:0 dropped:0 overruns:0 frame:0

TX packets:32519 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:2403162 (2.2 MiB) TX bytes:3663159 (3.4 MiB)

Interrupt:16 Base address:0x2000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:79 errors:0 dropped:0 overruns:0 frame:0

TX packets:79 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:13659 (13.3 KiB) TX bytes:13659 (13.3 KiB)

My ipconfig /all[/u]

Windows IP Configuration

Host Name . . . . . . . . . . . . : adminstr-faf905

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8

Physical Address. . . . . . . . . : 00-50-56-C0-00-08

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.16.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1

Physical Address. . . . . . . . . : 00-50-56-C0-00-01

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.126.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter

Physical Address. . . . . . . . . : 00-15-F2-BB-73-49

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . : 192.168.1.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.254

DHCP Server . . . . . . . . . . . : 192.168.1.254

DNS Servers . . . . . . . . . . . : 192.168.1.254

Lease Obtained. . . . . . . . . . : Sunday, August 19, 2007 2:49:39 PM

Lease Expires . . . . . . . . . . : Wednesday, August 22, 2007 2:49:39 PM

My .vmx[/u]

config.version = "8"

virtualHW.version = "6"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "512"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Ubuntu.vmdk"

ide1:0.present = "TRUE"

ide1:0.fileName = "E:"

ide1:0.deviceType = "cdrom-raw"

floppy0.autodetect = "TRUE"

ethernet0.present = "TRUE"

ethernet0.wakeOnPcktRcv = "FALSE"

usb.present = "TRUE"

ehci.present = "TRUE"

sound.present = "TRUE"

sound.fileName = "-1"

sound.autodetect = "TRUE"

svga.autodetect = "TRUE"

pciBridge0.present = "TRUE"

mks.keyboardFilter = "allow"

displayName = "Ubuntu"

guestOS = "ubuntu"

nvram = "Ubuntu.nvram"

deploymentPlatform = "windows"

virtualHW.productCompatibility = "hosted"

tools.upgrade.policy = "useGlobal"

ide1:0.autodetect = "FALSE"

floppy0.fileName = "A:"

isolation.tools.hgfs.disable = "FALSE"

ide1:0.startConnected = "TRUE"

ethernet0.addressType = "generated"

uuid.location = "56 4d a6 83 da e8 f7 98-5c c9 7b 01 e5 b7 8e ed"

uuid.bios = "56 4d a6 83 da e8 f7 98-5c c9 7b 01 e5 b7 8e ed"

scsi0:0.redo = ""

pciBridge0.pciSlotNumber = "17"

scsi0.pciSlotNumber = "16"

ethernet0.pciSlotNumber = "32"

sound.pciSlotNumber = "33"

ehci.pciSlotNumber = "34"

ethernet0.generatedAddress = "00:0c:29:b7:8e:ed"

ethernet0.generatedAddressOffset = "0"

tools.remindInstall = "FALSE"

tools.syncTime = "FALSE"

ethernet0.connectionType = "bridged"

extendedConfigFile = "Ubuntu.vmxf"

sharedFolder.option = "alwaysEnabled"

sharedFolder.maxNum = "1"

sharedFolder0.present = "TRUE"

sharedFolder0.enabled = "TRUE"

sharedFolder0.readAccess = "TRUE"

sharedFolder0.writeAccess = "TRUE"

sharedFolder0.hostPath = "D:\"

sharedFolder0.guestName = "Bittorrent"

sharedFolder0.expiration = "never"

numvcpus = "2"

ethernet0.vnet = "VMnet8"

0 Kudos
3 Replies
KevinG
Immortal
Immortal

With the VM powered off, remove the following line from the .vmx file

ethernet0.vnet = "VMnet8"

Your .vmx file contains

ethernet0.connectionType = "bridged"

ethernet0.vnet = "VMnet8"

you do not use vmnet8 with Bridged networking

rafingrat
Contributor
Contributor

Ah, ok, I did that but still didnt work, then realised that I had outpost firewall running and it had an issue with vmware. Had to create a rule to allow it. Up and running now Smiley Happy

0 Kudos
KevinG
Immortal
Immortal

Glad to hear it is resolved. Smiley Happy

I sometimes forget to ask if there is a firewall in the configuration, just glad you remembered Smiley Wink

0 Kudos