indicium
Contributor
Contributor

BIOS or EFI doesn't show up as option

When trying to install ESXi on Workstation 11.1 Build 249682, there is no option to select EFI or BIOS.  It is there for all other OS's.  Any ideas on this.

Thanks

0 Kudos
8 Replies
HuanguoZhong
VMware Employee
VMware Employee

You can edit the VM from "VM-> Settings -> Options -> Advanced ->  Check the checkbox 'Boot with EFI instead of BIOS' -> Save the settings by click OK button", then you can install ESX with EFI.  And on VMware Workstation, even you installed ESX with BIOS, you can still boot it from EFI(change the setting in VM settings). But for production systems, just stick to the guide and reinstall the host using EFI instead of BIOS on your hardware server.

0 Kudos
indicium
Contributor
Contributor

I tried that and got an error. I also tried editing the vmx file and that didn't work either.

0 Kudos
dariusd
Leadership
Leadership

What was the error in each case (both when using the VM Settings screen and when editing the .vmx file)?  It is certainly expected to work.

--

Darius

0 Kudos
indicium
Contributor
Contributor

The first few times with either checking the EFI box or editing the vmx file caused the load to stop at EFI Network and eventually load the EFI Shell.  Last night I tried again and strangely ESXi started the install, it almost got to the end and the stopped with a fault.  I have attached the fault message.

0 Kudos
dariusd
Leadership
Leadership

Please attach the vmware.log (and vmware-0.log, vmware-1.log, etc.) from inside the virtual machine's directory on the host.

--

Darius

0 Kudos
indicium
Contributor
Contributor

Solved, While browsing the Web for a solution, I came across installing ESXi on Workstation 9 and then the Light Bulb went on.  I am using ESXi 5.1 U3 and efi doesn't work on Hardware version 11.  I first tried Hardware version 9 and that worked then I went to Hardware version 10 and that worked.  I tried to upgrade te version and it failed again.  So, I'm leaving the version at level 10.

0 Kudos
dariusd
Leadership
Leadership

Hi indicium,

indicium wrote:

[...] efi doesn't work on Hardware version 11.

That absolutely should not be the case.  If it is the case, it's a critical bug that we will want to fix immediately.

Please provide more detailed instructions on what you are doing to trigger the failure.  Once again, if you could provide the vmware.log showing the failure ("A fault has occurred causing a virtual CPU to enter the shutdown state..."), that would be very likely to assist us in isolating the problem.

Thanks,

--

Darius

0 Kudos
indicium
Contributor
Contributor

Darius,

I have attached the vwware.log.  ESXi stops loading at "/imgpayld.tgz" and that is where the error appears on the display.  This occurs every time, as long as the statement 'firmware = "efi" ' is in the config for HW version 11.

Indicium

0 Kudos