KennDevine
Contributor
Contributor

Audio not working on Windows 10 VM after v12.5.4 upgrade

Jump to solution

I have two, 64-bit Windows 10 Pro VMs running on a Windows 10 Pro host. The host is a Dell Latitude E-6430.

One of the VMs rolled up just fine, but the other is throwing errors regarding the audio controller. The speaker icon in the system tray is marked with a red X. When clicked, Windows attempts to repair the error and fails. Device Manager does not show an entry for Sound, Video, and Game Controllers like the 'good' VM does, but rather an entry for Other Devices where the Multimedia Audio Controller is shown with a yellow triangle and the device status is listed as Code 28, "The drivers for this device are not installed".

I've rerun the VMWare tools update; first Repair, then Modify where I removed the device from both Device Manager and VMWare, rebooted, reinstalled, and the condition persists. I've tried manually installing the driver, but that fails with the message "The installation failed because a function driver was not specified for this device instance". References for this type of error harken back to Win XP and Vista days; I've tried what I've seen but nothing has worked so far.

Can anyone offer any sage advice?

Kind regards,

Kenn in Virginia

38 Replies
mbmast
Enthusiast
Enthusiast

I am having this problem with a fresh install of Workstation 12.5.7 on my host machine (Windows Server 2012 R2 Essentials) and a fresh guest install of Windows 10 Pro Build 1703.  If the problem was in the VMTools back in version 12.5.4 of Workstation, why is this still happening in version 12.5.7 of Workstation?

0 Kudos
dfischvtas
Contributor
Contributor

I tried the above suggestions, but I did not find success.  What worked for me:

  1. Power down the VM
  2. Edit the VM properties to delete the sound card. (click OK to commit the change)
  3. Edit the VM properties again and add a new sound card.
  4. Boot VM and sound is available.
MarcusWeaver
Contributor
Contributor

WOW! It worked. I'm running fedora 26, with guest OS windows 10 x64, with windows tools 10.1.7.

Thanks dfischvtas

I tried the above suggestions, but I did not find success.  What worked for me:

  1. Power down the VM
  2. Edit the VM properties to delete the sound card. (click OK to commit the change)
  3. Edit the VM properties again and add a new sound card.
  4. Boot VM and sound is available.
wila
Immortal
Immortal

Hi,

Obviously for everybody who installed an older version of VMware Tools. This solution by dfischvtas is better!

If you're unsure then you can always take a snapshot of your VM before removing the Sound card.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
rSerge
Contributor
Contributor

Actually no need to power off the VM. Just remove the sound card, click "OK" to VM Settings dialogs, then add the sound card and click "OK" to VM Settings dialogs. The VM should after a while find hardware changes and install the sound card automatically.

YeisonNL
Contributor
Contributor

Hi Wila,

Just great!. It was the only solution that worked with my VMware Fusion using Windows 10 x64.

I tried already removing and reinstalling VMware tools and it didnt work!.

Downloading the old version and installing it after removing the VMware tools again (a reboot needed), the audio and all the other driver are working as a charm!

Smiley Happy

0 Kudos
JohnW3
Contributor
Contributor

Abundant thanks, @Tfid!  This one worked for me, finally ending a three-day search.  It was a bit tricky to locate the download for Tools 10.0.9; only 10.0.6 showed up in the search results, but changing "1006" to "1009" in the URL got me there.

I didn't yet try copying the DriverStore folders and upgrading to the latest Tools. I'll wait until something else forces that upgrade.

0 Kudos
FHWS
Contributor
Contributor

Dear Tfid,

thank you very much, your solution was my last chance after 8 hours of trying - and it was the only one that worked!

Advice to all: If you work for hours on this problem and find a solution - create a snapshot IMMEDIATELY before changing anything else!

I did not do it and lost hours: I began with the proposals from wila and dfischvtas, and after some time it worked suddenly. I thought I knew the way there and wanted to do it again from the beginning, but without all detours (in order to have a clean installation). But I never could reproduce the solution again. I did some 20 - 40 attempts with wila and dfischvtas - but it never worked again!

But now, everything is ok for me, I just followed the solution of Tfid.

It's really a pity: I used VMWare on a WinXP computer for years. But it was really slow. Now I thought, I could replace it with Hyper-V on Win10. But this was complicated: I had to switch the LAN- and WLAN-interface all the time and the WLAN-switch troubled other WLAN-applications. So I bought VMware Workstation 14 - and now worked a full day only for getting sound!

Why does every improvement come with new severe mistakes?

Regards

Jörn

0 Kudos
YeisonNL
Contributor
Contributor

Hello Tfid,

I just want to thank you. You solution worked!. I used the Willa solution for already 4 months. Back then I downloaded/installed old VMware tools ver. 10.0.10. After installation Sound worked but I lost some sharing functionality between Mac en Win10 VM. Mainly the copy/paste between host en VM was really handy.

The second folder was a little different, but worked just the same.  I found this two in my installation.

C:\Windows\System32\DriverStore\FileRepository\

vmaudio.inf_amd64_30933caaaa23abee

wdmaudio.inf_amd64_6b5a0534c3cf6f82

I saved this folders to a temp location in Win10 VM. Then I installed my last Fusion VMware tools version. In my case ver. 10.1.6. After installation, as expected, the sound didn't work anymore. I just install the ' unknonwn device' driver in Device Manager as you suggested, using the saved audio folders... and Voila!!.

Everything works, even the copy / paste functions that I lost because of the old version VMware tools. Sharing within my macOS High Sierra and the Windows 10x (last version) is finally working as expected.

Thanks again!

0 Kudos
wila
Immortal
Immortal

Hi,

Just as a FYI, last time I saw this, the way that I solved it, was by removing the audio adapter from the virtual machine and then add it back.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
mackpt1
Contributor
Contributor

Here is how to fix Audio Volume Issues in Windows 10

1- Search for Sound in the Search bar at the bottom of desktop.

2- Go to Sound settings in the Control Panel

3- Right click the default devices in the new window that pops up and go to its Properties section.

4- Click on the Enhancements tab , choose the option to Disable all enhancements and hit the button Apply.

Source:- https://merabheja.com/fix-audio-volume-issues-in-windows-10/

0 Kudos
SPWilkins
Contributor
Contributor

rSerge

I was going to suggest the same thing, only. just to be safe, I removed the device from Device Manager inside the guest system, BEFORE removing the "Sound Card" from the Guest's VMware "Settings" panel.  I then added the sound card again, as you did.

It appears from your results that the initial removal from Device Manager may not have been important, but I was making sure and would still recommend it.  However, no restart was needed in my case either.

0 Kudos
dchall
Contributor
Contributor

I tried that and it didn't work.  However a much simpler solution that did work for me was as follows:

> Shut down the Virtual machine

> Go to Virtual Machine from Fusion menu bar

> Settings

> Sound Card -Remove sound Card

> Click on Add device and select Sound Card and add and check Connect sound card

> Power on the Virtual Machine and test the behaviour

Good luck...

0 Kudos
SIhor
Contributor
Contributor

Upgrade audio driver

David2025
Contributor
Contributor

Your driver are working,The issue was completely sloved, Thany you very much!

0 Kudos
colemarc
Contributor
Contributor

Windows 10 x64 guest on VMWare 15.5 Pro on Windows 10 x64 host

Looking in Device Manager you can find that virtual audio device under [Sound, video and game controllers] is VEN_1274 DEV_1371 SUBSYS_13711274.

This is Creative AudioPCI ES1371/ES1373, for which Windows 10 got no drivers. Even updating the driver finds nothing.

Shut down the guest OS, find the .vmx configuration file for the virtual machine and add the following line:

sound.virtualdev = "hdaudio"

Start the virtual machine and see that Windows recognizes a [High Definition Audio Device].

Problem solved.

0 Kudos
yohojones
Contributor
Contributor

Thank you.  This worked for me too. Imported Parallels VM because they went subscription. Sound wasn't working. Removed and added sound card and sound is working fine now.

0 Kudos
alexnovelli
Contributor
Contributor

Thank you so much! Worked for me too!

0 Kudos
InfoSeek
Contributor
Contributor

My plantronics headset fails within minutes during a call. I am currently testing the setting VM > Manage > Change Hardware Compatibility. . . Pick an older built and try it for a while. I can't tell if that's going to be the end of the audio device mess VMWare has caused with the recent updates, but everything else has failed so far.

0 Kudos