6uillerm0
Contributor
Contributor

After sleep w10 host, can not ping guests (vmware workstation pro 15.5 & 16.0)

Jump to solution

Hello Community!

Appreciate a lot your support

Issue scenario:

Guest VMs (CentOS and Win7) do have internet connection (they can connect internet. they can ping to 8.8.8.8)

From Host (Win10), it is unabled to ping to each VM. (i required to have a ssh connection)

All is managed as NAT connections.

Workaround:

I noticed that modifying VNE (by restoring default) i can connect ping, ssh, ftp, etc to guests.

I rather import a fixed configuration so NAT subnet has the range i need in my Centos.

I had no luck with repair option, neither with uninstall/install option.

Nevertheless, if I suspend/shutdown Host, the issue comes back.

If i just close the VMWare Workstation application and open it again all still works ok (avoiding suspend the host)

I tryied also creating a new CentOS guest. It works with default values, but it looks like is not related to guest machines.

I checked vmware services in host w10, they were always up an running in automatic.

I checked vmware.log but it does not seem to fail anything.

Looks like it is any firewall in win10, but do not know where to look and, it is fixed by restoring VNE configuration.

Any suggestion?

Thanks

-- Sep 22--

I upgrade to vmware workstation 16.0, the issue is still present. so i uninstall this version and install back to the 15.5.

Is there a way to totally remove the app, so i start from zero? (cleaning all paths, regedit, etc.)

0 Kudos
41 Replies
njlaw
Contributor
Contributor

This is the workaround that works for me.  Thank you!

 

Still an issue in VMware Workstation Pro 16.1.0 build-17198959 (the latest at the time of this post).

0 Kudos
samuel_thapa
Contributor
Contributor

I have also same issue after updating to vmware 16.1. Disabling and enabling the vnet card start to ping the guest. Does anyone has permanent solution for this issue.

 

DAVISTONE
Contributor
Contributor

Here is my experience to fix the same issue. 

I have read though all the posts in this thread. In one of the reply that submitted by Yanw, a Vmware employee, motioned that he was not able to replicate the problem. This makes me thinking whether there is anything unique on my workstation and is network related contributing to this issue.

So I uninstalled "Wireshark", "Zenmap (Window's flavor of Namp)". I also removed the WinPCAP driver and NPCAP driver which were installed together with Wireshark/Zenmap. After that, everything works as expected.

Now I am able to leave the VMs on (both windows and linux OS), place the Windows 10 host into sleep. And still able to RDP/SSH to them after waking up the host.

I hope my experience could provide some hint of fixing this issue. What I mean is take a look of the apps on your PC that are network related, removing them and see. 

Another observation: Windows 10 starts to allocate apps (including VMware workstation in my case) to utilize GPU computing resource. It's a good idea but I am not 100% comfortable at the moment. Although there is no issue experienced so far, I will make a note here just in case something happens in the future.

0 Kudos
DAVISTONE
Contributor
Contributor

It is concluded the "npcap" is the cause of this issue, at least on my PC. I have tried two versions of "npcap": 0.990 and 1.10. Both versions triggered the same problem as soon as installed. And the problem goes away right after "npcap" is removed.

1.10 is the latest version available so there is not much I can do at this point. 

Just to confirm: I am on windows 10 pro version "10.0.19042.685". Vmware workstation version 16.1.

carbajgu
Contributor
Contributor

Hello DAVISTONE, hello all!

I appreciate a lot the information you gave us. I can confirm the problem is not longer bothering me.

Just uninstalled: Wireshark 3.4.0 64-bit / Npcap and after my computer slept/woke up my connection still works.

 

The only problem will be that... i eventually need to work with wireshark/npcap. Do you suggest an alternative for wireshark/ncap?

Thanks for the chrismas gift and HAPPY NEW YEAR!

Best regards.

0 Kudos
DAVISTONE
Contributor
Contributor

Happy new year!

According to Npcap, the software is deployed in Windows 10 as a service named "npcap", I suspect the service is not able to restore properly after sleep. You can try and restart this service after windows 10 woke up and see if this could temporarily fix this issue. Also open a bug report with npcap to have some one from their team to look at it. (Sorry, I have a few other things going on and won't have time to handle this in the next a few weeks.)

https://nmap.org/npcap/guide/npcap-devguide.html#npcap-feature-native-servicename

Regarding packet capture alternative, you will be surprised that windows 10 has included its own packet capture tool.

This is a CLI tool called pktmon.exe. I think this is Microsoft's answer to Linux's "tcpdump".

https://betanews.com/2020/05/18/windows-10-secret-network-packet-monitor/

There was a GUI tool developed by Microsoft named "Microsoft Network Monitor". But the tool is no longer supported although you can still download and use it. The tool can open the ".etl" format file captured by "pktmon.exe".

https://www.microsoft.com/en-in/download/details.aspx?id=4865

Cheers!

 

0 Kudos
cheosman
Contributor
Contributor

Thank you for disable and enable tips. Huhu, it's more simple than my method. Disable and enable will be done again and again and again and again...

0 Kudos
DAVISTONE
Contributor
Contributor

Hey Cheosman, 

Please be aware that fixing the issue by "disable/enable" npacp service was not test. What was tested is "uninstall" npacp. 

I had some time over the weekend and attempted "disable/enable" npacp service but no go. I am not able to find "npacp" service on my windows 10 PC.

If "disable/enable" npcap option worked for you, would you please share the steps to achieve that? or post a screenshot here.

Thanks!

0 Kudos
cheosman
Contributor
Contributor

Thank you DAVISTONE, but i need Npcap for Nmap/Wireshark. 

What i mean was disable and enable again VMnet8, then wait for a few seconds.

carbajgu
Contributor
Contributor

Hello Guys,

This npcap issue is tracked in this thread: https://github.com/nmap/npcap/issues/106

They said npcap 0.9989 does work as expected, i downloaded it from: https://nmap.org/npcap/dist/

 

I confirm, I can have wireshark/npcap coliving with vmware, no workaround required.

Nevertheless, i do not know the improvements that the current version of npcap has... (from 0.9989 to 1.0000 included in wireshark).

I did not attempt to install 1.10 since the issue thread is still not closed.(opened in 19 Apr 2020)

We have to pay  attention of this thread if there are news, but i can live with 0.9989.

BR

cheosman
Contributor
Contributor

Dear all,

Im using npcap 1.10. Right now the problem was gone. I changed the The Environments Variables priority because \VMware Workstation\bin\ was on the top of the list. So I moved down a little bit below the %SystemRoot%\system32.

--- [2021-01-14] --- SORRY, NOT WORKING. Huhu

0 Kudos
DAVISTONE
Contributor
Contributor

1) Thanks carbajgu, nice catch.

I have tested this option and with npcap version 0.9989 installed the issue is disappeared.

2) Also thanks to cheosman,

I have also tried "disable/enable" Vmware Network Adapter "VMnet0X" (under Control Panel\All Control Panel Items\Network Connections) after the PC waking up from sleep, and worked too. I guess for anyone willing to stay with latest version of npcap, your option is still viable.

* For seamless user experience, I tried with Windows Scheduler to call a script to toggle vmware vnics on PC waking up and worked too. Here is the script I used. Please include a carriage return after the last line to ensure it will be executed. Add any custom Vmware vNICs on your PC if required.

netsh interface set interface "VMware Network Adapter VMnet1" disable
netsh interface set interface "VMware Network Adapter VMnet1" enable
netsh interface set interface "VMware Network Adapter VMnet8" disable
netsh interface set interface "VMware Network Adapter VMnet8" enable

Here is the URL for the windows event used to trigger the script when PC wakeup. 

https://sumtips.com/how-to/run-program-windows-wakes-up-sleep-hibernate/

3) Hopefully, newer version of npcap will be released soon to resolve this issue.

Cheers!

0 Kudos
matten59
Contributor
Contributor

I had similar problem in my Laptop Win10 VMware environment.

Issue scenario:
In the laptop running vmware ws 16 as host,  IP contact with guest VM (NAT connection) was lost whenever the Laptop was awaken after having entered sleep mode, e.g. during lunch hour.
Located the issue to vmhost adapter for VMnet8, of which related IPs (192.168.117...) apparently each time disappeared from routing table. 
Tired of having to go into the laptop's network settings and disable+enable VMnet8 each time this happened, I set up following

Workaround:
I created a minimal batchfile (.bat) with below few commands:

@Echo on
timeout /t 10
netsh interface set interface "VMware Network Adapter VMnet8" admin=DISABLED
timeout /t 10
netsh interface set interface "VMware Network Adapter VMnet8" admin=ENABLED

I may of course execute this manually by rightclicking the .bat-file and "run as admin"
But instead I opened Windows Task Scheduler, created a New Task.
I selected as Trigger: "On workstation unlock", and as Action: "Start a program" with path to above .bat-file.
I chose to let the task being run using user account: SYSTEM
In all, it makes the above commands execute anytime the laptop "wakes up from sleep".

Since then, the problem is gone. Coming back from lunch and logging back into the laptop, I always find the VMware Host->Guest communication working as needed, and the Guest responding successfully to ping.
Although not tested, I assume the same is applicable also when using the free VMware Player

0 Kudos
carbajgu
Contributor
Contributor

Hello Matten,

No workaround needed, just uninstall/install the last version of ncap that is used by wireshark. URL was shared lines above.

This case should be closed, since it was already solved.

0 Kudos
matten59
Contributor
Contributor

Sorry carbajgu , when struggling with this issue I was too quick - scrolling down the list of entries in this thread. But failed to notice there were further pages, where the actual root cause (npcap) was described. Now all found and read through, the npcap substituted with 0.9989 and all is well with my VMnet.
Thanks for valuable hints and tricks.

0 Kudos
redsolja
Contributor
Contributor

I have the same issue. Some VMs are host only and some are NAT.

This is my workaround:

1. open powershell as admin

2. run: restart-netadapter -name "vm*1" and restart-netadapter -name "vm*8"

 

VMnet1 and VMnet8 are my host-only and NAT vmware networks.

 

0 Kudos
cheosman
Contributor
Contributor

Good for you. You have 2 steps only. 🤣

0 Kudos
redsolja
Contributor
Contributor

There are many issues with downgrading software in general. I am not a big fan.

0 Kudos
davidwca
Contributor
Contributor

NPCAP 1.20 fixed the annoying issue for me.

Please go to https://nmap.org/npcap/ and get the latest version. It was fixed by this commit: https://github.com/nmap/npcap/commit/7ea7deba9bc2ad6345126aa255176eb2a0097ee1

DAVISTONE
Contributor
Contributor

Holy smoke, you are blazing fast. npacp 1.20 was only available yesterday (Mar 10, 2021).

That's really good news. Finally we can put this issue behind us. 

(It only took 6 months since the ticket opened on Sep 8, 2020.)

 

0 Kudos