6uillerm0
Contributor
Contributor

After sleep w10 host, can not ping guests (vmware workstation pro 15.5 & 16.0)

Jump to solution

Hello Community!

Appreciate a lot your support

Issue scenario:

Guest VMs (CentOS and Win7) do have internet connection (they can connect internet. they can ping to 8.8.8.8)

From Host (Win10), it is unabled to ping to each VM. (i required to have a ssh connection)

All is managed as NAT connections.

Workaround:

I noticed that modifying VNE (by restoring default) i can connect ping, ssh, ftp, etc to guests.

I rather import a fixed configuration so NAT subnet has the range i need in my Centos.

I had no luck with repair option, neither with uninstall/install option.

Nevertheless, if I suspend/shutdown Host, the issue comes back.

If i just close the VMWare Workstation application and open it again all still works ok (avoiding suspend the host)

I tryied also creating a new CentOS guest. It works with default values, but it looks like is not related to guest machines.

I checked vmware services in host w10, they were always up an running in automatic.

I checked vmware.log but it does not seem to fail anything.

Looks like it is any firewall in win10, but do not know where to look and, it is fixed by restoring VNE configuration.

Any suggestion?

Thanks

-- Sep 22--

I upgrade to vmware workstation 16.0, the issue is still present. so i uninstall this version and install back to the 15.5.

Is there a way to totally remove the app, so i start from zero? (cleaning all paths, regedit, etc.)

0 Kudos
1 Solution

Accepted Solutions
carbajgu
Contributor
Contributor

Hello Matten,

No workaround needed, just uninstall/install the last version of ncap that is used by wireshark. URL was shared lines above.

This case should be closed, since it was already solved.

View solution in original post

0 Kudos
41 Replies
wila
Immortal
Immortal

Hi,

If you suspend/resume a guest, then it will run a script to detect if the IP address etc.. is still available before bringing the network connection back up.

This is most likely what is causing you issues.

You can configure how your VM behaves (run the power suspend/resume scripts or not) by changing the power controls.

See also:

Configuring Power Controls for a Virtual Machine

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
6uillerm0
Contributor
Contributor

Hello Wila! appreciate a lot your answer.

Notice:

There is no issue after suspend/resume the guest VMs. Conectivity from host to them works good after that event.

The problem is when the host is suspend/resume. Does not matter if the guests are up and running or stopped, in both escenarios they will not be pingable after host suspend (or shutdown)

After restore default in VNE some scripts run that enable back this connectivity.

No need to do any change in VM (either CentOS or Win7) they start working after workaround, and fail after host is suspended.

BR

0 Kudos
wila
Immortal
Immortal

Hi,

OK.. in that case you might want to try and restart the NAT network at the host.

eg. from a command prompt with administrator privileges:

C:\WINDOWS\system32>net stop "VMware NAT Service"

The VMware NAT Service service is stopping.

The VMware NAT Service service was stopped successfully.

C:\WINDOWS\system32>net start "VMware NAT Service"

The VMware NAT Service service is starting.

The VMware NAT Service service was started successfully.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
6uillerm0
Contributor
Contributor

Hello Wila,

From my host i checked by using ping to my guest 192.168.247.128

It worked before sleep, and failed after sleep.

So, i tried restarting service you shared, does not work.

Any other suggestion? Or should i perform the fix in other way?

BR

Microsoft Windows [Version 10.0.18362.1016]

(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\carbajgu>ping 192.168.247.128

Pinging 192.168.247.128 with 32 bytes of data:

Reply from 192.168.247.128: bytes=32 time<1ms TTL=128

Reply from 192.168.247.128: bytes=32 time=1ms TTL=128

Reply from 192.168.247.128: bytes=32 time=1ms TTL=128

Reply from 192.168.247.128: bytes=32 time=1ms TTL=128

Ping statistics for 192.168.247.128:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Users\carbajgu>date

The current date is: mié. 09/09/2020

Enter the new date: (dd-mm-yy)

C:\Users\carbajgu>time

The current time is: 17:00:22.82

Enter the new time:

C:\Users\carbajgu>echo sleeping my host

sleeping my host

C:\Users\carbajgu>echo back

back

C:\Users\carbajgu>date

The current date is: mié. 09/09/2020

Enter the new date: (dd-mm-yy)

C:\Users\carbajgu>time

The current time is: 17:02:55.62

Enter the new time:

C:\Users\carbajgu>ping 192.168.247.128

Pinging 192.168.247.128 with 32 bytes of data:

Reply from 192.168.247.1: Destination host unreachable.

Request timed out.

Request timed out.

Ping statistics for 192.168.247.128:

    Packets: Sent = 3, Received = 1, Lost = 2 (66% loss),

Control-C

^C

C:\WINDOWS\system32>net stop "VMware NAT Service"

The VMware NAT Service service is stopping.

The VMware NAT Service service was stopped successfully.

C:\WINDOWS\system32>net start "VMware NAT Service"

The VMware NAT Service service was started successfully.

C:\WINDOWS\system32>time

The current time is: 17:06:06.57

Enter the new time:

C:\WINDOWS\system32>ping 192.168.247.128

Pinging 192.168.247.128 with 32 bytes of data:

Request timed out.

Request timed out.

Ping statistics for 192.168.247.128:

    Packets: Sent = 2, Received = 0, Lost = 2 (100% loss),

Control-C

^C

C:\WINDOWS\system32>

0 Kudos
wila
Immortal
Immortal

Hi,

Did you wait a bit after restarting the network? It might take a bit of time for things to work again.

If that's a yes, then I'm currently out of ideas.

Perhaps somebody else has additional tips to try.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
6uillerm0
Contributor
Contributor

Hello Wil!

I applied this way:

1. Connection between host & guest works.

2. Sleep my computer, so the problem happens.

3. Wake up my computer, confirm the issue.

4. Apply the workaround, stop/start vmware nat service. a host service.

5. Connection between host & guest still was down.

Workaround was performe some minutes after, (i noticed i requiered restart as administrator)

But not sure about this restart, consider that this host is my laptop and i shutdown daily, next day i will start the laptop and the same way, all services are stopped and started (all they seem work in automatic mode)

0 Kudos
cheosman
Contributor
Contributor

Hi, i have same problem. Actually it happen sometime after win10 updates. I think it is related to windows (Host).

My workaround.

1. suspend all guest

2. open virtual network editor, change setting

3. export setting (one time only)

If ping timeout happen, just import again. Haha, every time i did this funny thing.

FYI, if you reboot host (Win10), this problem is not happen. Maybe some cache is still there. If you shutdown or sleep for a longer time this problem arise.

0 Kudos
6uillerm0
Contributor
Contributor

Hello Cheosman!

So I am not alone! Thanks a lot for answering. Yes, this is the only workaround up to now. It bothers a lot to restore backup everytime i have to work with my vm's (which is daily)

In my case, I got a new computer. My new and old computer have the same Win10 with the same updates...

In order to avoid to reconfigure all vm's i backuped up the VNE. But this problem showed up. I do not know if this would happens is i did not restore the old pc VNE. I tried using a default one. and also creating a new VM.

Well, we have to live this way and hope a new patch fix my windows. (vm workstation6 remains with the issue).

Regards,

0 Kudos
Alexey_Halturin
Contributor
Contributor

Hi all,

I am using W10 + VMWare Workstation 16 Player and I have the same problem. But Player doesn't even have VNE, so I had to restart my laptop every time it went to sleep.

But eventually I found a workaround. Just open Network Connections in Windows, disable and re-enable VMWare Network Adapter VMnet {x}.

Regards,

Alexey

carbajgu
Contributor
Contributor

Hello Alexey!

Appreciate a lot your workaround! it works!

Guys, this workaround means that after my computer starts or wakes up and my VMs  keep isolated, It is not required to close all of them, reconfigured networks in VNE and start VMs again.

As Alexey said, just disable/enable these network adapters works.

It helps me a lot, thank you Alexey!

 

(I am 6uillerm0, i have no idea how this platform create a second profile with the same email. Your post was not notified to my mail that is why i did not notice online)

 

0 Kudos
davidwca
Contributor
Contributor

Same thing here. And disabling/reenabling the host only virtual adapter brings back the connectivity.

It's very annoying. Please fix, VMware!

0 Kudos
yanw
VMware Employee
VMware Employee

I can not reproduce the issue you hit after sleep and resume the Win10 host. Would you please share your Win10 host version? You can open a command line and there will be the information such as "Microsoft Windows [Version 10.0.18363.1198]" ?  And it that possible to paste the output of "ipconfig /all" when you hit the issue?

0 Kudos
carbajgu
Contributor
Contributor

Hello Yanw,

 

Win version:

Microsoft Windows [Version 10.0.18362.1016]

 

Vmware ws:

VMware® Workstation 16 Pro

16.1.0 build-17198959

 

HW:

HP EliteBook 840 G6

 

Tell me if you need more information, thanks for your time

Regards

0 Kudos
Alexey_Halturin
Contributor
Contributor

Hi Yanw,

Windows Version: 10.0.19041.630 (WIN10 Home)

After wake up from hibernation:
Ethernet VMware Network Adapter VMnet8:

Connection-specific DNS suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
Physical Address . . . . . . . . : 00-50-56-C0-00-08
DHCP Enabled . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::b1ad:7f1c:d31a:e76%13(Preferred)
IPv4 Address. . . . . . . . . . . : 169.254.14.118(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 570445910
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-F9-5B-3E-A0-88-69-D6-8F-E4
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Primary WINS-сервер . . . . . . . : 192.168.142.2
NetBios over TCP/IP . . . . . . . : Enabled

After disabling and reenabling VMnet8:

Ethernet VMware Network Adapter VMnet8:

Connection-specific DNS suffix . :
Description. . . . . . . .. . . . : VMware Virtual Ethernet Adapter for VMnet8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::b1ad:7f1c:d31a:e76%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.142.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease obtained. . . . . . . . . . : 4 Dec 2020 17:23:49
Lease expires . . . . . . . . . . : 4 Dec 2020 17:53:48
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 192.168.142.254
DHCPv6 IAID . . . . . . . . . . . : 570445910
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-F9-5B-3E-A0-88-69-D6-8F-E4
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Primary WINS-сервер . . . . . . . : 192.168.142.2
NetBios over TCP/IP . . . . . . . : Enabled

Regards,

Alexey

 

 

 

0 Kudos
carbajgu
Contributor
Contributor

Hello again,

In my case, IPAddress in VMnet8 does not change.

Check files zipped/attached:

1 After turned my computer on, notice, this time there were no issue.

2. Stop working after sleep/wake up event.

3. Fixed with workaround by restarting only vmnet8. Nevertheless, the configuration that changes is not vmnet8 but vmnet1

Workaround, AS ADMIN:
C:\WINDOWS\system32>netsh interface set interface "VMware Network Adapter VMnet8" disable
C:\WINDOWS\system32>netsh interface set interface "VMware Network Adapter VMnet8" enable

Regards

 

yanw
VMware Employee
VMware Employee

Thanks for the information. It is possible that the vmware virtual network adapter send dhcp re-fresh request as a client before the DHCP service ready from the wake up.

Would you please try to configure a static IP address to the "Ethernet VMware Network Adapter VMnet8" (192.168.142.1/255.255.255.0 for your case just leave the gateway and DNS blank should be fine), and again try the sleep/wake up action

0 Kudos
carbajgu
Contributor
Contributor

Hello Yanw,

From Win10 "Network Connections" I updated "VMware Network Adapter VMnet8" as requested (check before and after screenshots attached).

Besides, since VMware VNE was still considering vm8 as the old subnet, i also updated these values (check after2 screenshot attached) New SubnetIP is 192.168.142.0. (Internally in NAT Settings it set Gateway IP as 192.168.142.2)

 

After this changes, i started a centos7 with dhcp and check the new IP assigned. Through a putty connection in win10, i connected as expected.

I proceeded to sleep win10, after wake up. Nevertheless, the issue showed up again.

 

I will restore the VNE backup so, i will can connect to my VMS (that has statics IPs). Any test you want to try let me know, i will perform it as soon as possible.

BR

 

 

This is the ipconfig/all for vmnet8, after sleep and the issue showed up.

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::1484:f4f4:18dd:8704%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.142.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 1207980118
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-C5-92-99-00-68-EB-3A-BC-53
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

0 Kudos
fendywoo
Contributor
Contributor

I'm having this issue too and this step solve it. 

1. In VMware Workstation Pro > Edit > Virtual Network Editor.
2. Allow administrator Change Setting at the bottom of the page.
3. Under Name " VMNet0" By default Bridged "Automatically" change to > "Your physical network port".
4. Click Apply and Ok.

This step would solve the problem. Give it a try

0 Kudos
carbajgu
Contributor
Contributor

Hello Fendywoo,

I tried with no luck. I am sharing the change done just in case i confused something.

I was not sure about my physical network port, I took my Ethernet connection from the list (this is the way i am currently connected)

After update this configuration, I suspended and resumed my host. The issue was still there.

Thanks / BR

VNE_VMnet0_update.png

0 Kudos