VMware Communities
gilad_benjamini
Contributor
Contributor

64 bit guest on 32 bit host

I am trying to install and run CentOS 64 bit on XP 32 bit host

I read through .

I downloaded and ran the utility mentioned in the page, and it states that my host is capable of running 64 bit systems.

Does that imply that my processor supports EM64T and VT ?

When trying to install CentOS 64 bit on a guest, the installation says that my machine is not 64 bit. Do I need to change something in my BIOS setting for that ?

I checked through the BIOS and couldn't find anything relevant. Using a Dell Latitude 630.

0 Kudos
9 Replies
oreeh
Immortal
Immortal

You can trust the tool.

You need to enable VT/SVM in the BIOS.

If there's no option to do that you are almost lost unless there's a BIOS update available.

However, if the VT feature isn't locked you can try and add

hv.enableIfUnlocked = "TRUE"

to the preferences file.

gilad_benjamini
Contributor
Contributor

If I turn to Dell support asking them for BIOS support, what's the right terminology to use ?

0 Kudos
oreeh
Immortal
Immortal

Ask them for a BIOS with the ability to enable hardware assisted virtualization.

The Intel variant is commonly known as VT, the AMD variant as SVM.

0 Kudos
gilad_benjamini
Contributor
Contributor

Just to get one more thing clear.

The utility I ran implies that my CPU supports this feature, but it doesn't know whether or not the BIOS enabled it ?

0 Kudos
KevinG
Immortal
Immortal

Please post the .vmx file from the virtual machine

Did you select "Other Linux 2.6.x 64-bit "as the OS type when you cretaed the VM?

0 Kudos
gilad_benjamini
Contributor
Contributor

I selected RHEL-5-64

Here is the file

config.version = "8"

virtualHW.version = "6"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "1024"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Red Hat Enterprise Linux 5 64-bit.vmdk"

ide1:0.present = "TRUE"

ide1:0.fileName = "F:\work\Downloads\CentOS5.2-x86\CentOS-5.2-x86_64-bin-1of7.iso"

ide1:0.deviceType = "cdrom-image"

floppy0.autodetect = "TRUE"

ethernet0.present = "TRUE"

ethernet0.virtualDev = "e1000"

ethernet0.wakeOnPcktRcv = "FALSE"

usb.present = "FALSE"

ehci.present = "TRUE"

sound.present = "FALSE"

sound.fileName = "-1"

sound.autodetect = "TRUE"

svga.autodetect = "TRUE"

pciBridge0.present = "TRUE"

mks.keyboardFilter = "allow"

displayName = "Owl"

guestOS = "rhel5-64"

nvram = "Red Hat Enterprise Linux 5 64-bit.nvram"

deploymentPlatform = "windows"

virtualHW.productCompatibility = "hosted"

tools.upgrade.policy = "useGlobal"

ide1:0.autodetect = "TRUE"

floppy0.fileName = "A:"

extendedConfigFile = "Red Hat Enterprise Linux 5 64-bit.vmxf"

floppy0.present = "FALSE"

serial0.present = "TRUE"

serial0.startConnected = "FALSE"

serial0.autodetect = "TRUE"

ethernet0.addressType = "generated"

uuid.location = "56 4d ee bd 46 8a c9 d4-02 fa 68 5a 74 c6 09 d5"

uuid.bios = "56 4d ee bd 46 8a c9 d4-02 fa 68 5a 74 c6 09 d5"

scsi0:0.redo = ""

pciBridge0.pciSlotNumber = "17"

scsi0.pciSlotNumber = "16"

ethernet0.pciSlotNumber = "32"

ehci.pciSlotNumber = "33"

ethernet0.generatedAddress = "00:0c:29:c6:09:d5"

ethernet0.generatedAddressOffset = "0"

tools.remindInstall = "TRUE"

0 Kudos
gilad_benjamini
Contributor
Contributor

I just realized that there is a message when I start the machine: This CPU is VT-capable, but VT is not enabled (check your BIOS/firmware settings).

Back to the BIOS I guess

0 Kudos
KevinG
Immortal
Immortal

I have the Dell 620 with the Intel processor and it works fine.

Go into your BIOS to expand the "Post Behavior" to expose the "Virtualization " option, make sure it is enabled and do a complete power off/on after exiting the BIOS

gilad_benjamini
Contributor
Contributor

Did.

It works.

Thanks

0 Kudos