vmwarewsuser
Contributor
Contributor

3D Acceleration under Windows 2000 not working

Jump to solution

I am presently running the evaluation version of Workstation 11, version 11.1.2

I am running a Windows 2000 Professional virtual machine under it, and am having a problem - I have enabled 3D acceleration within the Display page of the machine settings, but Windows 2000 is not picking up on it. DXDiag (DirectX 9.0c) claims that there is only 32MB of memory, as a pose to the 128MB that has been configured and it also says that D3D acceleration is not available.

I have tried enabling 3D on another machine with Windows XP Home, DXDiag for DX9.0c shows that it works absolutely fine in this case - it picks up on the extra memory and D3D acceleration.

I have tried installing Windows 2000 with 3D acceleration disabled, installing VMware Tools, then enabling it afterwards and reinstalling VMware Tools and the video driver, but to no avail.

Has anyone else had this problem and is there a way to fix it? I can't seem to find anything that says that support for this under Windows 2000 is discontinued, I suppose if it was though, Workstation wouldn't have automatically enabled it, during the creation of the machine, in the first place.

Thank you very much

0 Kudos
1 Solution

Accepted Solutions
rachelsunsm
VMware Employee
VMware Employee

I tried on my environment with both workstation 11 and workstation 12, I can reproduce your problems, I will file a bug to track it.

Hope dev can fix it.

Thanks for your comments.

Thanks,

View solution in original post

0 Kudos
2 Replies
rachelsunsm
VMware Employee
VMware Employee

I tried on my environment with both workstation 11 and workstation 12, I can reproduce your problems, I will file a bug to track it.

Hope dev can fix it.

Thanks for your comments.

Thanks,

View solution in original post

0 Kudos
rachelsunsm
VMware Employee
VMware Employee

Dev has reviewed the bug and give explanation:

1. Windows 2000 uses older frozen driver.

2. We can't sign Win200 drivers anymore, so we actually froze that driver earlier than current WinXP drivers. (For instance, the Win2000 driver doesn't support guest-backed surfaces.)

3. As a workaround, lower hardware version to virtualHW.version="8" or virtualHW.version="9".

And we may have comments to mention this.

Thanks again for using VMware Workstation!

Rachel

0 Kudos