Rob41
Contributor
Contributor

vmware-setup-helper requires root access

Having just installed vmplayer on openSUSE Leap 15.1 and find it can only run as root:

I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"

==== AUTHENTICATING FOR org.freedesktop.policykit.exec ====

Authentication is needed to run `/usr/lib/vmware/bin/vmware-setup-helper' as the super user

Authenticating as: root

Password:

polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie

==== AUTHENTICATION FAILED ====

Error executing command as another user: Not authorized

ie. it asks for root password whenever it starts, but even with this cannot proceed.

When the player is run as root it works, but I do not think this is satisfactory.  How can I run the player with normal user permissions?

Tags (2)
0 Kudos
2 Replies
dps910_
Contributor
Contributor

I just had this issue aswell when trying to set up vmware player 15.5.1, I fixed it by doing the following:

- Install a polkit authentication agent. I installed polkit-gnome "sudo pacman -S polkit-gnome". It should be in your package manager.

- Open a terminal, and cd to where polkit-gnome is installed to. For me it was in "/usr/lib/polkit-gnome". If you can't find it type "whereis polkit-gnome".

- Run "polkit-gnome-authentication-agent-1" in that terminal. Then open another table and run "vmplayer". It should work now and the gnome polkit will ask you for your password.

0 Kudos
JvodQl0D
Enthusiast
Enthusiast

EDIT: SOLVED.  see last comments...


i'm having this exact problem in Debian 11 with `VMware-Workstation-Full-16.1.2-17966106.x86_64.bundle` installed.
no package `polkit-gnome` available, but installed some others without resolve:

```
i A gir1.2-polkit-1.0 - GObject introspection data for PolicyKit
p gir1.2-polkit-1.0:i386 - GObject introspection data for PolicyKit
v gir1.2-polkitagent-1.0 -
v gir1.2-polkitagent-1.0:i386 -
i A libpolkit-agent-1-0 - PolicyKit Authentication Agent API
p libpolkit-agent-1-0:i386 - PolicyKit Authentication Agent API
i libpolkit-agent-1-dev - PolicyKit Authentication Agent API - development files
p libpolkit-agent-1-dev:i386 - PolicyKit Authentication Agent API - development files
i A libpolkit-gobject-1-0 - PolicyKit Authorization API
p libpolkit-gobject-1-0:i386 - PolicyKit Authorization API
p libpolkit-gobject-1-dev - PolicyKit Authorization API - development files
p libpolkit-gobject-1-dev:i386 - PolicyKit Authorization API - development files
i A libpolkit-qt5-1-1 - PolicyKit-qt5-1 library
p libpolkit-qt5-1-1:i386 - PolicyKit-qt5-1 library
p libpolkit-qt5-1-dev - PolicyKit-qt5-1 development files
p libpolkit-qt5-1-dev:i386 - PolicyKit-qt5-1 development files
p lxpolkit - LXDE PolicyKit authentication agent
p lxpolkit:i386 - LXDE PolicyKit authentication agent
v lxpolkit:any -
p mate-polkit - MATE authentication agent for PolicyKit-1
p mate-polkit:i386 - MATE authentication agent for PolicyKit-1
p mate-polkit-bin - MATE authentication agent for PolicyKit-1 (executable wrapper script)
p mate-polkit-common - MATE authentication agent for PolicyKit-1 (common files)
p mate-polkit-common:i386 - MATE authentication agent for PolicyKit-1 (common files)
v polkit-1-auth-agent -
v polkit-1-auth-agent:i386 -
v polkit-1-auth-agent:any -
p polkit-kde-agent-1 - KDE dialogs for PolicyKit
p polkit-kde-agent-1:i386 - KDE dialogs for PolicyKit
p ukui-polkit - UKUI authentication agent for PolicyKit-1
p ukui-polkit:i386 - UKUI authentication agent for PolicyKit-1
i zulupolkit - tool to execute privileged operations
p zulupolkit:i386 - tool to execute privileged operations
```

```
$ vmware
I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is needed to run `/usr/lib/vmware/bin/vmware-setup-helper' as the super user
Authenticating as: XXXXX
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
```

running `vmware-setup-helper` separately does nothing,


solved: `sudo aptitude install policykit-1-gnome` & reboot.
if not solved, make sure "PolicyKit Authentication Agent" is enabled in xfce's "session and startup".

EDIT: happened again with VMware-Workstation-Full-16.2.1-18811642.x86_64.bundle :
I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"
pkexec must be setuid root
i was forced to run vmware as root in CLI first, then running as normal user worked. 😞

0 Kudos