jcbodnar
Contributor
Contributor

vmnet0 missing when using ubuntu 6.10 deb, reconfigure networking options?

Jump to solution

I've install VMware Player 1.0.2 build-29634 using synaptic (apt-get) on Ubuntu 6.10. I guess the package handles all the setup for you because I didn't have to answer any of the regular networking questions. Player runs fine (with a Centos 4.3 image) except I can't get bridged networking to work. It seems I have no vmnet0. (Isn't that the interface for bridged networking?)

$ ifconfig

eth0 Link encap:Ethernet HWaddr 00:11:5B:73:D7:10

inet addr:72.179.51.25 Bcast:255.255.255.255 Mask:255.255.248.0

inet6 addr: fe80::211:5bff:fe73:d710/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:49746 errors:0 dropped:0 overruns:0 frame:5

TX packets:10263 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:20972377 (20.0 MiB) TX bytes:1096488 (1.0 MiB)

Interrupt:217 Base address:0xec00

eth1 Link encap:Ethernet HWaddr 00:E0:29:2B:9F:D2

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0

inet6 addr: fe80::2e0:29ff:fe2b:9fd2/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2981 errors:0 dropped:0 overruns:0 frame:0

TX packets:3768 errors:0 dropped:0 overruns:0 carrier:0

collisions:1 txqueuelen:1000

RX bytes:327195 (319.5 KiB) TX bytes:3829331 (3.6 MiB)

Interrupt:177 Base address:0x4000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:8 errors:0 dropped:0 overruns:0 frame:0

TX packets:8 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:604 (604.0 b) TX bytes:604 (604.0 b)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:C0:00:01

inet addr:192.168.126.1 Bcast:192.168.126.255 Mask:255.255.255.0

inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

vmnet8 Link encap:Ethernet HWaddr 00:50:56:C0:00:08

inet addr:192.168.20.1 Bcast:192.168.20.255 Mask:255.255.255.0

inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:14 errors:0 dropped:0 overruns:0 frame:0

TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

I'm guessing it has something to do with the fact that I have two NICs on this machine. eth0 is an external interface. eth1 is for my internal network. I want the bridging to be on eth1. In /etc/vmware/locations I see the line:

answer VNET_0_INTERFACE eth0

I tried changing that to eth1 and restarting the vmware-player service but still no vmnet0.

Is there a way to reconfigure vmware's networking options so it bridges on eth1 and I can get a vmnet0? Or am I completely off base with my logic and something else is wrong?

0 Kudos
1 Solution

Accepted Solutions
KevinG
Immortal
Immortal

I have no vmnet0. (Isn't that the interface for bridged networking?)

vmnet0 is not an interface, it is a virtual switch and should not appear in the output from ifconfig

Post the output from " psawww | grep -i bridge " from the Linux host

What is the guest OS?

Post the .vmx file from the virtual machine

Post the output from ipconfig -a or ipconfig /all from the guest OS?

View solution in original post

0 Kudos
3 Replies
KevinG
Immortal
Immortal

I have no vmnet0. (Isn't that the interface for bridged networking?)

vmnet0 is not an interface, it is a virtual switch and should not appear in the output from ifconfig

Post the output from " psawww | grep -i bridge " from the Linux host

What is the guest OS?

Post the .vmx file from the virtual machine

Post the output from ipconfig -a or ipconfig /all from the guest OS?

View solution in original post

0 Kudos
jcbodnar
Contributor
Contributor

ps awww | grep -i bridge provided a clue to the problem. vmnet-bridge was not running. I would have thought the init script that came with the ubuntu vmware-player .deb would have started something like this. Perhaps not. Once I ran it, I started the vm back up, switched it to bridged and it got an ip address via dhcp on the local net.

Thanks!

0 Kudos
KevinG
Immortal
Immortal

Thanks for the update Smiley Happy

Glad to hear that it is resolved

0 Kudos