osde_info
Enthusiast
Enthusiast

soundcard disconnected because cannot open file "C:\ProgramData\VMware\dndlogs\dndlog.conf"

windows 7 host

vmware player 3.1.2 301548

ubuntu 10.4 guest

The default sound device cannot be opened:

A device ID has been used that is out of range for your system.

Sound will be disconnected.

Oct 15 16:39:40.937: vcpu-0| [http://msg.dictionary.load.openFailed|http://msg.dictionary.load.openFailed] 
Cannot open file "C:\ProgramData\VMware\dndlogs\dndlog.conf": The system cannot find the path specified.
Oct 15 16:39:40.937: vcpu-0| [http://msg.sound.defaultbadwaveopen|http://msg.sound.defaultbadwaveopen] The default sound device cannot be opened:
Oct 15 16:39:40.937: vcpu-0| A device ID has been used that is out of range for your system.
Oct 15 16:39:40.937: vcpu-0| [http://msg.pciSound.HostOpenDspChannelFailed|http://msg.pciSound.HostOpenDspChannelFailed] Sound will be disconnected.

what is dndlog.conf ?

where do i get a blank one from ?

or

is there any other way to (re)enable sound in my VM ?






regards

clive

http://vizz.info

regards clive http://vizz.info
0 Kudos
5 Replies
danwalmsley
Contributor
Contributor

I am getting the exact same error, and the program apart from this has become hoerrendously slow. I can't get it to boot any of my virtual machines, iv tried uninstall -> restart, install -> restart and nothing its still a problem.

This might all be since I upgraded to the latest version of vmplayer....

Please someone help diagnose the machine..

(Windows 7 Host)

0 Kudos
continuum
Immortal
Immortal

Hi Clive

both issues seem to be not related but there is a problem with that dndlog.conf in recent versions.

Can you post the full vmware.log ?

Do you use drag and drop from host to VM or the other way round ?

Have you tried to create an empty dndlog.conf in the specified directory ?






_________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

osde_info
Enthusiast
Enthusiast

vmware.log

see attached

Do you use drag and drop from host to VM or the other way round ?

i dont use any dnd either way

Have you tried to create an empty dndlog.conf in the specified directory ?

no i'll try that next






regards

clive

http://vizz.info

regards clive http://vizz.info
0 Kudos
osde_info
Enthusiast
Enthusiast

fantastic workaround thanks creating C:\ProgramData\VMware\dndlogs\dndlog.conf has got rid of the err msg but no sound yet !

ps

vmwply has also created dndui.log and dndvmx.log in the dndlogs subdir !






regards

clive

http://vizz.info

regards clive http://vizz.info
0 Kudos
bonobo201110141
Contributor
Contributor

I had the same problem and managed to solve it completely with advice from another post.

1)  In Ubunutu

System-->Preferences-->Sound-->Hardware-->Profile

Change "Analog Stereo Duplex" to "Analog Stereo Output".

2) To fix addition problem of losing connection at login:

Disable pulse audio in gdm (gnome login manager)

http://www.debuntu.org/how-disable-pulseaudio-and-sound-gdm

0 Kudos