ankurdubey521
Contributor
Contributor

"Cycle Through Multiple Monitor" broken for triple monitor setup on Workstation Player 16

VM: Manjaro Linux (Kernel 5.8)

Host: Windows 10 2004 Pro 64bit

I just upgraded to VMWare Workstation Player 16 (from 15). I have a triple monitor setup (two external 1080p monitors connected to laptop with 1080p display). Before the upgrade I was able to use the triple monior setup inside the VM by selecting a layout from "Cycle Multiple Displays", but now selecting a layout from the list does not do anything.

Strangely enough multi monitor works when I disable any one of the three displays, and try to use a dual monitor setup.

One more observation: I tried to look into the mksSandbox logs, and I found that it refers to the other two displays as "DISPLAY 4" and "DISPLAY 5" instead of dispay 2, 3. Maybe this might have something to do with the issue.

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 0 size: 1920x1080  position: (0, 0) name: \\.\DISPLAY1 

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 3 size: 1920x1080  position: (1920, 0) name: \\.\DISPLAY4 

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 4 size: 1080x1920  position: (-1080, -232) name: \\.\DISPLAY5 

Have attached mksSandbox*.log and vmware*.log as a zip.

This is a similar thread with exact same issue:Re: Multiple monitors not working with vmware workstation player 16 

0 Kudos
14 Replies
joshingyou
Contributor
Contributor

I'm seeing the same problem. Clicking o nthe different layouts does nothing. My mksSandbox logs lists Display 1 through 3:

2021-01-30T10:08:17.082-08:00| mks| I005: Current Display Settings:
2021-01-30T10:08:17.082-08:00| mks| I005: Display: 0 size: 3840x2160 position: (0, 0) name: \\.\DISPLAY1
2021-01-30T10:08:17.082-08:00| mks| I005: Display: 1 size: 3840x2160 position: (3840, 0) name: \\.\DISPLAY2
2021-01-30T10:08:17.082-08:00| mks| I005: Display: 2 size: 3840x2160 position: (-3840, 0) name: \\.\DISPLAY3

Funny enough VMware thinks I'm running Windows 8, even though I'm running Windows 10.

2021-01-30T10:08:17.066-08:00| main| I005: Log for VMware Workstation pid=17636 version=16.1.0 build=build-17198959 option=Release
2021-01-30T10:08:17.066-08:00| main| I005: The host is 64-bit.
2021-01-30T10:08:17.066-08:00| main| I005: Host codepage=windows-1252 encoding=windows-1252
2021-01-30T10:08:17.066-08:00| main| I005: Host is Windows 8 Pro, 64-bit (Build 19041)

0 Kudos
darksidemaze
Contributor
Contributor

I'll give this thread a bump as I'm seeing this problem as well, ie 2 monitors VM guests can use the two monitors, plug in 3rd monitor, the VM guests can run on 1 monitor, cycle monitor toolbar button shows the layout options popup window, but selecting any of those layout options doesnt do anything. 

Host: Win10x64 20H2

OS Build: 19402.746

Experience: 120.2212.551.0

Nvidia Quadro P400.

Player version: 16.1.0 build-17198959

Player OS report: Windows 10 Pro, 64-bit (Build 19042.746) 10.0.19042

Guest Windows 7. 

Eliminated so far. Vsync speed & resolution, nvidia monitor order, Windows Monitor Order, Ultramon running and not, Virtual Machine Graphics Memory lots or not, nVidia GPU Utilisation - dedicated to graphics only and Use for Graphics and compute needs. 

Off now to see how to get Player 16 guest logging debug info because option is not visible from "guest settings, options tab" as I have no Advanced option in the list as described in Pro version help page.

I can put the nVidia into debug mode to see if anything shows up around the time I choose a multi monitor layout so I'll be seeing what the graphics card sees when it works with 2 physical monitors and not 3 monitors. 

Logs not posted yet as I need to review info for data security reasons. 

 

Anyway a bounce for this problem, in the hope someone from VMware might see it and find something useful from the above in order to solve it. 

0 Kudos
darksidemaze
Contributor
Contributor

One other point, as a newbie, I dont know if its better to create a separate new post or whether its just better to thread bump? Apologies if the etiquette is wrong. 

Edit: My thinking is the popup layout window is the problem. I dont know yet as I've not downloaded Rohitab's API monitor or any other API monitor of sorts to see what API's are being called by this button, if any, to get more of an insight. 

 

But as I see it, when 3 or more monitors are detected, the Choose A Monitor Layout window button changes. The iconography is two monitors one in front of the other on the left of the button and a down pointing triangle on the right of the button. Clicking this button displays the layout window options and whilst this is efficient to then select the multi monitor layout in one click, as there's a bit more work to do behind the scenes, maybe a quick work around bearing in mind multi OS issues with GUI, the Choose A Monitor Layout window button could become dual use. What I mean is, if I click the left part of the button, it cycles through the monitor layout's like previous versions of VMware did. If I click the right side of the button where the down pointing triangle is, it can display the popup layout window for users to shortcut straight to the layout they want instead of cycling. 

This way the old monitor cycling code can be kept in play, whilst the new layout window manager pop code can be tested a bit more in the wild without it being a "killer" to users because they can just click the left or right side of this button to get their monitor layout.

 

Anyway, I've got to downgrade to a version where it works over 3 monitors for now, so when I find that downgrade version, I'll post that version number as single monitor use is so 1990's. 😎

 

JMO.

0 Kudos
darksidemaze
Contributor
Contributor

So VMware Player version 15.5.7 build-17171714 works, current one on the website downloads.

Saw this version also has the popup layout window when 3 or more monitors are present and this works so I doubt my suggestion above would work now. 

Did notice the 15.5.7 doesnt support side channel attack mitigation, as I was using this in 16 and I had it popping up telling me this everytime I started the guest OS and this is something I had not disabled when trying to get the popup layout manager to work.

Fortunately didnt have any problems with guests used in 16 working in 15.

 

FWIW.

0 Kudos
darksidemaze
Contributor
Contributor

So as I have HyperV enabled on this machine I added to the VMX file the line

ulm.disableMitigations="TRUE"

Which is based on this post. Solved: mitigations warning - VMware Technology Network VMTN

Anyway no change adding the above setting, the Windows layout button still didnt do anything when I selected a layout.  

Its odd that it works with 2 monitors, but not 3 + monitors which is what keeps drawing me back to the idea the bug is in Player and not a windows setting issue somewhere.

For the record, I do run with every security option enabled, so Ransomware protection is on, Reputation-base protection is on, Isolated browsing is enabled, all of those options are off, except Advanced Graphics which is on. As this requires a restart switching it off, I'll see if that makes a difference, which I doubt because the 2monitor works but not 3, but its worth a check.

Exploitation is all on at highest levels like Control Flow Guard, Data Execution Protection, ALSR options etc etc.. Core Isolation on.

When installing/uninstalling different player versions, the installation program's tmp files were tripping off Windows Defender and it kept asking me to send these to MS for analysis which is a bit odd, but before I could manually examine them, they had disappeared from the tmp folder, so MS never got them.

0 Kudos
darksidemaze
Contributor
Contributor

Well something odd was occurring with VMware-player-16.1.0-17198959.exe, Windows Defender was complaining about some of the TMP files during uninstall and installation and wanted to submit these to MS. I didnt submit because they had gone from the tmp folder before I could examine them, but having tried  Windows Security, App & Browser control, Isolated Browsing, Change Application guard settings, Advanced Graphics toggled on and off, the popup Windows Monitor Layout window still doesnt work with 3+ monitors. 

I tested this, in case something in Windows10 was affecting something to do with this problem, I have seen earlier versions of Win10 ignore its own Controlled Folder settings in the past, allowing some apps like VMware through to the Users folders, but opensource OpenOffice cant write to the Users Folder. Dont know why at this stage, but there's more going on behind the scenes that is let on, so sometimes being a flick switcher is the only way to find glitches in the matrix so to speak. 

 

Shout out to Christian at Ultramon whose support has been very rapid and welcome!

0 Kudos
darksidemaze
Contributor
Contributor

So installed the latest updates from MS and Dell firmware (bios, HD controllers, USB, Intel ME), and the popup Window Layout window for 3+ monitors still doesnt work.

Host OS Version: Windows 10 Pro, 64-bit (Build 19042.789) 10.0.19042

Anyway have found the logs I'll do a side by side comparison with 2 mons plugged in and 3mons plugged in and see whats being thrown, as I'd rather not go back to 15 if I can help it, not that the guest goes online, but theres some very creative individuals out there who like to poke around in other peoples systems.

0 Kudos
darksidemaze
Contributor
Contributor

So compared the vmware.log files for Player 15 3 monitors working, Player 16 2 monitors working & Player 16 3 monitors not working. 

What I've listed below is line entries seen in P16 3 mons not in P16 2 and/or P15 3.

So the working players didnt have two extra IPv6 entries, but P16/3mon shows two extra IPv6 address which doesnt seem logical on the surface.

Lines found in 16 3mon but not found in 15 3mon or 16 2 mon
vmx| I005: IP=fe80::dcf8:9a3e:4566:556c%20
vmx| I005: IP=2001:0:14be:4c8:cde:6cf:2664:c740
vmx| I005: P9FS_PowerOn: 9PFS server is not enabled.
vmx| I005: HgfsServerManagerVigorInit: Initialize: dev api
vmx| I005: GuestRpcSendTimedOut: message to toolbox-dnd timed out.
vmx| I005: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

Lines Missing from 16 3mon but found in 15 3mon and 16 2mon
vmx| I005: VUsbUpdateVigorFieldsAndAutoconnect: New set of 1 USB devices
2021-02-03T15:51:29.376Z| vmx| I005: USB: Found device [name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008 speed:full family:wireless,bluetooth deviceType:virtual-bluetooth info:0000001 version:3]

Missing from 16 3mon but found in 15 3mon
vmx| I005: ToolsSetDisplayTopology: Sending rpcMsg = DisplayTopology_Set 3 , 1920 0 1920 1080 , 0 0 1920 1080 , 3840 0 1920 1080

Missing from 16 3mon but found in 16 2mon
vmx| I005: ToolsSetDisplayTopology: Sending rpcMsg = DisplayTopology_Set 1 , 0 0 1920 1080

These last two debugview output messages found have had lots of lines snipped because its the hardware stuff.

 

So it seems to me like the GuestRpcSendTimedOut: message to toolbox-dnd timed out. is where its falling down in one area and I've seen other posters suggest its not a problem, however RPC usually means Remote Procedure Call, so it appears to be sending a message to another process. Maybe a case for a sysinternals utility, I dont know if one exists to monitor the RPC messages but thats where I'll be looking next, although I have a hunch its actually a CPU issue.

The other thing is I cant for the life of me figure out why those extra IPv6 connections appear in 16 3mon. Havent looked at routing tables or anything, but it doesnt seem right based on my gut feeling. 🙂

Thats what I found so far by trawling the VMware.Log, off to the do other logs now and see what else can be dug up. 

These logs look remarkably like what one would see in DebugView? Is it debugview output dumped to a file?

0 Kudos
darksidemaze
Contributor
Contributor

Well different approach was called for. So spun up a new W7, found that it cant install some of the VMware Tools due to the changes with installing drivers and SHA-2 as noted here Solved: Re: Setup failed to install the VSock Virtual Mach... - VMware Technology Network VMTN

The suggested MS link in this vSock post cites this url https://support.microsoft.com/en-us/topic/2019-sha-2-code-signing-support-requirement-for-windows-an... 

but it doesnt show anything. Posting "2019-sha-2-code-signing-support-requirement-for-windows-and-wsus"  into "bada bing" brings up the webpage in the results, clicking the link takes me to a blank webpage. clicking the Cache triangle in the "bada bing" to see what the search engine saw displays a single line of text "Could not find the requested document in the cache." **bleep** those db indexes just fail when you need them the most. 

So where else can I find this 2019 sha2 webpage? I know, Putinland, so I located the Russian webpage equivalent which is this URL 2019 SHA-2 Требование подписания кода для Windows и WSUS (microsoft.com) and I got the Russian translation of the webpage. Great! Thought what if I just change the Ru-Ru to En-Us in the URL will it display the webpage in english for me then? Tried but no joy. Ok well lets see how good the MS Edge translator is, triggered a "Translate page from Russian?" dropdown by hitting F5 again as MS Edge unusually didnt automatically volunteer to translate the webpage like it normal does when I land on a foreign language webpage. Clicked the Translate program and I got my English translation. Anyway explored that but was like this is too much for me right now, maybe I'll come back to this. 

So next approach, check for updates in Player16, see if VM have released anything over night, no, but I did check out the Workstation 16 Pro link. Noticed I could try this for 30days, so what the heck, lets give that a go. At least I'll find out if the paid for version is displaying the same problem, which would then alter the factors/variables still in play. 

Downloaded & installed the Workstation 16 Pro, load and ran one of the newly created temp virtual machines, starting with a W10x32 guest.

Loaded into Workstation 16 Pro, installed the VMware tools, clicked the Window layout button, and it worked, the guest spread its desktop across my host desktop faster than you can say Jack Rabbit!

Great, shut that down, then tried the newly created W7 temp guest, didnt install or update the tools manual left the system to its own default devices and hey, that also spread its desktop over my host desktop faster than a hot knife in butter! 

So the W7 & W10 guests I created a short while ago, spread across 3 monitors exactly as I would expect. 

However having made a copy of a W7 guest I've been doing stuff in for a while now, that just wont work in the 16 pro, it cites an internal error, so now its a case of trying to track down what the problem is. 

So all I've done is prove that 3 or more monitors will work with side channel mitigation enabled in Workstation 16 Pro and likely Player 16, so its not the side channel mitigation causing the problem, which was one of the doubts. 

I'll be checking the Vmtools now as this seems to play a part in this desktop spreading by virtue of the fact, if Vmware tools is not installed the guest desktop doesnt spread across the host desktop faster than a Gingham table cloth over a polished wooden table. 🙂

#ToTheMoon

 

 

0 Kudos
darksidemaze
Contributor
Contributor

So my nVidia Quadro professional series graphics card has a utility called configureMosaic.exe which lets me combine 2 or more physical monitors into 1 pseudo ultrawide monitor or any other grid configuration like TV studio backgrounds which MS window's the OS sees. VMware Player also sees the same pseudo ultrawide monitor, so with 3 monitors all the same size mounted on an Ergotron HX Triple Monitor Bow Kit, Windows and VMware sees monitor Left as 1 normal sized monitor, and Monitor Centre & Monitor Right as 1 ultrawide monitor or whatever shortcut shown below I clicked on. 

These are the windows shortcuts I created which configures the monitors how I want the monitors to appear to windows and vmware. This is hardware hacking. 

3 monitors all the same size, primary monitor being the first
monL+monC+monR
C:\NVIDIA\configureMosaic.exe set rows=1 cols=1 display=0x80061087 res=1920,1080 nextgrid rows=1 cols=1 display=0x80061081 res=1920,1080 nextgrid rows=1 cols=1 display=0x80061083 res=1920,1080

2monitors, normal sized on left, ultrawide on the right.
monL+mosaic[MonC+monR]
C:\NVIDIA\configureMosaic.exe set rows=1 cols=1 display=0x80061087 res=1920,1080 nextgrid rows=1 cols=2 display=0x80061081 display=0x80061083 res=1920,1080

2monitors, ultrawide on the left, normal sized on the right.
mosaic[monL+monC]+monR
C:\NVIDIA\configureMosaic.exe set rows=1 cols=2 display=0x80061087 display=0x80061081 res=1920,1080 nextgrid rows=1 cols=1 display=0x80061083 res=1920,1080

1monitor ultrawide
mosaic[monL+monC+monR]
C:\NVIDIA\configureMosaic.exe set rows=1 cols=3 display=0x80061087 display=0x80061081 display=0x80061083 res=1920,1080

Then on the VMware guest, I can use ultramon scripts to split the ultrawide monitor into two or other configurations , or use other utility software which splits ultrawide monitors into pseudo smaller monitors. The latter may be better as some programs will have popup modal windows which centre to the screen.

The first monitor listed in mosaic is the GDI primary monitor which means the Win10 start button will appear there, so Realtime Soft UltraMon handles moving the Windows 10 Start button automatically for me, on the host and in the guest when I change configurations. nVidia mosaic and vmware player make it possible to have a very very varied number of screen configurations which makes it easier to hide from the webbrowsing scripts that fingerprint & track our devices ignoring our default right to privacy.

Anyway thats my workaround, links here:
How to setup MOSAIC using NVIDIA control panel | NVIDIA (custhelp.com)
Mosaic Utility Driver (nvidia.com)
us.download.nvidia.com/Windows/Quadro_Certified/Mosaic-Utility/2.1.3/README.txt
MOSAIC RECOMMENDED CONNECTIONS-v01.pdf (nvidia.com)
If you want to roll your own NVAPI Reference Documentation (nvidia.com)

UltraMon Features - Shortcuts (realtimesoft.com)

PowerToys FancyZones utility for Windows 10 | Microsoft Docs

Quadro View is the upgraded replacement for nVidia nView.
Quadro View Desktop Management Software | NVIDIA
NVIDIA Quadro View Release Highlights

 

YMMV with other graphics cards and manufacturers and some driver hacking in guests, but using VMware Player is another piece of armour in the war to maintain privacy, and multiple online persona's to #AlgoBate

0 Kudos
darksidemaze
Contributor
Contributor

TL;DR after a bit more investigation. 

All on Evaluation Licences.

Player16 3+ monitors, only single monitor use allowed.

Workstation16, 3+ monitors, all monitor layout combo's allowed.

Player16 2 monitors, single or dual monitor use allowed.

Workstation16 2 monitors, single or dual monitor use allowed.

Player16 1 monitor, single used allowed. 

Workstation16 1 monitor, single use allowed.

Bit of an odd one out this. Should I report this as a bug?

0 Kudos
georgebusila
Contributor
Contributor

Yes please! 

0 Kudos
darksidemaze
Contributor
Contributor

How?

Searching for "How to post a bug" returned this, & I cant see any links in the menu above either.

Search - VMware Technology Network VMTN

0 Kudos
Anywho
Contributor
Contributor

Tried workstation pro 16, seems having the same issue, can't handle third monitor.

0 Kudos