Kris3
Contributor
Contributor

not able to share folder/file

New install of Mint 20.1, new install of VMware player 16.1, new install of Win10 21H1(several times).

I did this on a previous build but the windows build was allowed to go to the default location in .local .(that's one of the settings when first setting up a newly installed VMware.)

This time I chose to put it on an external SSD. Would that make a difference?

Before I was able to share an outside folder. On this one I cannot.

I power down windows, click on vm for that windows, edit virtual machine settings / options / shared folders set to always enabled, map as network drive.

But it doesn't show up in windows explorer network.

 

EDIT:started working for some reason.

- ThinkPad T570-20HA, i7-7600U, 2.8GHz, UEFI/GPT, Win10 21H1 Pro x64, also dual boot to Mint 20.1, 16GB, Sammy 256GB M.2 . -
0 Kudos
3 Replies
RaSystemlord
Expert
Expert

You are right that this shared folder thingy is a bit abstract with Linux/VMware. I got similar problems with Kubuntu 20.04 Host. Not sure what got it working ... installing cifs, network tools, checking permissions OR just the complete reboot of the system. Drag&drop does not work anymore either - so, unfortunately you must get this working in order to use the VM for anything useful.

External disk does not matter, but according to my tests RECENT (after 16.04 LTS) *buntu's (and some other Linuxes) do NOT work if a VM is located on NTFS. NTFS works as a data storage as expected, but not for a VM location ... VM is incredibly slow, if ever even starts completely.

 

0 Kudos
Kris3
Contributor
Contributor

"VMware tools"...  at least that's my guess, and a temporary prob at that.

I had just installed 16.1 Player and let it update its tools. I went to install win and got a message that there was an update to tools, "remind me later or apply". G** I just did that!!! Since the win install was going, I said remind me later. did that twice and both times when windows got installed and started and went to desktop it gave me an error message something about an update file missing, and wouldn't share.

the 3rd time I tried to install windows I let it update tools. I forget but I think that particular win install hosed but when I did it over all went well, no win error message, and share worked fine. Go figure.

Yes, target location makes no difference. I've done both external SSD and internal SSD linux local. Speed depends on where you put it - runs okay on a USB3 external Unitek adapter sata3 SSD, but good on a M.2 (which is to be expected).

I did find that fix for it saying there was no display acceleration on Win startup. Easy.

However, though Schwab SSE runs perfectly, NWN2 does not realize when it is running full screen and can't adjust gamma, so, worthless.

So VMware under Mint 20.1 gets 5 stars but NWN2 gets zero. Or at least under 16.1 Player. Or maybe current ver of tools.........

So far... 🙂

- ThinkPad T570-20HA, i7-7600U, 2.8GHz, UEFI/GPT, Win10 21H1 Pro x64, also dual boot to Mint 20.1, 16GB, Sammy 256GB M.2 . -
0 Kudos
RaSystemlord
Expert
Expert

... not really related to the original problem, but just continuing the discussion with topics that you brought up ...

With my tests of NTFS (not working), with *buntu I also meant Mint 20.1. Does not run from NTFS with VMware. I guess the ntfs-drivers are common to many versions of Linux.

Yes, SSD with USB-3 gives a decent performance for anything normal. I also tried with M.2, which is OK, but didn't give much benefit speed-wise. Somebody studying more closely USB-3 versions said that there is no performance gain possible if your USB-3 level isn't high enough (not sure, 3.1 or 3.2 or whatever the recent versions are called).

VMware computer gives a very good performance, in general, if you just have SSD and enough memory, especially if you run several VMs at the same time. Normally, without large/very large datasets (what is large is very relative depending on the industry), it isn't a problem since even better laptops can have 32 GB of RAM.

0 Kudos