mikestevenson
Contributor
Contributor

no connectivity between VMs on host-only network

Jump to solution

I am having trouble getting network connectivity between two Windows 7 VMs using a host-only network in VMware Player.  Each VM is able to get an (unique) IP address via dhcp and can ping both itself and the gateway, but cannot reach the other system.  I watched the VMnet1 adapter on my host in Wireshark and could see icmp packets coming in, but nothing went back out again.  My vmnetdhcp.conf file is unchanged with the exception of adding a line to set the default gateway on my guests.  This was an attempt to fix this problem, and the same behavior was observed before changing anything.  Here are the particulars for that network segment:

subnet 192.168.184.0 netmask 255.255.255.0 {
range 192.168.184.128 192.168.184.254;            # default allows up to 125 VM's
option broadcast-address 192.168.184.255;
option domain-name-servers 192.168.184.1;
option domain-name "localdomain";
option routers 192.168.184.1;  # this is the line I added
default-lease-time 1800;
max-lease-time 7200;
}
host VMnet1 {
    hardware ethernet 00:50:56:C0:00:01;
    fixed-address 192.168.184.1;
    option domain-name-servers 0.0.0.0;
    option domain-name "";
}

Is there some problem with my configuration somewhere, or is this just a limitation of VMware Player? 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

With Windows 7 as the OS you may need to allow ICMP traffic in the Windows Firewall.

André

View solution in original post

0 Kudos
3 Replies
a_p_
Leadership
Leadership

With Windows 7 as the OS you may need to allow ICMP traffic in the Windows Firewall.

André

View solution in original post

0 Kudos
WoodyZ
Immortal
Immortal

option routers is not normally used in a Host Only VMnet and should not have to be used.  As André already mentioned but to be more explicit, by default Windows 7 Firewall does not allow ICMP Echo Requests (ping) so make sure you modify you're Windows 7 Firewall Rules and remove the option routers from the VMnet1 dhcp.conf file and restart the service.

0 Kudos
mikestevenson
Contributor
Contributor

This was definitely the issue.  I didn't realize that icmp traffic was blocked by default.  I could swear I've been able to ping Windows 7 VMs in the past without making any firewall rule changes, but maybe not.  Thanks for pointing me in the right direction.

0 Kudos