eole73
Contributor
Contributor

impossible to delete a VM (says it appears to be in use)

Hello,

I have a VM that I have not used for a while (Ubuntu server) and I wanted to delete the VM from the disk.

However, whenever I select this VM in the VM Workstation interface menu listing the VMs, I have a message saying that the VM appears to be in use. When I select "Take Ownership", I have a error message saying that it failed  and that the VM is in use by an application on my host computer. I have check with the task manager but I don't find any application relative to that VM running.

The last message also gives the path of the configuration file of this VM.
So by now I can not do anything with this VM nor delete it. Any idea how to solve this problem? Is there anything to do in the configuration file of the VM?

I'm running workstation 16.2.2 on windows 11 host, but I have used this VM a few months ago without much problems (at least never encountered this one with any VM I have created and worked with in the past)

Thanks

0 Kudos
2 Replies
fabio1975
Expert
Expert

Ciao 

Did you follow this KB to check if the VM is active?

Investigating if a hosted virtual machine is powered on (1003844) (vmware.com)

0 Kudos
eole73
Contributor
Contributor

Hello Fabio,

Thanks for your answer and the link. I read the tutorial and I was about to check on my computer but yesterday when I launched vmware worstation the problem was not present anymore. I don't understand why as I have previously tried to reboot my computer but the problem was still there even after rebooting. I didn't change anything and lastly the problem disappeared! So I was finally able to delete the vm. 🙂

0 Kudos