TS02
Contributor
Contributor

Virtualized Intel VT-x/EPT Error

Jump to solution
Hi there.
 
I wondered if someone could help me.
 
I am trying to create a CentOS VM using VMware Workstation 16 Player, but when I try to power on the VM, I get an error message - 'Attached'
 

'Virtualized Intel VT-x/EPT is not supported on this platform. Continue without virtualized Intel VT-x/EPT'

If possible, please could you help me as this VM was working perfectly fine a few months ago.
 
Kind Regards,
 
Tamoor
 
Image
 
Labels (1)
0 Kudos
1 Solution

Accepted Solutions
ender_
Enthusiast
Enthusiast

If you're not planning to run nested VMs (VMs inside your VMWare VM), just disable the "Virtualize Intel VT-x/EPT or AMD-V/RVI" checkbox in VM Settings→CPU, and the message will go away; if you do plan to run nested VMs, you will have to disable Hyper-V on the host.

View solution in original post

13 Replies
ender_
Enthusiast
Enthusiast

If you're not planning to run nested VMs (VMs inside your VMWare VM), just disable the "Virtualize Intel VT-x/EPT or AMD-V/RVI" checkbox in VM Settings→CPU, and the message will go away; if you do plan to run nested VMs, you will have to disable Hyper-V on the host.

View solution in original post

TS02
Contributor
Contributor

Hi ender_,

I received this message too. Is this because I have Hyper V enabled?

TS02_1-1609251965171.png

Also, I was reading some info online and apparently VMware and Microsoft worked together in order to allow users to use VMware Workstation Player when Hyper-V was enabled.

Surely, I shouldn't be having these issues since I am using both: VMware Workstation 16 Player and am running Windows 10 20H2.

Link to Blog -> https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

Regards,

Tamoor

0 Kudos
ender_
Enthusiast
Enthusiast

Which Windows version do you have? VMWare supports Hyper-V API on Windows 10 2004 and newer only.

0 Kudos
TS02
Contributor
Contributor

I am using Windows 10 Pro

0 Kudos
ender_
Enthusiast
Enthusiast

There are currently 11 major versions of Windows 10 Pro (3 of which are supported) - right-click the Start button, select Run from the menu and run winver, that will tell you the exact version you're running.

ender__0-1609275400605.png

The part in red is your Windows 10 version - if it's 1909 or older, VMWare won't work if Hyper-V is enabled.

0 Kudos
TS02
Contributor
Contributor

Hi ender_,

This is the current version that my system is running.

TS02_0-1609276888133.png

 

0 Kudos
ender_
Enthusiast
Enthusiast

OK, this is new enough to support Hyper-V. I missed nested virtualization part of the error in your first image - disable that in the VM settings, and it should work.

0 Kudos
TS02
Contributor
Contributor

But, I am intending to use 3 other VM's within my main VM. So I can't do that.

0 Kudos
ender_
Enthusiast
Enthusiast

If you want to do nested virtualization, you will have to disable Hyper-V on the host - follow the link in my first message. Hyper-V API currently doesn't support nested virt, so you can have one or the other.

0 Kudos
TS02
Contributor
Contributor

I see. I'll follow the steps you gave earlier tomorrow morning and let you know how I get on.

Thanks for the help so far ender_

0 Kudos
jmjohnson85
Contributor
Contributor

Just want to add that for me running this command:

bcdedit /set hypervisorlaunchtype off

resolved the nested virtualization issue for me (required a reboot to take affect though). Of course I can no longer use WSL2/Docker/etc.. on the host machine until I revert the setting back to 'auto'.

0 Kudos
TS02
Contributor
Contributor

Hi ender_,

Sorry for no updates. I followed the instructions you sent and my VM seems to be working okay. If anything goes wrong I'll be sure to post something on the community page.

Thank you once again.

Take care and Happy New Year!

0 Kudos
hunk1989
Contributor
Contributor

Please check my tutorial to resolve this issue which i have in this page

 

https://communities.vmware.com/t5/Nested-Virtualization/Virtualization-Intel-VT-xEPT-it-not-supporte...

0 Kudos