Contributor
Contributor

VMware player + modem

Jump to solution

Well i have googled allot on this subject and i know by now that onboard modems are a tough cookie for VMware player. But I'd like to ask anyway cause maybe there is a solution.

I got an onboard modem (Agere Systems HDA modem) Wich is installed propperly on my win 7 machine. I installed VMware player with an XP os. but no modem to be found. this is a classic problem and if I didn't know better I would give up cause all the answers I found where dissapointing.

Now when i check out the device manager and click on the modem i see it uses 'COM5' so this gave me a spark of hope. I added this com port to the VM settings, but I'm still not sure what to do next cause i can't install the drivers.

Any input would be more than welcome.

Kind regards

Patrick

0 Kudos
1 Solution

Accepted Solutions
Hot Shot
Hot Shot

Installing drivers may not be necessary, and it probaly won't work to install the drivers in the VM anyway. The modem isn't being presented to the VM, only a Com port. Hopefully you are using an application in the VM that can speak to the serial port and does not need driver specific functions.

So the host is using the modem on Com5, but the VM is probably using Com1 as it only has one serial device installed, at least that is my guess.

View solution in original post

0 Kudos
1 Reply
Hot Shot
Hot Shot

Installing drivers may not be necessary, and it probaly won't work to install the drivers in the VM anyway. The modem isn't being presented to the VM, only a Com port. Hopefully you are using an application in the VM that can speak to the serial port and does not need driver specific functions.

So the host is using the modem on Com5, but the VM is probably using Com1 as it only has one serial device installed, at least that is my guess.

View solution in original post

0 Kudos